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8. ABOVEGROUND NET PRIMARY PRODUCTIVITY 
ESTIMATION OF PAMPA GRASSLANDS USING 
MODIS AND GOES DATA 

By: Piedad M. Cristiano1, María Eugenia Beget2, Carlos Di Bella12, Gabriela Posse2 and Tomás 
Hartmann2 

8.1. Relevance of the application 

The Primary Productivity (PP) of ecosystems is the key variable that defines the carbon input of an ecosystem. 
Particularly in areas with an extensive livestock production, where pastures and grasslands are the main forage 
resources that sustain cattle production, accurate estimations of Aboveground Net Primary Productivity (ANPP) are 
considered an elemental necessity to adjust grazing pressure and improve sustainable management. ANPP maps will 
be generated on a monthly basis and can be supplied to farmers, cooperative associations and government decision 
makers to be used as a tool for optimal development of their activities. 

8.2. Objective of the application 

In order to provide a useful tool in the calculation of feed balances for fields of the Pampas Region, the overall 
objective of this exercise is to generate the Aboveground Net Primary Productivity (ANPP) map using the efficiency 
model as proposed by Kumar and Monteith (1982). Particular objective of this exercise is furthermore to compute 
the annual ANPP for 2007. 

8.3. Methodology 

Regional ANPP is estimated applying the efficiency model as proposed by Kumar and Monteith (1982) and monthly 
as well as an annual ANPP map for the Pampas Region in Argentina will be generated. A graphical representation of 
the methodology is given in figure 8.1. The model linearly relates the ANPP to the photosynthetically active radiation 
(PAR) absorbed by vegetation (APAR) and the plant radiation use efficiency (RUE) which is the energy conversion 
coefficient of absorbed radiation into aboveground biomass. The model can be expressed as ANPP = RUE * APAR 
(Kumar and Monteith, 1982). APAR can be calculated by multiplying the fraction of PAR intercepted by vegetation 
(fPAR) by the incoming PAR. This model has the advantage of using spectral information provided by remote 
sensing, such as the NDVI index, to estimate the fPAR.  
A thematic map of the RUE was created reflecting the environmental conditions (water and nutrient availability) in 
the region. This map is used to estimate the regional ANPP in conjunction with the efficiency model.  
The study area includes 3 provinces belonging to the Pampas Region of Argentina: Buenos Aires, Entre Rios and 
South of Santa Fe (see figure 8.2). This region is characterized by a vast plain of grasses but is intensively modified by 

humans. Main activities in the region are agriculture and livestock production. The highest rainfall is recorded during 
the spring-summer season and its intensity decreases from east to west, with an overall mean annual precipitation of 
900 mm. The mean annual temperature is 15ºC with a mean monthly temperature ranging from 7°C during the 
winter season to 21°C in summer. Because of the seasonality of water conditions, the RUE map was separated in a 
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dry season RUE (autumn-winter) and wet season RUE (spring-summer). Nutrient availability for the RUE maps was 
derived from the soil types given by the Soil Atlas of Argentina (Soil Institute of CIRN/INTA et al, 1995). 
 

 
Figure 8.1 Flow chart of the followed methodology 
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Figure 8.2 Study area located in the Pampas Region 

8.4. Data processing and analysis  

8.4.1. Introduction 

Ensure that you have unzipped the exercise data and move using the ILWIS navigator to this active working 

directory. Once close ILWIS and Open ILWIS again to ensure that the directory settings are correct. You will not 
see any files in the ILWIS catalogue as all data still needs to be imported. You can use the Windows Explorer to 
check the data available. All data is in TIF format. Regional data needed to conduct the exercise are:  
 

 monthly NDVI (ndvi_mmmyys), where m is month, y is year and s indicates that a submap is used;  
 monthly PAR (par_mmmyy);  
 bi-seasonal RUE maps (rue_ss), where s is season (spring-summer or autumn-winter). 

 
NDVI images used were obtained from the MODIS sensor (Moderate Resolution Imaging Spectroradiometer), on 
board the TERRA satellite (NASA). A submap was created using two tiles covering the region (v 12 h 12 and 13). 
The data was received by the HRPT station operated by INTA. Spatial resolution of these images is 250 x 250 m, 
having a temporal resolution of 16 days. Maximum NDVI was selected from the two biweekly images available for 
each month in order to avoid the degrading effects mainly caused by the atmosphere. 
PAR maps were generated from the average daily global radiation product (W/m2) for each month produced by the 
National Institute for Space Research of Brazil (INPE). This product is based on images from the geostationary 

satellite Geostationary Observational Environmental Satellite-8 and 12 (GOES) which has a spatial resolution of 16 
km2 and temporal resolution of 8 days. These values were converted to MJ/m2 and accumulated for each month of 
the year 2007. To convert the global radiation to PAR, values were multiplied by a factor of 0.47, according to Akmal 
& Jansen (2004). A median filter using a 7x7 matrix was applied to blur the edge effects of these maps. 
The RUE was spatialized according to the stress factors (water and nitrogen) due to the environmental conditions in 
spring and summer months from October to December while the months from April to September was used for 
autumn-winter. A RUE value of 0.48 was taken from literature (Paruelo et al. 1997, Clavijo et al. 2007) which is 
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regarded the optimal value for grasslands. In each environmental condition, a reduction rate was applied to the RUE 
according to different treatments as is established by Cristiano et al. (in press, 2011). 

8.4.2. Data pre-processing 

8.4.2.1. Data import into ILWIS 

Conversion to ILWIS format and resampling of PAR and RUE maps has to be performed before the actual data 
analysis can be done. To convert TIFF format to ILWIS format, a data translation library, called GDAL is going to 
be executed from the DOS Command Line prompt. The executable “gdal_translate.exe” is situated in the main 
ILWIS directory.  
To open the DOS Command Window, select the option “Run” from the Windows Start button and type “Cmd” and 
press “OK”. The command line expression window is opened. Change the directory to your active working directory 
typing: “cd C:\chapter8” (see also figure 8.3). Note that the drive or path could be different if you have copied the 
exercise data into another directory. 

Figure 8.3 MS DOS command line window 
To import a layer into ILWIS format (step 1 of the flow chart of figure 8.1) use the general syntax command: 
 

GDAL_translate.exe –of ILWIS inputfile outputfile 
 

Where: “-of ILWIS” specifies that the output raster format should be ILWIS; “inputfile” is the TIF file to be 
imported and “outputfile” is the raster destination file in ILWIS format. 
 
Import the following layer typing the expressions below in the command line (note the location of the ILWIS and 
the exercise working directory on your system, in this case ILWIS is installed in “C:\ILWIS” and the working 
directory is “C:\chapter8”) and press enter to execute the operation: 
 

C:\ILWIS\gdal_translate.exe -of ILWIS C:\chapter8\ndvi_0107s.tif C:\chapter8\ndvi_0107.mpr 

 
To display the imported NDVI map double click on the newly created file “ndvi_0107” and use as Representation 
“NDVI1” and press “Show”. Inspect the values of the map using the left mouse button pressed while moving the 
cursor over the map. 
Use your Windows Explorer and check the content of the directory once more. You will note another file, called 
“import.bat”. Right click with the mouse on the file “import.bat”, select “Edit” from the context sensitive menu and 
the file content can be displayed using NotePad or WordPad. Check the content. You will note that for each map 
layer an import syntax line has been provided in this batch file, similar as the one you typed in the command line 
window. Furthermore note that you might have to edit each line if the locations of your local ILWIS and Working 
directories are different. You can use from the Notepad menu the options “Edit”, “Replace” and provide the 

appropriate directory settings. When this is done save the file, double click it with the mouse and the import will be 
executed using this batch file. Wait until the import is completed and from the main ILWIS menu, select “Window 
=> Refresh”. Note that the newly imported maps should now be shown in the ILWIS catalog.  Display an example 
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from the NDVI, RUE and PAR maps, using for the NDV map the Representation “NDVI1 and for the other maps 
the “Pseudo” Representation can be used. 

8.4.2.2. Further RUE and PAR pre-processing 

In order not to have an exercise dataset that has a large file size volume a subset of the NDVI map is used here. So 

step 2 in the flowchart of figure 8.1 can be omitted here. If we want to calculate in ILWIS using different maps, they 
have to have the same row and column dimensions. Here the RUE and PAR maps have different dimensions and 
therefore need to be resampled to fit the NDVI map.  
Right click with the mouse the input map “rue_sprsum”, from the context sensitive menu select the options “Spatial 
Reference Operations => Resample”. Select “Nearest Neighbour” as Resampling Method and as output raster map 
name specify “rue_sprsumr”. As Georeference the one from the January NDVI map has to be selected: 
“ndvi_0107”. Press “Show” to execute the operation. Display the resulting map “rue_sprsumr” using a “Pseudo” 
Representation. From the active map window menu, select the option “Layer => Add Layer” and select now the 
“NDVI_0107” map. In the Raster Map Display Options check the box “Transparent” and a transparency of 50 % 
can be used, press “OK”. Now the two maps can be displayed using a single window as the map dimensions and 
coordinate system are identical. Close the map view and repeat the procedure for the map “rue_autwin”, using the 
same resampling method (“Nearest Neighour”) and georeference (“NDVI_0107”), as output map name 
specify”rue_autwinr”. Display and check your resulting map. 
In a similar manner also the PAR monthly maps need to be resampled. Right click with the mouse the input map 
“par_0107”, from the context sensitive menu select the options “Spatial Reference Operations => Resample”. Select 
“Nearest Neighbour” as Resampling Method and as output raster map name specify “par_0107r”. As Georeference 
the one from the January NDVI map has to be selected: “ndvi_0107”. As data value range specify “-100” and 
“1000” as minimum and maximum respectively, the Precision can be kept default. Press “Show” to execute the 
operation. Have a look at the map and then close the map window.  
As this operation has to be repeated another 11 times, use the command line history. From the main ILIWS menu, 
select the command line history drop down button at the right hand side for the command line. Select the string that 

has resulted in the previously conducted resampling of the PAR map. This string is given below: 
  

par_0107r.mpr{dom=value.dom;vr=-100:1000} = MapResample(par_0107,ndvi_0107.grf,nearest) 
 

Modify the string as follows and press enter to execute a new resampling procedure for the February PAR map: 
  

par_0207r.mpr{dom=value.dom;vr=-100:1000}:=MapResample(par_0207,ndvi_0107.grf,nearest) 
 

Repeat the procedure as described above to resample the remaining PAR maps. By the end of this all PAR and RUE 
maps have been resampled and can be used in conjunction with the NDVI maps of 2007. See also figure 8.4. 

Figure 8.4 NDVI_0107 submap and resampled RUE_sprsumr and PAR_0107r maps 

8.4.3. Data analysis 

Intercepted fraction of PAR (fPAR) computation (step 5 in the flowchart of figure 8.1) will be calculated here 
according to the procedure proposed by Potter et al. (1993), indicated in equation 1. 
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(Eq. 1) 
 

To calculate the fpar map on a monthly basis a new map list has to be created. From the main ILWIS menu, select 

“File => Create => MapList” and add all “NDVI_*” maps in a sequential order to the right hand listing, using the 
“>” icon. Specify as Map List name “NDVI_07” and press “OK”. Display the newly created map list “NDVI_07” 
as an animated sequence, using as Representation “NDVI1”, check the map values obtained. 
 
Open from the main ILWIS menu the option “Operations => Raster Operations => MapList Calculation”. Specify 
the settings as indicated in figure 8.5 and press “Show” to execute the operation. Display the newly created map list 
“fpar” as an animated sequence, using as Representation “fapar”, check the map values obtained. 

Figure 8.5 fPar calculations for the whole NDVI maplist 
 
fPAR data range should be between (0-0.95) accordingly to Potter et al. (1993). For that reason the initial fPAR maps 
obtained should be corrected using the following conditions: if fPAR ≤ 0, fPAR=0 and if fPAR ≥0.95, fPAR=0.95. 
To correct the fPAR maps select from the main ILWIS menu the option “Operations => Raster Operations => 
MapList Calculation”. Specify the settings as indicated in figure 8.6 and press “Show” to execute the operation.   

Figure 8.6 MapList calculations to correct the fPAr 
 
The next step is to calculate the Absorbed PAR or APAR (see also step 8 in the flowchart of figure 8.1) by 
multiplying the fPAR monthly maps by the corresponding PAR monthly maps. To do this first create a new maplist 
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using the resampled monthly PAR maps. From the main ILWIS menu, select “File => Create => MapList” and add 
all resampled “PAR_*r” maps in a sequential order to the right hand listing, using the “>” icon. Specify as Map List 
name “PAR_07” and press “OK”. Display the newly created map list “PAR_07” as an animated sequence, using as 

Representation “Pseudo”, check the map values obtained. 
Open from the main ILWIS menu the option “Operations => Raster Operations => MapList Calculation”. Specify 
the settings as indicated in figure 8.7 and press “Show” to execute the operation. Display the newly created map list 
“apar” as an animated sequence, using as Representation “Pseudo”, check the map values obtained. 
 

Figure 8.7 Maplist calculations to obtain the APAR and the resulting map for January 2007 
 
The next step is to calculate the monthly ANPP (e.g. for January 2007, see also step 9 in flowchart of figure 8.1) by 
multiplying the APAR map by the corresponding season RUE map. Note that you have to choose the right RUE 
map regarding the season corresponding to each month. Choose “rue_sprsumr” to compute ANPP from October to 
March and “rue_autwinr” for the April to September period.  
As these calculations have to be repeated for all the months create a script and run it from the ILWIS command line. 
To create a script, select from the main ILWIS menu the options “File => Create => Script”. Select the “Script” tab 
in the script editor and type the content as indicated in figure 8.8 (left). Note that the first line is just a comment; the 
second line is defining the calculation that should be performed. Here three parameters are used, presented by %1 up 
to %3. Open the “Parameters” tab to further define the input and output maps that are going to be used. Provide the 
content as indicated in figure 8.8 (right). When completed select the “Save” Icon from the menu and save the script 
as: “ANPP_Calc”. To run the script press the “>” icon from the menu and provide the relevant input and output 
map information, details for the month of January are presented in figure 8.9. Press “OK” to run the script. 
 

Figure 8.8 Prepare ILWIS script to calculate the monthly ANPP 
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Figure 8.9 ILWIS Script parameter definition for ANPP calculation 

 
When the calculation has finished open the newly created ANPP map, here called “anpp_1” using as Representation 
“Pseudo”. Your results should resemble those of figure 8.10. 

Figure 8.10 ANPP map calculated for the month of January 2007 
 
As this operation has to be repeated another 11 times, use the command line history. From the main ILIWS menu, 
select the command line history drop down button at the right hand side for the command line string that has 
resulted in the previously conducted run of the script. This string is also given below: 
 
 Run ANPP_calc apar_1 rue_sprsumr “anpp_01” 
 
Modify the string as follows and press enter to execute a new script run to create the February ANPP map: 
  

Run ANPP_calc apar_2 rue_sprsumr “anpp_02” 
 
Repeat the procedure as described above to calculate the remaining monthly ANPP maps. Once more note that for 
the months of October to March the “rue_sprsumr” is used to compute the ANPP and from April to September the 
“rue_autwinr” should be used. 
Once you have calculated all monthly ANPP maps, these have to be integrated into the annual ANPP (step 10 in the 
flow chart of figure 8.1). To calculate the ANPP_2007 map a new map list can be created. From the main ILWIS 
menu, select “File => Create => MapList” and add all “ANPP_*” maps in a sequential order to the right hand 
listing, using the “>” icon. Specify as Map List name “ANPP_2007” and press “OK”. Display the newly created map 
list “ANPP_2007” as an animated sequence, using as Representation “Pseudo”, check the map values obtained. 

Close the map display if you have seen the animated sequence. Right click with the mouse the maplist 
“ANPP_2007”, from the context sensitive menu select the options “Statistics => MapList Statistics”, use as 
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Statistical Function “Sum” and specify as Output Raster Map “anpp_sum”, press show to execute the operation. 
When the calculation has finished, open the newly created anpp_sum map, which shows you the annual ANPP in 
kg/ha for 2007. Use as Representation “Pseudo”. You can add a layer with country boundary information onto this 

final map. To do so, select from the active map window the options “Layer => Add Layer” and browse to your 
ILWIS directory, select the sub directory: Extensions\Geonetcast-Toolbox\util\maps and from there select the 
vector layer “country_02” and press “OK”, unselect the option “Info” and select the option “Boundaries Only” and 
press “OK”. Move the mouse, with the left mouse button pressed, over the map and note the values obtained. Your 
results should resemble those of figure 8.11. 

Figure 8.11 Final ANPP map for 2007 

8.5. Conclusions 

A methodology to compute monthly ANPP in the Pampa Region from NDVI and PAR data was presented. The 
methodology is based on the efficiency model using bi-seasonal RUE maps.  

A validation was previously performed comparing with ANPP obtained with the traditional model of Kumar & 
Monteith (1982) that uses a fixed RUE value (in this case, 0.48 g/MJ). Both models were validated against three sets 
of data using simple linear regression using the coefficients of determination (R2) and slopes for all comparisons. The 
three independent set data were: field ANPP estimations, ANPP estimated with a rainfall model (Sala et al. 1988) and 
ANPP estimations from CASA model (Imhoff et al. 2004). For more details see Cristiano et al. (2011). Both 
methods (variable RUE and fixed RUE) presented a low level of adjustment comparing with productivity observed 
in the field (R2= 0.25 and 0.30, respectively). This might be due because the sites used are having the same 
environmental conditions. When we used data covering all environmental conditions (ANPP obtained by the rainfall 
and CASA models), the adjustment level increased significantly and the R2 was greater in the variable RUE model 
than in the fixed RUE model. This indicates that a few number of field ANPP sites did not reflect the variability in 
the environmental conditions required for a proper validation. We believe it is necessary to perform a proper 
validation of the model using more field ANPP data covering the full range of environmental conditions studied.  
Here use is made of the NDVI obtained from the MODIS TERRA instrument. Currently in the GEONETCast-
DevCoCast data stream also NDVI products are available, like the decadal NDVI derived from the SPOT 
Vegetation instrument, or the daily NDVI derived from the SEVIRI-instrument onboard Meteosat Second 

Generation. This is a new daily product that is generated by the Meteorological Product Extraction Facility. All of 
these products can be easily incorporated in your analysis using the import routines available from the 
GEONETCast toolbox. 
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