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8.1 Importancia de la aplicación 
 
La productividad primaria (PP) de los ecosistemas es una variable clave que define las 

entradas de carbono al sistema. Particularmente en áreas de producción ganadera extensiva, 
donde las pasturas y los pastizales constituyen la principal fuente de recursos forrajeros que 
sustentan la producción, estimaciones precisas de la productividad primaria neta aérea (ANPP) 
son representan una herramienta esencial para ajustar la demanda forrajera y mejorar el 
manejo sustentable. Se generarán mapas mensuales de ANPP destinados a productores 
ganaderos, asociaciones cooperativas y decisores gubernamentales para ser utilizados como 
una herramienta para optimizar el desarrollo de sus actividades. 

 
8.2 Objetivos de la aplicación 
 
De manera de proveer una herramienta útil para el cálculo del balance forrajero para 

establecimientos de un área de la Región Pampeana, el objetivo general es generar un mapa 
de ANPP utilizando el modelo de eficiencias propuesto por Kumar y Monteith (1982). El 
objetivo particular del ejercicio es calcular la ANPP para el año 2007. 

 
8.3 Metodología 
 
La ANPP regional es calculada aplicando el modelo de eficiencia propuesto por Kumar y 

Monteith (1982), y se generarán mapas de un área de la Región Pampeana, mensual y anual 
para el año 2007. La metodología se encuentra representada en la figura 8.1. El modelo 
relaciona linealmente la ANPP con la radiación fotosintéticamente activa (PAR) absorbida por 
la vegetación (APAR) y la eficiencia del uso de la radiación (RUE), la cual es el coeficiente de 
conversión de la radiación absorbida en biomasa aérea. El modelo puede expresarse como: 
ANPP = RUE * APAR (Kumar y Monteith, 1982). La APAR puede calcularse multiplicando la 
fracción de PAR interceptada por la vegetación (fPAR) por la PAR incidente. El modelo tiene 
como ventaja la utilización de información espectral provista por sensores remotos, como el 
índice NDVI para estimar la fPAR. 

Un mapa de RUE fue previamente creado de manera de representar distintas condiciones 
ambientales de disponibilidad de agua y nutrientes en la región. Este mapa es utilizado para la 
estimación regional de la ANPP junto con información derivada de sensores remotos. 

El área de estudio incluye parte de tres provincias Argentinas pertenecientes a la Región 
Pampeana: norte de Buenos Aires, sur de Entre Ríos y sur de Santa Fe (ver figura 8.2). Esta 
región es caracterizada por vegetación de pastizal intensamente modificada por la actividad 
agrícola y ganadera. La mayores precipitaciones se registran en los meses de primavera-verano 
y su intensidad decrece de este a oeste, con una media de 900 mm. La temperatura media 
anual es 15ºC con una media mensual ente 7ºC en invierno y 21ºC en verano. Debido a la 
estacionalidad en las condiciones hídricas el mapa de RU fue generado para cada estación, la 
estación seca (otoño-invierno) y la estación húmeda (primavera-verano). La disponibilidad de 
nutrientes considerada en el mapa de RUE fue derivada del Atlas de Suelos (INTA, 1995). 
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Figura 8.1: Esquema de la metodología aplicada. 
 



 

 
Figura 8.2: Área de estudio localizada en la Región Pampeana. 
 
8.4 Procesamiento y análisis 
 
8.4.1 Introducción 
 
En primer lugar, asegúrese de descomprimir los datos del ejercicio y diríjase al directorio de 

trabajo utilizando el navegador de ILWIS. Cierre ILWIS y ábralo nuevamente para asegurarse 
que el directorio de trabajo es el correcto. No verá aún ningún archivo en el catálogo de ILWIS 
debido a que los datos no han sido importados. Puede utilizar el Explorador de Windows para 
verificar los datos disponibles. Todos los datos se encuentran en formato TIFF. Los datos 
necesarios para llevar a cabo el ejercicio son: 

• NDVI mensual (ndvi_mmmyys), donde m es el mes, y el año y s indica que un 
submapa es utilizado; 
• PAR mensual (par_mmmyy); 
• Mapas bi-estacionales de RUE (rue_ss), donde s es la estación (primavera-

verano u otoño-invierno). 
Las imágenes de NDVI han sido provistas por el sensor MODIS (Moderate Resolution Imaging 

Spectroradiometer) a bordo del satélite Terra (NASA). Un submapa fue creado utilizado dos 
imágenes que cubren la región de estudio (h12v12 y h12v13). Las imágenes fueron 
recepcionadas por la estación HRPT operada por el INTA. La resolución espacial de las 
imágenes es de 250 x 250 m y la resolución temporal de 16 días. El máximo NDVI fue 
seleccionado de las imágenes bisemanales disponibles para cada mes, de manera de descartar 
los efectos causados por la atmósfera. 

Los mapas de PAR fueron generados a partir del producto mensual de radiación global media 
diaria (W/m2) provisto por el Instituto Nacional de Investigaciones Espaciales de Brasil (INPE). 
El producto está basado en imágenes del satélite GOES (Geostationary Observational 
Environmental Satellite-8 y 12) de 16 km2 de resolución espacial y 8 días de resolución 
temporal. Estos valores fueron convertidos a MJ/m2 y acumulados mensualmente para los 



meses de 2007. Para convertir la radiación global a PAR se utilizó un factor de 0.47, presentado 
por Akmal y Jansen (2004). Se aplicó un filtro de madiana usando una matriz de 7x7 para 
difuminar los bordes del mapa. 

La RUE fue especializada de acuerdo a los factores de estrés hídrico y nitrogenado 
considerando las condiciones ambientales en primavera y verano para los meses de octubre a 
diciembre, mientras que los meses de abril a septiembre fue considerado para el período de 
otoño e invierno. El valor de RUE=0.48 fue considerado como óptimo (Paruelo et al. 1997, 
Clavijo et al. 2007) y en cada condición ambiental se aplicó una reducción en la RUE de 
acuerdo a lo establecido por Cristiano et al. (en prensa, 2011). 

 
8.4.2 Pre-procesamiento de los datos 
 
8.4.2.1 Importación de los datos a ILWIS 
 
Previo al procesamiento de los datos, es necesario convertir los datos a formato ILWIS y 

remuestrear las imágenes de PAR y RUE. Para convertir el formato TIFF a formato ILWIS, se 
debe ejecutar la librería de traducción GDAL desde la línea de comandos de la ventana DOS. El 
archivo ejecutable “gdal_translate.exe” está ubicado en el directorio principal de ILWIS. 

Para abrir la ventana de comandos de DOS, selecciones la opción “Ejecutar” desde el menú 
de Inicio de Windows tipeando “cmd” y presionando “ok”. Una vez abierta la ventana de 
comandos, cambio el directorio al directorio de trabajo tipeando “cd C:\chapter8” (ver figura 
8.3). Tenga en cuenta que el camino puede ser diferente si usted copió los datos del ejercicio a 
otro directorio. 

 

 
Figura 8.3: Ventana de comandos de MS DOS. 
 
Para importar la capa o imagen al formato ILWIS (paso 1 del esquema de la figura 8.1) utilice 

la sintaxis del comando general: 
 
GDAL_translate.exe –of ILWIS inputfile outputfile 
 
donde “-of ILWIS” especifica el formato de salida de la imagen como ILWIS; “inputfile” es el 

archivo TIF a importar y “outputfile” es el destino del archivo en formato ILWIS. 
 
Importe la imagen siguiente tipeando la expresión anterior en la línea de comando (note la 

ubicación de ILWIS y del directorio del ejercicio en su sistema. En este caso ILWIS está 
instalado en “C:\ILWIS” y el directorio de trabajo es “C:\chapter8”) y presione “Enter” to 
ejecutar la operación: 

 
C:\ILWIS\gdal_translate.exe -of ILWIS C:\chapter8\ndvi_0107s.tif 

C:\chapter8\ndvi_0107.mpr 
 



Para desplegar la imagen de NDVI importada haga doble click sobre el archivo creado 
“ndvi_0107” usando la Representación “NDVI1” y presione “Show”. Examine los valores del 
mapa usando el botón izquierdo del ratón presionado mientras mueve el cursor sobre el 
mapa. 

 
Utilice su Explorador de Windows y revise el contenido del directorio una vez más. Notará un 

archivo llamado “import.bat”. Con el botón derecho sobre éste archivo seleccione “Edit” del 
menú contextual para desplegar el contenido del archivo en NotePad o WordPad. Revise el 
contenido. Notará que para cada mapa se ha generado una línea de sintaxis, similar a la que 
usted tipeó en la ventana de línea de comandos. Además notará que usted debería editar cada 
línea si la ubicación de ILWIS y el directorio de trabajo son diferentes. Puede usar 
“Reemplazar” del menú “Edición” y proveer el directorio apropieado. Una vez realizado guarde 
el archivo, haga doble click con el ratón y la importación será ejecutada usando este archivo 
“import.bat”. Una vez completada la importación, seleccione “Window => Refresh” desde el 
menu principal de ILWIS. Note que se muestran los nuevos mapas importados en el catálogo 
de ILWIS. Despliegue un ejemplo de mapa de NDVI, RU y PAR, utilizando la representación 
“NDVI1” para el NDVI y “Pseudo” para los otros mapas. 

 
8.4.2.2 Pre-procesamiento de mapas de RUE y PAR 
 
De manera de no realizar el ejercicio con un conjunto de datos demasiado grande se utilizará 

un recorte de los mapas de NDVI. De esta manera, el paso 2 del esquema de la figura 8.1 
puede ser omitido. Si queremos calcular in ILWIS utilizando mapas diferentes, éstos deben 
tener la misma cantidad de filas y columnas. En este caso los mapas de RUE y PAR tienen 
diferentes dimensiones, por lo tanto requieren ser remuestreados al tamaño del mapa de 
NDVI. 

Haciendo doble click sobre el mapa de entrada “rue_sprsum”, seleccione la opción “Spatial 
Reference Operations => Resample” del menú contextual. Seleccione “Nearest Neighbour” 
como método de remuestreo y especifique “rue_sprsumr” como nombre del mapa de salida. 
Seleccione el mapa de enero “ndvi_0107” como referencia (Georeference). Presione “Show” 
para ejecutar la operación- Despliegue el mapa resultante usando la representación “Pseudo”. 
Desde el menú del mapa activo, seleccione la opción “Layer => Add Layer” y el mapa 
“NDVI_0107”. En Raster Map Display Options marque “Transparent” usando una transparencia 
del 50% y presione “Ok”. Ahora, los dos mapas pueden ser desplegados en una misma ventana 
ya que las dimensiones y el sistema de coordenadas de ambos son idénticos. Cierre el visor del 
mapa y repita el procedimiento para el mapa “rue_autwin” utilizando el mismo método de 
remuestreo (“Nearest Neighour”) y georreferencia (“NDVI_0107”). Especifique como nombre 
de salida “rue_autwinr”, despliegue y revise el mapa resultante. 

De manera similar necesitan ser remuestreados los mapas de PAR. Haga doble click sobre el 
mapa de entrada “par_0107”, seleccionado “Spatial Reference Operations => Resample” del 
menú contextual. Seleccione “Nearest Neighbour” como método de remuestreo y especifique 
“par_0107r” como nombre de salida del mapa. Seleccione el mapa de enero “ndvi_0107” 
como referencia (Georeference). Como rango de valores especifique “-100” y 

“1000” como mínimo y máximo respectivamente, la precisión debe ser la que está por 
defecto. Presiones “Show” para ejecutar la operación. Revise el mapa y luego cierre la 
ventana. 

Como esta operación debe repetirse 11 veces, utilice la historia de la línea de comandos. 
Desde el menú principal de ILWIS, seleccione la línea de comandos utilizando la flecha hacia 
abajo. Seleccione la línea resultante en el paso anterior de remuestreo del mapa de PAR: 

 
par_0107r.mpr{dom=value.dom;vr=-100:1000} =MapResample(par_0107,ndvi_0107.grf,nearest) 
 



Modifique la línea como sigue y presione “Enter” para ejecutar un nuevo procedimiento de 
remuestreo para el mapa de PAR de febrero: 

 
par_0207r.mpr{dom=value.dom;vr=-100:1000}:=MapResample(par_0207,ndvi_0107.grf,nearest) 

 
Repita el procedimiento descripto arriba para remuestrear los mapas de PAR restantes. Al 

finalizar, todos los mapas de PAR y RUE han sido remuestreados y pueden ser utilizados en 
conjunto con los mapas de NDVI del año 2007 (ver figura 8.4). 

 

 
Figura 8.4: Recorte del mapa NDVI_0107 y remuestreo de los mapas RUE_sprsumr y 

PAR_0107r 
 
8.4.3 Análisis de los datos 
 
El cálculo de la fracción de PAR interceptada (fPAR, paso 5 en el esquema de la figura 8.1) 

será realizado de acuerdo al procedimiento propuesto por Potter et al. (1993) indicado en la 
ecuación 1. 
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Para calcular el mapa de fPAR en base mensual una nueva lista de mapa debe ser creada. 

Desde el menú principal de ILWIS seleccione “File => Create => MapList” y agregue todos los 
mapas “NDVI_*” en orden secuencial hacia la lista de la derecha utilizando el ícono “>”. 
Especifique como nombre la lista en Map List: “NDVI_07” y presione “Ok”. Despliegue la lista 
de mapa creada en una secuencia animada utilizando “NDVI1” como representación y revise 
los valores del mapa obtenido. 

Desde el menú principal de ILWIS seleccione “Operations => Raster Operations => MapList 
Calculation”. Especifique la expresión indicada en la figua 8.5 y presione “Show” para ejecutar 
la operación. Despliegue la lista de mapa creada “fPAR” como secuencia animada usando la 
representación “fpar” y revise los valores obtenidos. 

 



  
Figura 8.5: Cálculo de fPAR para todo la lista de mapa NDVI 
 
El rango de datos de fPAR debe estar entre 0 y 0.95 según Potter et al. (1993). Por esa razón, 

los mapas iniciales de fPAR deben corregirse siguiendo la siguiente condición: si fPAR ≤ 0, 
fPAR=0 y si  fPAR ≥0.95, fPAR=0.95. Para corregir los mapas de fPAR seleccione del menú de 
ILWIS “Operations => Raster Operations => MapList Calculation”. Especifique la expresión 
indicada en la figura 8.6 y presione “Show” para ejecutar la operación. 

 

 
Figura 8.6: Cálculos para corregir la lista de mapa de fPAR 
 
A continuación deberá calcularse el PAR absorbido o APAR (ver paso 8 en el esquema de la 

figura 8.1) multiplicando los mapas de fPAR mensual por el correspondiente mapa de PAR 
mensual. Para ello, cree una nueva lista de mapa usando los mapas mensuales de PAR 
remuestreados. Desde el menú principal de ILWIS, seleccione “File => Create => MapList” y 
agregue todos los mapas remuestreados “PAR_*r” en orden secuencial a la lista de la derecha 
utilizando el ícono “>”. Especifique el nombre de la lista de mapa como “PAR_07” y presione 
“Ok”. Despliegue la nueva lista de mapa creada como secuencia animada, utilizando la 
representación “Pseudo” y revise los valores obtenidos. 

 



 
Figura 8.7: Cálculos realizados con la lista de mapa para obtener APAR y mapa resultante 

para enero de 2007. 
 
El siguiente paso es calcular la ANPP mensual (por ejemplo para enero de 2007, ver paso 9 

de la figura 8.1) multiplicando el mapa de APAR con el correspondiente mapa estacional de la 
RUE. Note que debe elegir la estación correspondiente según cada mes. Elija “rue_sprsumr” 
para el cálculo de la ANPP desde octubre a marzo y “rue_autwinr” de abril a septiembre. 

Los cálculos deben repetirse para todos los meses, para ello cree un “script” y ejecútelo 
desde la línea de comandos de ILWIS. Para crear un “script”, seleccione desde el menú 
principal de ILWIS “File => Create => Script”. Seleccione la lengüeta “Script” en el editor y tipee 
el contenido indicado en la figura 8.8 (izquierda). Note que la primera línea es un comentario; 
la segunda línea define el cálculo a realizar. Se utilizan tres parámetros: representados por %1 
a %3. Abra la lengüeta “Parameters” para definir los mapas de entrada y salida que serán 
utilizados. Indique el contenido como se muestra en la figura 8.8 (derecha). Una vez 
completado seleccione “Save” desde el menú y guarde el “Script” como “ANPP_Calc”. Para 
ejecutarlo presione “>” desde el menú e indique los mapas de entrada y salida. Presione “Ok” 
para ejecutarlo. En la figura 8.9 se muestran los detalles para el mes de enero. 

 

 
Figura 8.8: Script de ILWIS para el cálculo de la ANPP mensual 
 

 
Figure 8.9: Definición de parámetros en el script de ILWIS para el cálculo de ANPP 
 



Cuando haya finalizado los cálculos, abra el mapa de ANPP creado, llamado “anpp_1” 
usando la representación “Pseudo”. Los resultados deben ser similares a los de la figura 8.10. 

 

 
Figura 8.10: Mapa de ANPP calculado para el mes de enero de 2007 
 
Como esta operación debe repetirse once veces, utilice la historia de la línea de comandos. 

Desde el menú principal de ILWIS seleccione la línea de comandos con la flecha hacia abajo 
correspondiente al cálculo precio. La línea se muestra a continuación: 

 
Run ANPP_calc apar_1 rue_sprsumr “anpp_01” 
 
Modifique la línea como se indica a continuación para ejecutar el cálculo para el mes de 

febrero: 
 
Run ANPP_calc apar_2 rue_sprsumr “anpp_02” 
 

Repita el procedimiento descripto arriba para calcular la ANPP de los meses restantes. Note 
una vez más que para los meses de octubre a marzo, debe utilizar "rue_sprsumr" y para los 
meses de abril a septiembre "Rue_autwinr". 

Una vez calculados los mapas mensuales de ANPP, deben ser integrados en un mapa anual 
(paso 10 del esquema de la figura 8.1). Para calcular el mapa ANPP_2007 debe crearse una 
nueva lista de mapa. Desde el menú principal de ILWIS, seleccione “File => Create => MapList” 
y agregue todos los mapas “ANPP_*” en orden secuencial a la lista de la derecha utilizando 
“>”. Especifique como nombre de la lista de mapa “ANPP_2007” y presione “Ok”. Despliegue la 
nueva lista de mapa creada“ANPP_2007” como secuencia animada, utilizando la 
representación “Pseudo” y revise los valores obtenidos en el mapa. Cierre el mapa si ha visto la 
secuencia animada. Haga click con el botón derecho del ratón sobre “ANPP_2007” y 
selecciones del menú contextual la opción “Statistics => MapList Statistics”, utilice “Sum” como 
Statistical Function y especifique como nombre de salida del mapa “anpp_sum”, presione 
“Show” para ejecutar la operación. 

Cuando los cálculos han sido terminados, abra el nuevo mapa creado “anpp_sum”. El mismo 
muestra la ANPP  en Kg/ha para el año 2007. Utilice la representación “Pseudo”. Puede 
agregar una capa con los límites del país a este mapa final. Para ello, selecciones desde la 
ventana del mapa activo la opción “Layer => Add Layer” e indique el directorio de ILWIS, 
selecciones el subdirectorio Extensions\Geonetcast-Toolbox\util\maps y seleccione el vector 
“country_02” y presione “Ok”. Quite la selección de la opción “Info”  y seleccione “Boundaries 
Only” y presione “Ok”. Mueva el ratón con el botón izquierdo presionado sobre el mapa y 
revise los valores obtenidos. Los resultados deben ser similares a la figura 8.11. 

 



 
Figura 8.11: Mapa final de ANPP para el año 2007. 
 
8.5 Conclusiones 
 
Una metodología para calcular la ANPP mensual en la región de Pampa de NDVI y datos PAR 

fue presentada en este ejercicio. La metodología se basa en el modelo de eficiencia con bi-
estacional mapas de la RUE. La validación se llevó a cabo con anterioridad comparando los 
datos de ANPP obtenidos con el modelo tradicional de Kumar y Monteith (1982) que utiliza un 
valor fijo RUE (en este caso, 0,48 g / MJ). Ambos modelos fueron validados con tres conjuntos 
de datos mediante regresión lineal simple usando los coeficientes de determinación (R2) y las 
pendientes para todas las comparaciones. Los tres conjuntos de datos independientes fueron: 
estimaciones de campo de la ANPP , estimaciones de ANPP realizadas a partir de un modelo de 
precipitaciones (Sala et al 1988) y estimaciones de ANPP a partir del modelo CASA (Imhoff et 
al. 2004). Para más detalles ver Cristiano et al. (2011). Ambos métodos (RUE variable y RUE 
fija) presentaron un bajo nivel de ajuste en comparación con la productividad observada en el 
campo (R2 = 0,25 y 0,30, respectivamente). Esto puede ser debido a que los sitios 
considerados presentaban las mismas las condiciones ambientales. Cuando se utilizaron los 
datos cubriendo todas las condiciones ambientales (ANPP obtenidos por las lluvias y el modelo 
CASA), el nivel de ajuste aumentó significativamente y el R2 fue mayor en el modelo de RUE 
variable que en el modelo RUE fija. Esto indica que el número pequeño de sitios considerados 
no reflejó la variabilidad en las condiciones ambientales necesarias para una correcta 
validación. Creemos que es necesario realizar una adecuada validación del modelo con más 
datos de ANPP tomados a campo cubriendo toda la gama de condiciones ambientales 
estudiadas. En este ejercicio se hace uso del NDVI obtenido a partir de MODIS TERRA. 
Actualmente en el GEONETCast-DevCoCast también provee los productos de NDVI, al igual que 
el NDVI decádico derivada de SPOT-Vegetation o los productos de NDVI diarios de SEVIRI a 
bordo de Meteosat-Segunda Generación. Este es un nuevo producto que se genera 
diariamente por Meteorological Product Extraction Facility. Todos 
estos productos pueden ser fácilmente incorporados en el análisis utilizando las rutinas de 
importación disponibles de la caja de herramientas de GEONETCast. 
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