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Tutorial 2: Introduction to basic Ilwis operations for WFS - Ethiopia
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Objective:

In this second tutorial, several satellite image data operations and GIS functionalities useful for the
project, will be shown using Ethiopia land cover sample data. You will proceed with: import land cover
data from GEONETCast, map view display zoom in - out using an appropriate color table, analyze map
data using pixel info, vector overlay, create a sub map using a georeference, perform simple map
calculation (e.g. display only Ethiopia/exclude data), vector to raster, map grid overlay, create map view
and a cartographic layout, export map layout to a report quality figure for e.g. a document; export map
data summary statistics and info to a table (Excel). These are very typical standard GIS operations to
generate user-defined output from GEONETCast satellite data in projects.

As sample data in tutorial 2, land cover monitoring satellite dataset from SPOT-Vegetation are used e.g.,
NDVI (SPOT-VGT 1km). These data are an important monitor for vegetation (crop) development during
the different regional growing seasons in Ethiopia. Ps. Other SPOT-VGT products or MSG LSA SAF
products can also be used (see classroom demo). A MSGMPE rainfall data set is also used.

Setting the input and output locations (for importing GEONETCast data)

We assume that you have set the correct input and output locations for your sample GEONETCast data
sources and output (active work directory). To verify this, go to the Configuration > Folders in the
GEONETCast Toolbox Menu. Ps. The input-output directories can be changed in this menu or by
adapting the geonetcast.ini (ascii-file), present your Drive:\llwis372\Extensions directory. [See
workshop].
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Pls. note that these locations are essential for successful operation of the toolbox. Failure of the import
is mostly due to wrong location settings used (e.g. wrong or non-existing directory names,.etc.).
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Viewing a near real time NDVI from VGT4Africa (SPOT_VGT instrument)

We describe here a step-wise procedure to create a view and analyze a recent NDVI image, using a LEAP view
window size. Spatial resolution for GNC data is 1-km (compared to 0.1 degree or approx. 10-km for LEAP output).

- Open ILWIS (v3.72)
0 Open (double-click) on GEONETCast and Toolbox
=  Go to SPOT VGT Products
e  Go to SPOT VGT Africa (and double-click). More than 16 datasets are visible, now go
to NDVI and one-click

- The SPOT VGT NDVI 10-day composite retrieval and processing window appears:

0 Specify the Decade date (yyyymmdecdec) e.g. 20110921 for the third decade of September 2011
(20110901, 20110911 for respectively the first and second decades). Note: make sure that this
dataset is available on your GNC LAN or input dataserver, otherwise select another available date or
input source file. You can do so, by browsing your server or data directory and check the filenames.

0 Input directory should point to the data sub-directory on your dataserver e.g. X:\VGT4Africa

0 Output directory should be your active llwis work directory e.g. d:\GNC_out (see your right llwis
panel or window)

0 Press Import, and wait a few moments, for ILWIS to find and read the raw data into your PC, convert
the file format and automatically generate a whole Africa NDVI map at 1-km resolution. This can take
a few moments (10’- 40’ seconds), pending your systems cpu speed. This is a rather large map (Africa
coverage).

- Go to the Refresh button from the Window main Menu (or press F5) to refresh your work directory files.
0 Check if a raster icon and filename ndvi20110921 is visible in the directory. Also another data quality
file is available i.e. ndvi20110921_SM, but we will not use it here.

- View the file, by double-clicking on the file icon or right-hand clicking and use Open from the Context sensitive
menu.

0 Change the Representation (Color Lookup Table or also named Palette in llwis) and apply the NDVI1
color scheme. This will yield a standard NDVI color map for Africa.

O Pls. have a look and try to interpret the color scheme and NDVI values, by browsing the map and left-
hand mouse clicking on pixels. You can also use the Open Pixel-Info from the File Menu, in order to
get exact co-location and value.

0 Using the [+] enlarge button, Zoom in a rectangle of choice e.g. Eastern Africa, Ethiopia.
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- You can add any world country or Ethiopian vector boundary map for better viewing, by adding a vector Layer
to the View, from the Layer Menu from the Map Window Menu.

0 With your map window open, go to the Menu Toolbar & go to Layer — Add Layer and look for a vector
(or polygon) file in your work directory or elsewhere; e.g. regions, woreda...

O Add the layer using the - Boundaries Only - display and Info Off Options and select a visible
contrasting Display color e.g. black (in this case). Pls. use the regions or woreda polygon layer map as
an example.

0 You can now zoom-in and out on the view. Pls. when analyzing the NDVI map values, select the Info =
off option for the overlaying vector map (regions, woreda), or use Open PixelInfo.

- Inthe next step we will create an Ethiopian window sized 1-km NDVI submap (LEAP window corners).

Create an Ethiopia map window of a GEONETCast satellite dataset

After you have imported a large image dataset, you usually want to view only your region of interest (ROI) in our
case here, Ethiopia (country borders, regions, zone or districts level). The next steps guide you to do this.

Step 1: create a Sub map

Open llwis with your work or data directory active. Open the raster map of interest [NDVI20110811] and display
using an appropriate Representation (color Look-up-table). In this case use [NDVI1].

A full Africa window NDVI (SPOTVGT) at a 1km resolution is shown (see Figure above).

Draw a rectangle of your region of interest (ROI) using the & % icons. You can modify and adapt your window,
also by using the view window sliders (border). Frame the exact window you would like your map to look like.

Now create a Submap of this window using the File Menu > Create > Submap > Submap from Raster
Use (o) lines and Columns (window as displayed)

Give a new name to the new submap (Output raster map)

Click on Show
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A new file set will appear in your work directory (new name raster map, georeference, histogram icon).
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Step 2: Create a mask of your Region of Interest ROI (Ethiopia country and regions borders)

We will use the Ethiopia regions map used by LEAP (as ESRI shape files available in LEAP data directory), in order to
have exactly the same area coverage. Any map can however be used as input, e.g. a catchment map or similar.

First, we have to create a raster map from the Regions polygon file (imported from the shape file). There are
several ways (4) to do so in llwis.

Option A: Main Toolbar Menu
A first option to rasterize a polygon map is to go via the Main Toolbar Menu > Operations > Rasterize > Polygon to
Raster.

Output Raster Map give name e.g. [regionmasklkm]

Use the georeference £ made in Step 1 as GeoRef

A new raster map of Regions will be visible in your directory (see below left).

You can do the same for the Zone or Woreda map (as shown right).
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Option B: Operation Tree Window

Another work option is to use the Operation Tree Window (left pane) and go to Rasterize (and do as indicated
above under Option A.

Option C: Mouse Context Menu (Right-hand click menu)

A third and fast option is to use the mouse context sensitive menu (right-hand mouse click).

To do so, find the Regions polygon map icon in the active directory, activate the polygon icon file and Right-hand
click to open the context Menu > Polygon to Raster > etc. (and do the operation as indicated in Option A).

Option D: Command line (scripting)
A forth method is to use a direct Command line statement to perform the operation (for more advanced users).

Step 3: Create an Ethiopia country map of your NDVI window map

This can be achieved by executing a simple map calculation statement, using the MapCalc routine from the Main
Toolbar Menu or directly by writing your mapcalc statement in the Command line of llwis.

Option A: Toolbar Menu
Go to the Toolbar and Operations Menu > Raster Operations > Map Calculation.
You will be asked to write an Expression. This is a mathematical operation on raster map layers, who have the
same georeference i.e., pixel size, window size, coordinate system !
Insert the following statement:
“ifundef(regionmasklkm,?,ndvi_et1)” (ps. type without “” brackets)
Output Raster Map: give your [newname]
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Domain: value, precision 0.01 [min -1.00 ; max +1.00]

Question: Can you explain the expression in words and/or what happened?

Option B: Command line
An example Command line syntax would read like this: “ndvi_et:= ifnotundef(regionmask1lkm,?, ndvi_sub)”
Type the command (without “”) and execute it by typing [enter]

Now display the map ndvi_et, using color representation [ndvil] and overlay the raster map with the region

polygon map. To do so, go to Layers Menu
Layers > Add layer > Regions, use Boundaries Only; color black

Your result should look like below:
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Create a print output of an Ilwis map

For generating report quality output from llwis, 2 steps are required:

Create a Mapview

To create a mapview, first open your raster map file and map window using AN

Then if needed, add Layers from the Layer Menu e.g. region boundaries (black)

Also optionally add gridlines (or graticule) from the Map window Layer Menu; choose e.g. 2 degrees,
Save your map view under a given name using the File > Save View Menu

Design a cartographic Layout

To create a Layout, go to the Main llwis File Menu > Create > Layout

According your preferences, you can use Page Setup. Portrait or Landscape (use Landscape here)

Go to the Insert Menu and insert the Mapview file. Use scale 100 (this is due to the degree format of
your file; and does not reflect real decimal map scale).

Activate the inserted map view (by clicking it with the mouse); and then insert more objects
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Map border: neat line graduation, Legend, North arrow, text, borders etc. according your cartographic
output preferences. Save your layout using a name as a name.ilo file.

Create Windows graphic output

Open your map Layout file, and then go to the File Menu and Export your map layout to a Windows bmp
map. Use e.g. 72 pixels. A *.bmp map is created in your directory. This file can then be easily used in
your reporting (Word insert Picture) as shown below.
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Data exchange (Import - Export) between LEAP and Ilwis

llwis permits to read LEAP image (GIS output) and also to generate map output with a LEAP image
format. This can be imported by LEAP (if LEAP is set to allow for this data import (see below *).

LEAP 2 ILWIS

To export LEAP images and output to Ilwis proceed as follows: If you have LEAP v2.4 on your PC or
laptop, open LEAP and go to the Viewer and display a LEAP dataset e.g. RFE2 dataset. As an example, go
to the LEAP View Menu and display an actual RFE2 rainfall map of the first decade of September 2010
(or 20100901). Export the map to GIS giving it an appropriate name e.g. RFE20100901 and also to your
llwis active work directory (by preference). Your LEAP RFE2 map looks as shown below.

Export the Leap image (e.g. RFE2) to GIS and make sure to save it in your llwis working directory.

Now import this GIS exported file using the Ilwis File Menu > Import > GDAL > Raster > as Arc/Info Binary
grid. A georeference will be automatically made by Ilwis. Give a name e.g. [rfe20100910]. The imported
map will be stored by llwis in an I0C or foreign collection Object (see icon in your working directory).

R import . X ]
- - -
Drivers
=) raster - Geospatial Data Abstraction Librany{GDALYArc/Infc
AirSAR Polarimetric mage =
ARC Digitized Raster Graphics = | tnout ‘RFEZ,ZDW 00301 ‘ l:l
Arc/info ASCI Grid
Arc/info Binary Grid
CEOS Image Output RFE2_20100301.mpr [ i ion " -
Cete i mage g \ P e ) Foreign Collection "RFE2_20100901
Convair PolGASP v U I 1
COSAR Annatatecd Binary hMatrix (Te [¢] Use s RFE2_201 onant
DIPEx 3
\ DRDC COASP SAR Processor Ras -l RFE2—201 DD9D1
| DTED Elevation Raster L RFEE_ED" ooYn
L FLAR
< \_ L} | »
Ok, Cancel
|

Now refresh your llwis directory using the ILWIS > Window > Refresh option and Open the foreign
collection (ioc) using right-hand mouse operation and Open or Display the RFE20100901 raster map in
llwis. Pls. use the Precipitation1 as a color Representation, and stretch the data range (reduce the max.
value of 144 to e.g. 100 or 80) for more a contrasted display. You can obtain the same color intensity
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settings as in LEAP if needed, by modifying (color stretching) the display data range. Your map should
look as below. If no coordinate system is present, add the standard LATLONWGS84 system in the map
properties.

[E) RFE2_20100901: Raster Map from RFE2_20100901, using GDAL, method : use as - [LWIS [ | [ )

file Eait Layers Options Help
DO & & Q| B e [T

R egions]

= [& Properties

& B RFE2_20100 x
= -£5' Properties 1
2 ¥ Legend —
o
50 4 o 4
=mo p f ) o

150

113,129 3°53720.7"N, 45°27'08.00"E 3°53'20.67"N, 45°27'08.00"E

This LEAP output and import in llwis is now ready for any further use and can be modified e.g.
resampled to another pixel size or be subjected to any other GIS operation, like map calculations, sums
etc.

ILWIS 2 LEAP

llwis maps can also be prepared as input for LEAP". Before exporting your llwis map, you should
resample the map to the standard Leap map window georeference (coordinate system and datum:
latlon wgs84, pixel size of 0.1 degree and LEAP map window corners).

To do this:

Go to Operation Tree (left window) > Spatial Reference Operations > Raster > Resample

Input: original (source) raster map; (o) resampling method e.g. use bicubic spline; Output raster map
name [yourname]; use the llwis georeference of Leap. This georeference is automatically made when
you import a Leap GIS export file into llwis. So, pls. use the georeference you made in Leap2llwis
exercise (see your georeference £2 in the 10C container of the imported RFE210100910 map above).

Go to File Menu > Export > Gdal > Image and Data Analysis format (IDA byte format). The IDA file format
is a simple and small image file format using 1 byte per pixel (0-255 data range levels).

View (open) the resulting map in llwis using an appropriate color representation.(Pls. read below *)

*) Ps. LEAP v.2.4 currently does not accept new alien files (names) to be imported and opened by the LEAP software, and reads
only dedicated image filenames (as IDA byte format) from its directory. A possibility is to overwrite or use an existing filename,
but this procedure is not recommended (!), as it jeopardizes and modifies your Leap datasets.
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Extracting statistical summary information from images (e.g. per region, zone,
woreda or any location of interest)

llwis maps can be combined with boundary map overlays (e.g. regions, zones, woredas) and summary
information (e.g. woreda averages, total sum, etc.) can be extracted and exported to an llwis table, but
also to e.g. Excel.

As an example a Meteosat MSGMPE daily rainfall sum estimate will be used and average rainfall per
woreda will be generated (see rainfall example case studies)

First have a look at a daily sum satellite rainfall estimate (EUMETSAT MSGMPE) from 2009-09-16.
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From the MSG full disk, we resampled an Ethiopia window, using the LEAP window georeference (see
Tutorial 3). We can see that there we some strong rainfall showers in the North west. Open the
MSGMPE20090916L.mpr using the Precipitationl Representation and Stretching the data range
between 0-50. If you overlay this map with the woreda segment layer (black) you will obtain a figure as
above.

A manual (menu) procedure to find the woreda average rainfall (20090916) in a table is described
below. Later, we will learn an automated procedure (as in Leap) using llwis Scripts.

Go to the Operations > Raster Operations > Cross
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Now aggregate the values to woreda level using an average statistic. With the table open, go to the
Menu > Columns > Aggregation and fill in as follow. You have now created a new table column
“mpe_avg_woreda”.

¥ Aggregate Column &J
Column [ Pmsompez0020916L + |
Function | fntverage ﬂ
[v Group by |F"}N0redas ﬂ
[ Weight
[~ Output Table
OupuColunn
Ok Cancel | Help |

We will now make a small new table [mpe_woreda.tbt] with only the woreda name column (extracted
from attribute table woreda.tbt of the woreda.mps and map. Here we will join the average rainfall
column from the previous mpw20090916_wor.tbt table and then export to Excel.

Go to the File Menu > Create > Table

D Create Table ﬁ

Table Name  |[mpe_woreda ‘

Description:
mpe_dailyraintall_perworeda tahle |

Dornain

oK |Cance|‘ Help ‘

And use “woredas” as domain (string). Follow instructions.

Open this mpe_woreda table, go to the Menu > Columns > Join. Select Table: mpe20090916_wor and
column: mpe_avg_woreda. Follow instructions and accept > using Next. You will see now the average
daily rainfall values next to the Woreda names. You can change the digits.

Now Export this Table to Excel. Go to the File > Export > Find the filename and use Format: DBase (dbf).
A file.dbf is made, which you can open with Excel.
This manual procedure is long, that’s why in llwis we can automate this process using script language.

Pls. see the Ilwis Script below:

10
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B Script "aggreg” - ILWIS -

File Edit View Help
Descrigtion |aggregate output to excel

& M S =

Script | Parameters | Drefault Values |

21_crosstht = TableCross(regions. 1. lgnorelUndefs)
crthl 221 _awg regions.dam
abcalc %1 _awvg REGIONMNAME = CalumnJoin(regions tht REGIONNAME)
abcalc %1 _awvy avg = ColumnJoinAwg(®:1_crosstht 261 regions, 1)
export dBase(®1_awvgtbt %1 _awva)
II'CAProgram Files\Microsoft OfficeOffice 4\Excel exa’ %21 _awg.dbf

Pls. if you want to sue the script already, verify if your Excel.exe is located in the directory indicated in the script, otherwise
adapt the script with the location on your laptop or PC, and save the script under a newname, e.g. aggreg2.

This script will automatically do the entire map cross and table operations for you on user selected input

maps, and export to Excel (see result below). We will learn how to write scripts in a later session.

4l A B c r
i [worlwoREDANAME MPE_AVG_WOF
1 Nefas Silk

.2 Bole 0.00001
| '3 Lideta

(4 Kirkos

i[5 Yeka

6 Addis Ketema

i (7 Arada

! ’8 Gulele

279 Adwa 0.00000
1710  Ahferom 0.00000
211 Alaje 0.27559
312 Alamata 0.13970
1713 Asgede Tsimbila 0.55163
514  Atshi Wenberta 0.00000
515  Degua Temben 0.00000
7716 Enderta 0.00000
817 Erob 0.00000
318  Ganta Afeshum 0.00000
1719 Gulomekeda 0.00000
120 Hawzen 0.00000
221 Hintalo Wejirat 0.06563
322 Kafta Humera 6.68437
A ")2 Walata Mwalalla [aNa'alalatal

Ps. some mission polygon data are due to the Addis Ababa urban sub-area shape file issues, and still have to be corrected

With Ilwis, all possible aggregation (polygon files) and pixel resolutions can be done, so you remain in
command of your entire data analysis procedure.
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