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Exercise
This exercise is a step-by-step guide for a downscaling application of Sentinel-3 land surface temperature (LST) data, using the SNAP toolbox as well as Sentinel-2 images acquired over Athens (Greece) and Chongqing (P.R. China).
LST is a key climatic parameter, controlling the majority of the land surface processes. In many applications, such as urban heat island monitoring or evapotranspiration mapping, daily LST observations are needed. However, there is a trade-off between the temporal and the spatial resolution of the current thermal remote sensing systems. Geostationary meteorological satellites (e.g. FengYun-2F) provide near continuous thermal observations, but are characterised by a low spatial resolution (> 3 km). The spatial scale of polar satellites with daily imagery (e.g. MODIS Terra/Aqua or Sentinel‑3) is also rather coarse (1 km). On the other hand, satellite-derived LST at a spatial resolution of 100 m, can be captured only by platforms with a low revisit cycle, such as the Landsat 8 satellite.
Hence, techniques must be developed to downscale the coarse scale LST data to a finer spatial resolution. Statistical downscaling (also commonly referred to as thermal sharpening) is a widely used downscaling methodology that employs a statistical relationship between LST and surface parameters (predictors). This relationship is firstly derived using the low spatial resolution observations and subsequently applied at high resolution, where predictors are also available using a different satellite platform. Complex statistical downscaling algorithms can be developed, using sophisticated regression techniques (e.g. artificial neural networks) and multiple predictor variables.
Here, we apply a base downscaling model, based on the strong relation that exists between LST and Normalized Difference Vegetation Index (NDVI), combining observations from the Sentinel satellites.
The Sea and Land Surface Temperature Radiometer (SLSTR) instrument onboard Sentinel‑3 covers 9 spectral bands (550–12000 nm). The Sentinel-3 LST product (SL_2_LST) includes pre-calculated LST values at 1 × 1 km, derived using the thermal channels of Sentinel‑3 and a split-window algorithm. NDVI values are also included in the SL_2_LST dataset.
The Sentinel‑2 MultiSpectral Instrument (MSI) can provide observations in the visible, near infrared, and short-wave infrared part of the spectrum, at a fine scale, up to 10 m for four bands. The Sentinel‑2 Level-2A product corresponds to the Bottom-Of-Atmosphere (BOA) reflectance, i.e. atmospherically corrected surface reflectance values.
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The main steps of the statistical downscaling procedure include:

a) Developing a simple linear regression model using the Sentinel‑3 data:
		EQUATION 1
where a, b are the regression coefficients and ε the regression residuals.

b) Applying the regression model to the low resolution NDVI image:
[bookmark: _GoBack]     { means modeled LST}	            EQUATION 2
in order to calculate the residual values per pixel: 
				EQUATION 3

c) Using the regression model with the high resolution NDVI image (Sentinel‑2), applying at the same time a local correction through the previously calculated residuals:
					EQUATION 4


Α. Processing of Sentinel 2 data
A1) Locate the exercise data in your PC (freely available from the Copernicus Open Access Hub: https://scihub.copernicus.eu/dhus/#/home). 
· C:\....\Data-downscaling
The data consists of two folders, one for Athens and one for Chongqing.
· C:\....\Data-downscaling\Athens
· C:\....\Data-downscaling\Chongqing

Each folder contains three subfolders a) Sentinel-2 data, b) Sentinel-3 data and c) boundaries of the study area.

A2) Open the SNAP Toolbox and import the Sentinel-2 data for Athens (Figure 1).
· File→ Open Product→ /…/MTD_MSIL2A.xml
[image: ]
Figure 1
· The Sentinel-2 data are now imported to SNAP. In the “Product Explorer” window (Figure 2) you can see the metadata files and the bands. Double click on any band to open the image data. In Figure 2 we have opened Band 4.
[image: ]
Figure 2
A3) Import the study area boundaries.
· Select File→ Import→ Vector→ ESRI Shapefile→ /…/athens.shp (Figure 3). The vector data will appear in the “Vector Data” folder.


[image: ]
Figure 3

A4) Use the Mask tool to mask out all data outside the study area in order to reduce the size of the Sentinel-2 data and to reduce processing time.
· Select Raster→ Masks→ Land/Sea. In the dialog box that appears use the following settings: 1) In the “I/O parameters” tab select a directory to save the new file 2) In the tab “Processing Parameters” a) select B4 and B8 as the source bands using Ctrl button to select both of them (we will only need Band 4 and Band 8 to calculate NDVI at 10m. resolution), b) Untick the “Use SRTM 3sec” option and c) select the “Use Vector as Mask” option and select Athens. Click Run (Figure 4).
[image: ]
Figure 4

· The new data file will appear in the “Product Explorer” (Figure 5).
[image: ]
Figure 5


A5) Calculation of Normalized Difference Vegetation Index (NDVI)
The vegetation density can be detected using the reflection values from the red band (Band 4) and the infrared band (Band 8). Green vegetation reflects more energy in the near- infrared band than in the visible range. Vegetation absorbs more radiation from the red band for the photosynthesis process. Leaves reflect less in the near-infrared region when they are stressed, diseased or dead. Features like clouds, water and snow show better reflection in the visible range then the near-infrared range, while the difference is almost zero for rock and bare soil. Values close to zero represent rock and bare soil and negative values represent water, snow and clouds. Taking ratio or difference of two bands makes the vegetation growth signal differentiated from the background signal.



· Use the Bands maths tool of SNAP to calculate NDVI. Select Raster→ Band Maths and in the dialog box that appears a) name the new band that will be created “NDVI” , b) untick the “Virtual” option and  c) click the “Edit Expression” option. Then insert the following equation in the expression box “($2.B8- $2.B4)/($2.B8+ $2.B4)” (Figure 6).

[image: ]
Figure 6
· Subset the NDVI data to minimize the size of the data. Select Raster→ Subset. In the “Spatial Subset” tab select the “Geo Coordinates” and insert the following coordinates (Figure 7) and in the “Band Subset” tab select the NDVI band (Figure 8):
	
	Athens
	Chongqing

	North latitude bound
	38.25
	29.6

	West longitude bound
	23.5
	106.4

	South latitude bound
	37.5
	29.4

	East longitude bound
	24
	106.6



[image: ]
Figure 7
[image: ]
Figure 8
A6) Save the final NDVI data 
· Select the subset file, right click on it and select Save  product as. Name the file “ndvi_10m.dim” (Figure 9).
[image: ]
Figure 9

· The processing of the Sentinel-2 data is now over and we will close all products from SNAP. Select File→ Close all products. You don’t need to save any changes.

B. Processing of Sentinel-3 data
B1) Import the Sentinel-2 data for Athens.
· Select File→ Open Product→ /…/xfdumanifest.xml. 
The Sentinel-3 data are now imported to SNAP. In the “Product Explorer” window (Figure 10) you can see the metadata files and the bands. Double click on the LST band to open the image data.

[image: ]
Figure 10

B2) Subset the data to reduce file size and to reduce processing time. Select Raster→ Subset. Use the following settings (Figure 12):

a) “Spatial Subset” tab→ “Geo Coordinates”
	
	Athens
	Chongqing

	North latitude bound
	43
	33

	West longitude bound
	18
	105

	South latitude bound
	32
	28

	East longitude bound
	23
	108



b) “Band Subset” tab: Select only NDVI, LST, x_in, y_in, latitude_in and lobgitude_in

c) “Tie-Point Grid Subset” tab: Select only x_tx, y_tx, latitude_tx, longitude_tx

 
The new subset file is now created and you can find it in the “Product Explorer”.
	[image: ]
Figure 12

B3) Next we will reproject our subset data to match the projection of Sentinel-2 data.
· Select Raster→ Geometric Operations→ Reprojection. Select a folder to save the new file in the “I/O parameters” tab and in the “Reprojection Parameters” tab select UTM/WGS 84 (Automatic). Then select Run (Figure 13).

The new file will appear in the Product Explorer.
[image: ]

B4) Subset the reprojected data in order to keep only the data we need. Select Raster→ Subset. Use the following settings: 

a) “Spatial Subset” tab→ “Geo Coordinates” 
	
	Athens
	Chongqing

	North latitude bound
	38.25
	31

	West longitude bound
	23.5
	106

	South latitude bound
	37.5
	29

	East longitude bound
	24
	107



b) “Band Subset” tab: Select only NDVI and LST.
[image: ]
Figure 14
Β5) Next we will import the vector data of the study area boundaries. Select File→ Import→ Vector→ ESRI Shapefile→ …/athens.shp (Figure 15).
[image: ]
Figure 15

B6) Mask out the data outside of the study area boundaries. 
· Select Raster→ Masks→ Land/Sea. In the dialog box that appears use the following settings: 1) In the “I/O parameters” tab select a directory to save the new file. Name it “lst_ndvi_1000m”. 2) In the tab “Processing Parameters” a) select NDVI and LST as the source bands using Ctrl button to select both of them, b) Untick the “Use SRTM 3sec” option and c) select the “Use Vector as Mask” option and select Athens. Click Run (Figure 16).
· 
[image: ]
Figure 16

The new file will appear in the “Product Explorer” (Figure 17).
[image: ]
Figure 17

B7) Plot the data with the Scatter plot analysis tool. Select Analysis→ Scatter plot. Select NDVI as the X-axis and LST as the y-axis. Click on the refresh button and the scatter plot will appear (Figure 18). A clear negative correlation between NDVI and LST is seen. When NDVI increases the LST decreases and vice versa. 

[image: ]
Figure 18.

B8) Find the regression equation (EQUATION 1). 
· Right click on the scatter plot and select “Copy Data to Clipboard” (Figure 19).

[image: ]
Figure 19

· Open a Microsoft Excel spreadsheet and paste the data (figure 20).
[image: ]

· Select the NDVI and LST data and select Insert͢͢͢→ Scatter (Figure 21).
[image: ]
Figure 21

· The scatter plot appears, right click on the data and select “Add Trendline” (Figure 22).

[image: ]

Figure 22

The regression equation is . Since y=LST1000 and x= NDVI1000 our regression equation is 

B9) Close all products. You don’t need to save anything.



C. Apply the statistical downscaling technique

C1) Select File→ Open Product and open the “ndvi_10.dim” and “lst_ndvi_1000m.dim” files.

C2) Use the “Collocation Tool” to align spatially the two overlapping products. Collocating products implies that the pixel values of slave products are resampled into the geographical raster of the master product. Select Raster→ Geometric Operations→ Collocation and use the following settings (Figure 23): Master = ndvi_10m, slave = lst_ndvi_10m.

[image: ]


C3) Use Band Maths to calculate EQUATION 2. Name the new file “ lst_1000_down” and use the expression “316.56-11.43*$3.NDVI_S” (Figure 24).
[image: ]
Figure 24

C4) Use Band Maths to calculate EQUATION 3. Name the new file “dlst_1000_down” and use the expression “$3.LST_S- $3.lst_1000_down” (Figure 25).
[image: ]
Figure 25

C4) Use filter to smooth the residuals. Select the dlst_1000_down band and select Raster→ Filtered Band . Find the Low-Pass filter and in the number of iterations box select 3 (Figure 26).
[image: ]
	Figure 26
C5)Use Fix edges function to adjust the values at the image edges. This function will set the original residual values in the case is that the filter algorithm resulted in no-data. Right click on the dlst_1000_down_lp5 band and select properties. Untick the “No-Data Valu used” option. Then open the Band Maths, name the new file as dlst_1000_down_smoothed and use the following expression: “nan($3.dlst_1000_down_lp5)? $3.dlst_1000_down: $3.dlst_1000_down_lp5” (Figure 27).

[image: ]
Figure 27

C6) Apply EQUATION 4. Open Band Maths, name the new file lst_10_down and use the following expression (Figure 28): 
316.56-11.43* $3.ndvi_M+ $3.dlst_1000_down_smoothed

[image: ]
Figure 28


C7) The final image is now loaded in SNAP (Figure 29). 
[image: ]
Figure 29
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