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Chapter 8

How to ...

8.1 How to ( Basics )

8.1.1 How to display maps and tables & zoom
In the Catalog, ILWIS data objects are represented by the following icons:

for raster maps,
for polygon maps,
for segment maps,
for point maps,
for tables.

To display maps and tables in new windows
n from the File menu in the Main window, a map window or a table window,

choose the Open command and select a map or table, or
n in the Catalog, double-click a map or table, or
n in the button bar of the Main window, use the Show Map or Show Table button

and select a map or table, or
n in the Catalog, click a map or table with the right mouse button, and select

Open from the context-sensitive menu, or
n in the Operation-list, double-click the Show item, or
n drag a map or table from the Catalog to the Show item in the Operation-list.

Before a map is displayed, some display options have to be specified, then a map is
displayed in a new map window. A table is directly displayed in a new table
window.

To add maps to an existing map window
n from the Layers menu in a map window, choose the Add Data Layer command

and select Raster map, Segment map, Polygon map or Point map from the
cascading menu, or

n from the Layers menu, choose the Layer Management command; then click the
Add Map button in the Layer Management dialog box, or

n drag a point, segment, polygon or raster map from the Catalog into the map
window.

Before the extra layer is displayed, some display options have to be specified. Then,
the selected point, segment or polygon map is displayed on top of the other layers
that are currently shown in the map window.
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When you selected a raster map to be added to a map window and the map window
already displays a raster map, then the newly selected raster map replaces the
currently shown raster map.

To show a map by one of its attributes
Instead of showing the units in a raster, polygon, segment or point map, you can
also display the attribute values of these units in a map window. The raster,
polygon, segment or point map should use a class or ID domain and an attribute
table should be linked to the map or to its domain.
n double-click a map in the Catalog or use another method as described above,

and
n in the Display Options dialog box of the map, click the Attribute check box and

select an attribute column from the attribute table,
n select or create a suitable representation.
For more information, see How to display a map by one of its attributes.

To retrieve specific elements of polygon, segment or point maps
Instead of showing all units in a polygon, segment or point map, you can selectively
display only those polygons, segments or points that have certain class names or
class codes, IDs or values. Using a mask is a powerful search method to retrieve
only the polygons, segments or points of interest.
n double-click a map in the Catalog or use another method as described above,

and
n in the Display Options dialog box of the map, click the Mask check box and

specify a mask, i.e. type one or more class names, class codes, IDs, or values
(depending on the domain of the map) that you want to retrieve.

For more information, see section 8.36.5 How to use masks.

When you want to retrieve specific classes, identifiers or values of a raster maps,
you can type a MapCalc formula on the command using the INMASK function.

To zoom in on maps displayed in a map window or in a map editor
n click the Zoom In button in a map window's button bar or a map editor's button

bar, or
n press the right mouse button while in a map window or a map editor; choose

Select Area from the context-sensitive menu, or
n from the Options menu in a map window or a map editor, choose the Zoom In

command.

The mouse pointer changes into a magnifying-glass, then
n click somewhere in the map to zoom in on this spot with a factor 2, or
n drag the cursor from one corner of interest to another (the mouse pointer

changes into a little box).
Whether the shape of the map window then changes or not depends on whether the
command Adjust Window Size on the Options menu of the map window is marked
or not.

To zoom in, you can also press CTRL + I on the keyboard: ILWIS will
automatically zoom in at the center of the map window with a factor 2.
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You can then use the PgUp and PgDn keys on the keyboard to scroll vertically, and
the Home and End keys to scroll horizontally.

To zoom out or to display the entire map again in the map window, select the Zoom
Out or Entire map commands on the Options menu or use the Zoom Out or Entire
map buttons in the button bar. The status line gives a brief explanation on the effect
of a button in a button bar, when the mouse pointer is located above one.

See also: section 8.36.3 How to use layers in a map window.

8.1.2 How to zoom in on maps

To zoom in on displayed maps, first
n click the Zoom In button in a displayed map, or
n  press the right mouse button while in a map window; choose Select Area from

the context-sensitive menu, or
n from the Options menu in a map window, choose the Zoom In command.

The mouse pointer changes into a magnifying-glass; then
n click somewhere in the map to zoom in this spot with a factor 2, or
n drag the cursor from one corner of interest to another (the mouse pointer

changes into a little box).

F  To zoom in, you can also press CTRL + I on the keyboard: ILWIS will
automatically zoom in at the center of the window with a factor 2. You can then use
the PgUp and PgDn keys on the keyboard to scroll vertically, and the Home and
End keys to scroll horizontally. For more information, see Map window : Zoom in.

F Whether the shape of the Map window then changes or not, depends on whether
the command Adjust Window Size on the Options menu of the map window is
marked or not.

F To display a map with 1 pixel in the map is 1 screen pixel, select the No Zoom
command on the Options menu. Then, use the scroll bars to move through the map.

F If you zoom in partly outside a map window, this part will also appear in the
zoomed in window.

See also: section 8.1.1 How to display maps and tables & zoom.

8.1.3 How to start operations
ILWIS operations are listed in the Operation-list.

To start an operation
n open the Operations menu in the Main window, and choose an operation, or
n double-click an operation in the Operation-list, or
n in the Catalog, click an input object with the right mouse button and select an

operation from the context-sensitive menu, or
n drag a data object from the Catalog to an operation in the Operation-list, or
n type a command on the command line of the Main window (see also

Appendices: ILWIS commands).
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A dialog box is opened in which you can enter the input and output object names
and other parameters necessary for the operation. When you click the OK button in
the operation's dialog box, an ILWIS expression is generated on the command line
of the Main window. Output objects that are obtained through an operation's dialog
box are always dependent.

Advanced users can type complete ILWIS expressions on the command line of the
Main window or create a script to execute a series of expressions. For more
information, see Appendices : ILWIS expressions and Appendices : ILWIS script
language (syntax).

8.1.4 How to create objects
There are several ways to create an object:
1. From the File menu in the Main window, choose Create, and choose the type of

object you want to create;
2. In the Operation-list, double-click a New command;

3. In dialog boxes, you can click the little create button  if available next to a
drop-down list box;

4. Type Create object abbreviation on the command line of the Main window.

8.1.5 How to open objects
There are several ways to open objects:
1. From the File menu in the Main window, choose Open, select the object you

want to view;
2. In the Catalog, double-click the object you want to view;
3. In the Catalog, use the right mouse button on an object and choose Open from

the context-sensitive menu;
4. In the Operation-list, double-click the Show command;
5. Drag an object from the Catalog to the Show command in the Operation-list;
6. Type Show or Show objectname.ext on the command line of the Main window.

Maps can also be opened by clicking the Show Map button  in the button bar
of the Main window.

Tables can also be opened by clicking the Show Table button  in the button bar
of the Main window.

For maps: the map is displayed in a new map window. For tables, histograms, and
two-dimensional tables: the table is displayed in a table window.
For other objects: either a specific editor is opened, or a dialog box appears.

You cannot double-click filters and scripts in the Catalog to open them; use one of
the other possibilities. To add maps as an extra layer to a map window, see How to
use layers in a map window.

F To show more objects than only maps and tables in the Catalog, refer to : How to
customize the Catalog.
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8.1.6 How to open the pixel information window
There are several ways to open the pixel information window:

1. In the button bar in the Main window, click the Pixel Information button  ;
2. From the File menu in the Main window, choose Open Pixel Information;
3. From the File menu in a map window, choose Open Pixel Information;
4. Type Pixelinfo on the command line of the Main window.

The pixel information window allows you to interactively inspect class names, IDs
or values in multiple maps with the same coordinate system. When one map is
displayed in a map window, the pixel information window is capable of retrieving
values of all maps added to the pixel info window, at the position of the mouse
pointer in the map window. In the same way, when you have an analog paper map
on the digitizer and you performed MapReference, the pixel information window is
capable of retrieving values of all maps added to the pixel info window, at the
position of the digitizer cursor.

See also: section 8.36.8 How to use pixel information.

8.1.7 How to edit objects
There are several ways to edit objects:
1. From the Edit menu in the Main window, choose Edit Object and select the

object you want to edit;
2. Double-click the Edit command in the Operation-list and choose an object to

edit;
3. Drag an object from the Catalog to the Edit command in the Operation-list;
4. Use the right mouse button on an object in the Catalog, choose Edit from the

context-sensitive menu;
5. Open the object (e.g. by double-clicking it in the Catalog, when it is possible to

edit the object, you will probably find a useful command on the Edit menu....
6. Type Edit or Edit objectname.ext on the command line of the Main window.

Maps can also be edited from within a map window: choose Edit Layer on the Edit
menu of the map window. Tables can directly be edited from within a table
window.

Service objects can also be edited when a map is displayed in a map window.

F To show more objects than only maps and tables in the Catalog, refer to: How to
customize the Catalog.

F Dependent data objects and read-only objects cannot be edited: check the properties
of the object.

F Histograms and matrices cannot be edited.
F Special editors are available for raster, polygon, segment and point maps, user-

defined domains, user-defined representations, etc.
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8.2 How to add

8.2.1 How to add annotation to a map window
ILWIS annotation can be added to a window in the form of texts, legends, boxes,
North arrow, scale bar, grid lines, graticule or bitmaps or metafiles (pictures) from
disk. Further, any picture or bitmap that was copied to the clipboard from other
Windows application programs can be pasted into ILWIS. You can also paste the
contents of another ILWIS map window into a current map window; for instance as
an inset-map giving an overview of a larger area.

Annotation is generally used on top of one or more data layers (displayed maps).
Annotation can be edited in the Annotation editor. To store annotation, you need to
save a map window as a map view.

To add annotation to a map window
n from the Layers menu in a map window, choose Add Annotation, and select the

type of annotation you want, or
n from the Layers menu, choose Layer Management. In the appearing Layer

Management dialog box, click the Add Annotation button and select the type of
annotation you want, or

n from the Edit menu, choose Annotation. The Annotation editor is opened
directly.

Except for bitmaps and pictures, you have to specify some display options for the
annotation layer before annotation is shown. The newly added annotation is
displayed at the left top corner of the map window; you are now in the Annotation
editor.

To add annotation from within the Annotation editor
When you have already added annotation and you are in the Annotation editor, you
can use the same possibilities as above but you can also:
n click one of the add annotation buttons in the button bar of the Annotation

editor (the status line gives an explanation), or
n click the right mouse button in the map window, and choose Add Annotation

from the context-sensitive menu.

Except for bitmaps and pictures, a display options dialog box follows.

To add bitmaps or pictures from disk to a map window
n use one methods described above, choose Bitmap or Picture,
n in the appearing Add BitMap or Picture dialog box, select a Bitmap (.BMP) or

Picture/Metafile (.WMF) from disk.

The bitmap or picture is displayed at the left top corner of the map window; you are
now in the Annotation editor.
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To add an ILWIS map as an inset-map to another map window
n display the map you want to use as inset-map,
n from the Edit menu in this map window, choose Copy,
n display the map in which you want the inset map to appear,
n from the Edit menu in that map window, choose Paste.

The inset-map is displayed at the left top corner of the map window; you are now in
the Annotation editor.

To add bitmaps and pictures via Clipboard to a map window
n open a Windows application program (for example Paintbrush),
n create a bitmap, picture, logo, graph, layed-out text, other graphics, etc.
n copy this to the clipboard,
n go to an ILWIS map window,
n from the Edit menu, choose Paste.
n The bitmap, picture, text or symbol is displayed at the left top corner of the map

window; you are now in the Annotation editor.

For more information, see Copying and Pasting through the clipboard.

F Before adding annotation to a map window, you might want to increase the size of
the map window, in order to have space for a title (text), the legend, etc. To achieve
this, you can select Extend Window from the Options menu in the map window.

F The Annotation editor allows for the positioning and sizing of annotation, and for
the insertion of new annotation.

F When finished adding and editing annotation, you can save the map window as a
map view: in the Annotation editor or in the map window, open the File menu and
choose the Save View or Save View As ... command.

8.2.2 How to add extra data layers to a map window

To add maps to an existing map window
n from the Layers menu, choose the Add Datalayer command and select Segment

map, Polygon map or Point map from the cascading menu, or
n from the Layers menu, choose the Layer Management command; use the Add

Map button in the dialog box which follows, or
n drag a point, segment or polygon map from the Catalog into the map window.

Before the extra layer is displayed, some display options have to be specified.
Then, the selected point, segment or polygon map will be displayed on top of the
other layers that are currently shown in the map window. When you selected a
raster map to be added to a map window, and the map window already displays a
raster map, then the newly selected raster map replaces the raster map the currently
shown raster map.
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A map window containing several data and annotation layers can be saved as a map
view.

See also: section 8.1.1 How to display maps and tables & zoom.
section 8.7.2 How to change display options of layers in a map

window.
section 8.2.1 How to add annotation to a map window.

8.2.3 How to add coordinates to a satellite image
To add coordinates to a satellite image, scanned photograph, scanned maps, etc.
create a georeference tiepoints. A georeference tiepoints stores the relation between
user-indicated points in the image (row,col) and coordinates (X,Y). These user-
indicated points are called tiepoints or control points. A georeference uses a
coordinate system.

To create a georeference tiepoints, you can display for example a color composite of
the bands in a map window, and choose the Create Georeference command from
the File menu in the map window. The Georeference tiepoints editor is
automatically started.
If you create a georeference tiepoints through the File menu of the Main window, or
through the Edit Properties dialog box of a raster map, you have to open the
Georeference tiepoint editor yourself, for example by double-clicking the newly
created georeference tiepoints in the Catalog.
For more information, see How to create a georeference.

Tiepoints or control points can be added to the image in the Georeference Tiepoints
editor. For each tiepoint, a relation should be established between the row and
column value in the map and an XY-coordinate.

In the Georeference Tiepoints editor, you can ad tiepoints to a map in several
manners:
n first, click at a recognisable point in the map without coordinates,
n the Add Tie Point dialog box appears. In this dialog box, the row and column

values at the position of the click are filled out. When you already have some
tiepoints, the dialog box will also come up with a suggestion for the XY
coordinates.

Then:
n click at the same position in a map which already has correct XY coordinates

and which is displayed in another map window (master/slave), or
n digitize the same point in an analog paper map which is stuck on a digitizer, or
n read the correct XY coordinates for this point from an analog paper map or a

table, and type these XY coordinates in the dialog box.

In the tiepoint editor, one of the following transformation methods can be selected:
conformal, affine, second order, full second order, third order and projective.
Usually, an affine transformation will do, but if the image is rather oblique, a
projective transformation can be selected.
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Once you have created a georeference tiepoints, it should be used for all bands of an
image. To ensure this, open the properties dialog box for the other bands, and select
the georeference tiepoints that you created (see also How to view and edit properties
of an object).

When a georeference tiepoints is created, these coordinates are added to the image;
you can:
n display any type of vector data on top of the map, and
n create new vector data using the georeferenced image as background, and
n update vector data using the georeferenced image as background, and
n use the map in pixel info, and
n rasterize any vector data on this georeference (for map calculations), and
n you can resample the map with the georeference tiepoints to another

georeference or vice versa in order to perform raster operations in which raster
maps with different georeferences are combined.

While creating a georeference tiepoints or a georeference tiepoints photo, you add
coordinates to the background map. To add this georeference to other bands of the
same image, edit the properties of these bands. In the Georeference Tiepoints
editor, you can already display any type of vector data on top of the map and use the
map in pixel info in order to check the accuracy of your tiepoints. When finished
creating the georeference tiepoints, you can rasterize any vector data on this
georeference (for map calculations), and you can resample the map with the
georeference tiepoints to another georeference or vice versa.

See also: section 8.10.12 How to create a georeference.
section 8.17.5 How to edit a georeference.

8.2.4 How to add columns to a table

To add an editable column to a table
n From the Columns menu, choose Add Column, or
n From the Columns menu, choose Column Management; the Column

Management dialog box appears; in this dialog box, click the Add Column
button, or

n In the table window, scroll to the last column and double-click to the right of
the last column on the grey column button.

The Add Column dialog box appears.

Any column created in one of these ways is always a source column, i.e. an editable
column. Even if you use this column later on as the output column of a calculation,
the column remains a source column.

To add a column which contains the answers of a calculation
n Type a TabCalc formula on the command line of the table window, or
n from Columns menu, choose use the Join, Aggregate, Cumulative or Least

Squares command, and fill out the appearing dialog box of this column
operation.

For more information on table calculation formulae, refer to Table Calculation.
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Columns created by typing a TabCalc formula on the command line in which you
use an equal symbol (=) are dependent columns. Columns that contain the result of
a join, aggregation, cumulative sum or least squares fit obtained through a dialog
box are also dependent columns. When you use an assignment symbol (:=) in a
TabCalc formula, the column is an editable source column.

8.3 How to aggregate column values
Several functions are available to aggregate values of a value column. Aggregation
means that you get one aggregate value, for instance the average or the sum, of a
whole column, or one value per group of class names. In this way, you can for
instance calculate the total area of each class.
Sometimes one item is considered to be more important than another item. Than,
weight values may be used during the calculation to express this difference in
importance.

Aggregations n aggregating values of all records of column a,
n aggregating values in column a for a group of records of

the same class (key column g), or
n aggregating values in column a for a group of records of

the same class (key column g) while using weight factors
in a weight column w.

To perform aggregations using the menu:
n open the table containing the column to aggregate
n open the Columns menu and choose Aggregation.

The Aggregate Column dialog box appears in which you specify:
n the value column that you want to aggregate
n the aggregation 'function' that you want to use
n if you want to group the data (e.g. according to soil classes): tick the “Group by”

box and select a column name
n if you want to use weights in a weight column (e.g. large areas are more

important than smaller ones), tick the “Weight” box and select the weight
column name (e.g. area)

n if you want to write the aggregation results in a separate table, tick the “Output
Table” box and  type a table name

n the Output Column name of the aggregation.

For examples of aggregations, see the aggregation functions described below.

To perform aggregations using the command line of the table window
n open the table containing the column to aggregate
n type your TabCalc formula on the command line of the table window, using one

of the following aggregation functions:  AGGAVG, AGGCNT, AGGMIN,
GGMED, AGGMAX, AGGPRD, AGGSTD, AGGSUM.
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Aggregation functions have 1, 2, or 3 arguments to specify how to perform the
calculation: (col, g, w).

The syntax used is as follows:: AGGAVG(col, g, w).

The first position gives the column (col) to aggregate; it needs always to be
specified.  The second and the third argument are optional. The second position is
to name the column (g) if you want to group the data. Finally, the third position is
to specify the column name (w) for assigning weight values.

F When no weight column is specified, then all data get the same weight value which
is per default 1.

F If you do not want to group the data but you do want to use a weight column then
only omit the column name to group but leave the commas in the syntax. For
example: AGGAVG(Col, ,w). Otherwise Ilwis can not make the distinction
between the column used to group or the column containing the weights.

F Refer for the complete list of Aggregation syntaxes to the appendices.
F Within the brackets, no expressions can be used.
F For ILWIS 1.41 users: argument g can be considered as the key column.

To aggregate the values of a column from another table
This requires specification of the table and columns to be used while the result is
written in the current table. The next example shows how to aggregate values from
a histogram table into an attribute table which you are working on:

Type in the command line of the table window:

Area = AGGAVG(Landuse.his.Area, Landuse)

Landuse.his Landuse.tbt
Parcel Area Parcel Landuse Value Weight Area

100 58200 100 Residential 4000 3 40139
124 16600 124 Residential 3500 2 40139
157 82540 157 Commercial 17500 1 67743
162 65925 162 Residential 7500 3 40139
181 8365 181 Industrial 20000 1 8365
202 82470 202 Institutional 12500 1 55935
225 19830 225 Residential 5000 4 40139
269 52945 269 Commercial 6000 2 67743
288 29400 288 Institutional 20800 2 55935
295 7235 295 Residential 5500 3 40139

The histogram table Landuse.his has a column Area (area of a parcel in
square metres). The table Landuse.tbt contains attribute data of the parcels. A new
column Area is created returning the average area per parcel for each Landuse
class.

To write output values into a new column of another existing table
The next example shows how to aggregate values into another  tabel than the one
you are working on.
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Use the following syntax:

Table2.NewCol = AGGAVG (Landuse.his.Area, Landuse.tbt
Landuse)

Landuse.his Landuse.tbt
Parcel Area Parcel Landuse Value Weight

100 58200 100 Residential 4000 3
124 16600 124 Residential 3500 2
157 82540 157 Commercial 17500 1
162 65925 162 Residential 7500 3
181 8365 181 Industrial 20000 1
202 82470 202 Institutional 12500 1
225 19830 225 Residential 5000 4
269 52945 269 Commercial 6000 2
288 29400 288 Institutional 20800 2
295 7235 295 Residential 5500 3

Table2
Parcel NewCol

100 40139
124 40139
157 67743
162 40139
181 8365
202 55935
225 40139
269 67743
288 55935
295 40139

Table2 is an existing table in your data set. The attribute table Landuse.tbt is in this
example the current table. Column Newcol in Table2 is assigned the average area
size per land use type. The area was found in the histogram table Landuse.his. The
column Landuse in the attribute table Landuse.tbt was used to group the data.

Examples of the aggregation function AGGAVG

Avg1 = AGGAVG(Value)

Avg2 = AGGAVG(Value,Landuse)

Avg3 = AGGAVG(Value,Landuse,Area)

Avg4 = AGGAVG(Value,,Area)

Parcel Landuse Value Area Avg1 Avg2 Avg3 Avg4
100 Residential 4000 58200 10230 5100 5509 10616
124 Residential 3500 16600 10230 5100 5509 10616
157 Commercial 17500 82540 10230 11750 13006 10616
162 Residential 7500 65925 10230 5100 5509 10616
181 Industrial 20000 8365 10230 20000 20000 10616
202 Institutional 12500 82470 10230 16650 14681 10616
225 Residential 5000 19830 10230 5100 5509 10616
269 Commercial 6000 52945 10230 11750 13006 10616
288 Institutional 20800 29400 10230 16650 14681 10616
295 Residential 5500 7235 10230 5100 5509 10616
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Column Avg1 shows the average value of all parcels. It does not matter which type
of land use is practiced on a parcel.
Column Avg2 shows the average value of the parcels grouped by the type of land
use. The weight factor is not taken into account.
Column Avg3 shows the weighted average value of the parcels per land use class.
The Area of each parcel is used as a weight value.
Column Avg4 shows the weighted average value of the parcels without grouping
the values per land use class. The Area of each parcel is used as a weight value.

Examples of the aggregation function AGGCNT

Cnt1 = AGGCNT(Value)

Cnt2 = AGGCNT(Value,Landuse)

Parcel Landuse Value Weight Cnt1 Cnt2
100 Residential 4000 3 10 5
124 Residential 3500 2 10 5
157 Commercial 17500 1 10 2
162 Residential 7500 3 10 5
181 Industrial 20000 1 10 1
202 Institutional 12500 1 10 2
225 Residential 5000 4 10 5
269 Commercial 6000 2 10 2
288 Institutional 20800 2 10 2
295 Residential 5500 3 10 5

Column Cnt1 shows the number of all parcels. It does not matter which type of land
use is practiced on a parcel.
Column Cnt2 shows the number of the parcels grouped by the type of land use.

F The use of weight values is not possible for this function.

Examples of the aggregation function AGGMAX

Max1 = AGGMAX(Value)

Max2 = AGGMAX(Value,Landuse)

Parcel Landuse Value Weight Max1 Max2
100 Residential 4000 3 20800 7500
124 Residential 3500 2 20800 7500
157 Commercial 17500 1 20800 17500
162 Residential 7500 3 20800 7500
181 Industrial 20000 1 20800 20000
202 Institutional 12500 1 20800 20800
225 Residential 5000 4 20800 7500
269 Commercial 6000 2 20800 17500
288 Institutional 20800 2 20800 20800
295 Residential 5500 3 20800 7500

Column Max1 shows the maximum value of all parcels. It does not matter which
type of land use is practiced on a parcel.
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Column Max2 shows the maximum value of the parcels grouped by the type of land
use. The weight factor is not taken into account.

F The use of weight values is not possible for this function.

Examples of the aggregation function AGGMED

Med1 = AGGMED(Value)

Med2 = AGGMED(Value,Landuse)

Med3 = AGGMED(Value,Landuse,Weight)

Med4 = AGGMED(Value,,Weight)

Parcel Landuse Value Weight Med1 Med2 Med3 Med4
100 Residential 4000 3 7500 5000 5000 5500
124 Residential 3500 2 7500 5000 5000 5500
157 Commercial 17500 1 7500 17500 6000 5500
162 Residential 7500 3 7500 5000 5000 5500
181 Industrial 20000 1 7500 20000 20000 5500
202 Institutional 12500 1 7500 20800 20800 5500
225 Residential 5000 4 7500 5000 5000 5500
269 Commercial 6000 2 7500 17500 6000 5500
288 Institutional 20800 2 7500 20800 20800 5500
295 Residential 5500 3 7500 5000 5000 5500

Column Med1 shows the median value of all parcels. It does not matter which type
of land use is practiced on a parcel.
Column Med2 shows the median value of the parcels grouped by the type of land
use. The weight factor is not taken into account.
Column Med3 shows the weighted median value of the parcels per land use class.
Column Med4 shows the weighted median value of the parcels without grouping
the values per land use class.

Examples of the aggregation function AGGMIN

Min1 = AGGMIN(Value)

Min2 = AGGMIN(Value,Landuse)

Parcel Landuse Value Weight Min1 Min2
100 Residential 4000 3 3500 3500
124 Residential 3500 2 3500 3500
157 Commercial 17500 1 3500 6000
162 Residential 7500 3 3500 3500
181 Industrial 20000 1 3500 20000
202 Institutional 12500 1 3500 12500
225 Residential 5000 4 3500 3500
269 Commercial 6000 2 3500 6000
288 Institutional 20800 2 3500 12500
295 Residential 5500 3 3500 3500
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Column Max1 shows the minimum value of all parcels. It does not matter which
type of land use is practiced on a parcel.
Column Max2 shows the minimum value of the parcels grouped by the type of land
use. The weight factor is not taken into account.

F The use of weight values is not possible for this function.

Examples of the aggregation function AGGPRD

Prd1 = AGGPRD(Units)

Prd2 = AGGPRD(Units,Landuse)

Prd3 = AGGPRD(Units,Landuse,Area)

Prd4 = AGGPRD(Value,,Area)

Parcel Landuse Units Area Prd1 Prd2 Prd3 Prd4
100 Residential 5 58200 4 4 4 5
124 Residential 4 16600 4 4 4 5
157 Commercial 12 82540 4 9 12 5
162 Residential 4 65925 4 4 4 5
181 Industrial 3 8365 4 3 3 5
202 Institutional 5 82470 4 5 5 5
225 Residential 7 19830 4 4 4 5
269 Commercial 9 52945 4 9 12 5
288 Institutional 6 29400 4 5 5 5
295 Residential 4 7235 4 4 4 5

Column Prd1 shows the predominant number of units on each parcel. It does not
matter which type of land use is practiced on a parcel.
Column Prd2 shows the predominant number of units on each parcel, grouped by
the type of land use. The weight factor Area is not taken into account.
Column Prd3 shows the weighted predominant number of units on each parcel, per
land use class. The size of the Area is taken as weight factor.
Column Prd4 shows the weighted predominant number of units on each parcel
without grouping the values per land use class. The size of the Area is taken as
weight factor. Since the Parcels with 5 units are relatively large the outcome is 5.

Examples of the aggregation function AGGSTD

Std1 = AGGSTD(Value)

Std2 = AGGSTD(Value,Landuse)

Std3 = AGGSTD(Value,Landuse,Weight)

Std4 = AGGSTD(Value,,Weight)
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Parcel Landuse Value Weight Std1 Std2 Std3 Std4
100 Residential 4000 3 6514.3 1392.8
124 Residential 3500 2 6514.3 1392.8
157 Commercial 17500 1 6514.3 5750.0
162 Residential 7500 3 6514.3 1392.8
181 Industrial 20000 1 6514.3 0.0
202 Institutional 12500 1 6514.3 4150.0
225 Residential 5000 4 6514.3 1392.8
269 Commercial 6000 2 6514.3 5750.0
288 Institutional 20800 2 6514.3 4150.0
295 Residential 5500 3 6514.3 1392.8

Column Std1 shows the standard deviation of all parcels. It does not matter which
type of land use is practiced on a parcel.
Column Std2 shows the the standard deviation of the parcels grouped by the type of
land use. The weight factor is not taken into account.
Column Std3 shows the the standard deviation of the parcels per land use class.
Column Std4 shows the the standard deviation of the parcels without grouping the
values per land use class.

Examples of the aggregation function AGGSUM

Std1 = AGGSUM(Value)

Std2 = AGGSUM(Value,Landuse)

Parcel Landuse Value Sum1 Sum2
100 Residential 4000 102300.0 25500.0
124 Residential 3500 102300.0 25500.0
157 Commercial 17500 102300.0 23500.0
162 Residential 7500 102300.0 25500.0
181 Industrial 20000 102300.0 20000.0
202 Institutional 12500 102300.0 23500.0
225 Residential 5000 102300.0 25500.0
269 Commercial 6000 102300.0 23500.0
288 Institutional 20800 102300.0 33300.0
295 Residential 5500 102300.0 25500.0

Column Sum1 shows the sum of all parcels. It does not matter which type of land
use is practiced on a parcel.
Column Sum2 shows the the sum of the parcels grouped by the type of land use.
The weight factor is not taken into account.

8.4 How to break dependency links
Dependent maps, tables and columns are the result of a calculation with MapCalc
or TabCalc (in which you used the definition sign =) or the result of another
operation. The complete expression by which dependent output objects are created
is stored by the output maps, tables and columns as their definition. Dependent data
objects thus know how they were created and on which input data they depend.

In principle, dependent data objects cannot be edited as the results of calculations
or operations need to be protected.
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If you do want to edit a dependent map, a dependent table or a dependent column,
you need to break the dependency links first. Breaking dependency links means that
the map, table or column no longer knows how it is created nor from which maps,
tables or columns it was created.

To break dependency links of dependent maps and dependent tables
n select a dependent map or table in the Catalog,
n press the right mouse button,
n choose Properties from the context-sensitive menu, or
n open the Edit menu in the Main window,
n choose Properties,
n select a dependent data object.

The Properties dialog box of the dependent map or table appears; click the button
Break Dependency Link.

When a dependent map is displayed in a map window, or when a dependent table is
displayed in a table window, you can also open the Edit menu in the map or table
window and select the Properties command. The Properties dialog box of that map
or table then appears; to break the dependency link, click the button Break
Dependency Link.

To break dependency links of dependent columns
n open a table in a table window,
n double-click the column button (which displays the column name) of a

dependent column, or
n from the Columns menu, choose Column Management, a dialog box appears in

which all columns are listed, then
n double-click a column in the list, or select a column in the list and click the

Properties button.

The Column Properties dialog box appears; click the button Break Dependency
Link.

To break dependency links on the command line or in scripts
You can also break dependency links by typing the following on the command line
in the Main window or in a script:

breakdep object.ext

For object.ext fill out the object name and extension. It is also allowed to use the
DOS wildcards * and ?. For more information, see Appendices : script language
(syntax).

To break the dependencies of all raster maps starting with A, you can thus type:

breakdep a*.mpr

To break the dependencies of all objects in this directory, you can thus type:

breakdep *.*
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See also: section 8.23 How to make dependent data objects up-to-date.
section 8.7.1 How to change the definition of dependent data 

objects.
section 8.29 How to release disk space.

8.5 How to calculate

8.5.1 How to calculate an aspect map
An aspect map shows to which side a slope is directed. An aspect value of 0 means
that the slope is facing the North.
To calculate aspect maps maps in radians and degrees:
1. Create a segment map with a value domain (it is advised to create a value

domain Height). Digitize the contour lines and give the contour lines the height
value they represent.

2. To create an interpolated height map from segment contour lines: open the
Operations menu in the Main window, choose Interpolation, then choose
Contour Interpolation. The output map is a Digital Elevation Model (DEM).
Keep in mind the pixel size that you are using.

3. To calculate height differences in X-direction: start the Filter operation, select
the Digital Elevation Model as the input map and select linear filter dfdx. Call
the output map for example DX.

4. To calculate height differences in Y-direction: start the Filter operation again,
select the Digital Elevation Model as input map and select linear filter dfdy.
Call the output map for example DY.

5. To calculate an aspect map in radians from these maps DX and DY, type on the
command line of the Main window:

ASPECTR = ATAN2(DX,DY) + PI

6. To convert the percentage values into degrees, type:

ASPECTD = RADDEG((ASPECTR))

If you wish, you can combine the statements of steps 5 and 6 into one statement:

ASPECTD = RADDEG(ATAN2(DX,DY) + PI)

Functions ATAN2 and RADDEG are internal MapCalc/TabCalc functions.
ASPECTR and ASPECTD are the output map names of the aspect maps in
radians and degrees respectively.

F When you start creating the segment map for the contour lines, it is advised to
create a user-defined value domain Height. Afterwards you can then create a user-
defined representation Height for this domain. You can change the colors of this
representation in the Representation Value/Gradual editor.

F The easiest way classify the values in your aspect map is to create a new
representation value for the output aspect map. For more information, see How to
classify a map.
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See also: section 8.8 How to classify a map.
section 8.6.1 How to calculate a classified aspect map (advanced).
section 8.5.7 How to calculate a slope map.

8.5.2 How to calculate a confusion matrix
One of the most common means of expressing classification accuracy is the
preparation of a confusion matrix.
A confusion matrix contains a comparison of some additional groundtruth which
has not been used to train the classifier, the so-called test set and the classification
result (See also: Classify).

It is not recommeded to use the same sample map for both the classification and the
accuracy assessment, because this will produce too optimistic figures. So, it is better
to make a second set, the test set, that contains some additional ground thruth. The
test set map must be in raster format.

The normal procedure is to prepare the test set in the same way as you create a
sample set during the training phase (See also Create a sample set). The resulting
map can be crossed with the classified image and the result presented in a
confusion matrix.

To calculate a confusion matrix it is assumed that a classification is already
performed and a test set is available. The following steps are to be taken:
n from the Operations menu in the Main window, choose the Raster Operations

command and Cross, or
n double-click the Cross item in the Operation-list, or
n use the right mouse button on a test set in the Catalog and select the Raster

Operations and Cross.

The cross dialog box appears.
n Select as first input map the test set map, as second map the classified image

and give a name for the output table (See also: Cross). Display the output table.
n To display the confusion matrix, choose Options command in the table window

and select option confusion matrix.

The Confusion matrix dialog box appears.

In the first column the test set must be selected. In the second column you select the
classified image. In the frequency you select the NPix. After OK is pressed the
confusion matrix is presented.

In the confusion matrix only the pixels of the test set are presented that are crossed
with “classified” pixels in the classified image. Note that the classified image can
contain some undefined values (“unclassified” pixels). Pixels in the test set that are
crossed with one of the undefined values in the classified image are not presented
in this matrix. It means that not all pixels of the test set are presented in the
confusion matrix.
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8.5.3 How to calculate a Digital Elevation Model
In ILWIS, you can obtain a Digital Elevation Model (DEM) by interpolation of
segments, by an interpolation of points, or by an interpolation of a raster map
which contains rasterized value segments and points.

From Segments
Digitize the contour lines of a segment map with a value domain. Make sure that
contour lines that consist of more than one segment have the same value. Code
consistency of segments can be checked in the Segment editor.

Then perform a Contour interpolation. Contour interpolation is an operation which
first rasterizes the contour lines in a segment map with a value domain, and then
calculates values by means of a linear interpolation for pixels that are not covered
by segments.
For the Contour interpolation operation, you can also use a segment map with a
class or ID domain as input, then the segment map must have an attribute table
with a value column representing height values.

To create a Digital Elevation Model from Segments
n from the Operations menu in the Main window, choose Interpolation, Contour

Interpolation, or
n double-click the InterpolSeg operation in the Operation-list, or
n use the right mouse button on a segment map in the Catalog and select Contour

Interpolation from the context-sensitive menu.

The Contour Interpolation dialog box appears.

From Points
Perform a point interpolation on your point map. A point interpolation performs an
interpolation on randomly distributed point values and returns regularly distributed
point values. This is also known as gridding. In ILWIS, the output values are raster
values.

The input map for a point interpolation is a point map where:
n points are values (point map with a value domain), or
n points are identifiers (point map with an ID domain) and for which elevation

values are stored in a column in a linked attribute table.

To create a Digital Elevation Model from Points
n from the Operations menu in the Main window, choose Interpolation, Point

Interpolation, Moving Average or Moving Surface, or
n double-click the MovAverage or MovSurface operation in the Operation-list, or
n use the right mouse button on a point map in the Catalog and select

Interpolation, Moving Average or Moving Surface.

The Moving Average dialog box or the Moving Surface dialog box appears.
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F Point interpolation is a time consuming operation, to speed up the process the user
is advised to use a relatively large pixel size during the interpolation and perform
the Densify operation after the interpolation. Densify is a raster operation which
lets you reduce the pixel size of your map. The number of rows and columns is
increased, and new values are assigned to the pixels by means of a bilinear or
bicubic interpolation.

From Segments with additional Point data
1. Digitize the contour lines of a segment map with a value domain. Rasterize the

segment map with the Segments to Raster operation:
n from the Operations menu in the main window, choose Rasterize, Segment

to Raster,
n double-click the SegRas operation in the Operation-list, or
n use the right mouse button on the segment map in the Catalog and select

Rasterize, Segment to Raster from the context-sensitive menu.

2. If you have a point map with a value domain, rasterize the point map with the
Points to Raster operation:
n from the Operations menu in the main window, choose Rasterize, Point to

Raster,
n double-click the PntRas operation in the Operation-list, or
n use the right mouse button on the point map in the Catalog and select

Rasterize, Point to Raster from the context-sensitive menu.

 If you have a point map that contains points with identifiers (point map with an
ID domain) for which elevation values are stored in a column in a linked
attribute table, rasterize the point map with the Points to Raster operation (see
2a) and in the Rasterize Point Map dialog box, select the correct column in
which your elevation data is stored.

 
 Use the same georeference for both the rasterized segment and rasterized point

map.
 
3. Then, combine the two raster maps by typing the following MapCalc expression

on the command line of the Main window:

 PNTSEG = iff(isundef(pntras), segras, pntras)

 where:
 PNTSEG is the output raster map name of the combined point and segment

map
 pntras is the name of the rasterized point map
 segras is the name of the rasterized segment map
 
4. Finally, interpolate the PNTSEG raster map. Therefore type in the command

line:

DEM = MapInterpolContour(PNTSEG)
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Visualize a DEM
To visualize a DEM, you can simply the DEM in a map window or apply the
Shadow filter on the DEM and display the filtered map in a map window; you can
overlay the contour lines in one color. Further, you can use Display 3D to create a
three-dimensional view of your study area. For more information and an example,
see How to display Digital Elevation Models.

See also: section 8.15.1 How to display Digital Elevation Models.

8.5.4 How to calculate a histogram
A histogram can be calculated for any raster, polygon, segment or point map.

To calculate a histogram
n use the Histogram operation on the Operations menu (Statistics), or
n double-click the Histogram operation in the Operation-list, or
n choose Statistics, Histogram from the context-sensitive menu when clicking the

right mouse button on a map in the Catalog, or
n drag a map from the Catalog to the Histogram command in the Operation-list.
For more information on how to show existing histograms in the Catalog, refer to
How to customize the Catalog.

8.5.5 How to calculate NDVI
To calculate NDVI (Normalized Difference Vegetation Index) values, you can use
the MapCalc function NDVI(a,b).

This function requires 2 satellite bands (one with visible or red values and the other
near-infra red values). The function performs the calculation:

(b - a) / (a + b)

When using the NDVI(a,b) function, replace a with the band with visible or red
reflectance, and b with the band with near-infrared reflectance.

Example
If TmBand3 is the band with red values, and TmBand4 is your band with near-infra
red values, type on the command line of the Main window:

VegInd = NDVI(TmBand3,TmBand4)

Output map VegInd contains NDVI values.

NDVI values range from  -1 to 1:
n Vegetated areas will generally yield high values because of their relatively high

near-infrared reflectance and low visible reflectance.
n In contrast, water, clouds, and snow have larger visible reflectance than near-

infrared reflectance. Thus, these features yield negative index values.
n Rock and bare soil areas have similar reflectances in the two bands and result in

vegetation indices near zero.
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8.5.6 How to calculate an Optimum Index Factor
To obtain multivariate statistical information of a data set, the optimum index
factor (O.I.F.) for 3-band combinations can be calulated.

A map list is needed as input, for which the Variance-covariance matrix or the
correlation matrix is (already) calculated. These matrices are stored internally in
the map list.

To show the O.I.F
n you have to view the properties of the map list:
n from the Edit menu in the Main window, choose Properties, and select a map

list, or
n press the right mouse button on a map list in the Catalog, and choose Properties

from the context-sensitive menu.

The Properties dialog box of the map list appears.
n click the button ‘Additional Info’

Note that it is necessary to calculate one of these two matrices before calculating the
O.I.F, otherwise no button ‘Additional Info’ will be shown in the properties dialog
box.

A table is displayed containing the ranked O.I.F. values and corresponding band
combinations.

See also: section 8.10.16 How to create a map list.

8.5.7 How to calculate a slope map
To calculate slope maps in percentages and in degrees:
1. Create a segment map with a value domain (it is advised to create a value

domain Height). Digitize the contour lines and give the contour lines the height
value they represent.

2. To create an interpolated height map from segment contour lines: open the
Operations menu in the Main window, choose Interpolation, then choose
Contour Interpolation. The output map is a Digital Elevation Model. Keep in
mind the pixel size that you are using.

3. To calculate height differences in X-direction: start the Filter operation, select
the Digital Elevation Model as the input map and select linear filter dfdx. Call
the output map for example DX.

4. To calculate height differences in Y-direction: start the Filter operation again,
select the Digital Elevation Model as input map and select linear filter dfdy.
Call the output map for example DY.
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5. To calculate a slope map in percentages from these maps DX and DY, type on
the command line of the Main window:

 SLOPEPCT = ((HYP(DX,DY))/ pixel size)*100

 Fill out the pixel size of the maps. HYP is an internal Mapcalc/Tabcalc
function. SLOPEPCT is the output map name of the slope map in percentages.

6. To convert the percentage values into degrees, type:

 SLOPEDEG = RADDEG(ATAN(SLOPEPCT/100))

Function ATAN and RADDEG are internal MapCalc/TabCalc functions.
SLOPEDEG is the output map name of the slope map in degrees.

Mind: the following slope values are the same: 30°= 58%, 45°= 100%, 60°= 173%,
80°= 567%. As you see, slope values in the SLOPEPCT map can be greater than
100%.

F When you start creating the segment map for the contour lines, it is advised to
create a user-defined value domain Height. Afterwards you can then create a user-
defined representation Height for this domain. You can change the colors of this
representation in the Representation Value/Gradual editor.

F You can also create a script to perform steps 2 through 6 described above. For more
information, see Map & Table calculation : creating and running scripts.

F To classify the values of the slope maps, there are two possibilities:
1. Create a new representation value for the output slope map and adapt the colors

in the Representation Value/Gradual editor. For more information, see How to
classify a map.

2. Create two domain Groups, for example: classes 0-10%, 10-25%, 25-50%, 50-
100%, >100% for the slope map in percentages and classes 0-6°, 6-12.5°, 12.5-
22.5°, 22.5-45°, >45° for the slope map in degrees. Then, use these domain
groups in the Slicing operation.

See also: section 8.8 How to classify a map.
section 8.5.1 How to calculate an aspect map.
section 8.6.1 How to calculate a classified aspect map (advanced).

8.5.8 How to calculate with maps and tables
For information on How to calculate with maps, see chapter 6 Map calculation.
For information on How to calculate with tables, see chapter 6 Table calculation.

8.5.9 How to calculate with class names or IDs in maps and tables
When using class names or IDs in an MapCalc or TabCalc expression, these class
names or IDs should be put between double quotes.

For example, if you want to assign a 1 in a new map Result to all areas in map
Landuse where , and a 0 to all other landuse classes, you can use the following
formula:
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Result = iff(landuse = “coffee”,1,0)

Landuse: Result1:

Read in the Landuse map for B: Bare, for C: Coffee, and for S: Shrub.

The same formula can be used in Table calculation when you want to assign a 1 to
all fields in column Landuse where the landuse class is coffee.

Parcel Landuse Result
01256 Coffee 1
01257 Banana 0
01258 Rice 0
01259 Maize 0
01260 Coffee 1
01261 Maize 0

8.5.10 How to calculate with undefineds in maps and tables
You might want to:
n test for undefined values, class names or IDs in maps or columns and assign

those another value, class name or  ID, or
n assign undefined values, class names or IDs to certain existing values, classes or

IDs.

Testing for undefineds
To test for undefined values, use the ISUNDEF function. The ISUNDEF(a)
function tests whether a is undefined. Argument a can be the outcome of an
expression or simply a map or column name.
Below, the ISUNDEF function is combined with a conditional IFF.

Result1 = iff (isundef(landuse), “mountains”, landuse)
Result2 = iff (isundef(population), 1000, population)

First formula (on a domain Class map or column)
If a pixel in map/field in column Landuse is undefined, then class name
“Mountains” is assigned to this pixel in map/field in column Result1; else the
original class name is assigned.

Second formula (on a domain Value map or column)
If a pixel of map/field in column Population is undefined, then value 1000 is
assigned to this pixel in map/field in column Result2; else the original population
value is assigned.
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Assigning undefined values
To assign undefined values, use a question mark when the output domain is a
domain Value, and use a question mark in between double quotes when the output
domain is a domain Class or ID. Below, examples are given of the ISUNDEF
function combined with a conditional IFF.

Result3 = iff (landuse = “mountains”, “?”, landuse)
Result4 = iff (popuplation = 1000, ?, population)

Third formula (output domain Class or ID)
If a pixel in map/field in column Landuse has class name “Mountains”, then
undefined is assigned to this pixel in map/filed in column Result3; else the original
class name is assigned.

Fourth formula (output domain Value)
If a pixel in map/field in column Population has value 1000, then undefined is
assigned to this pixel in map/field in column Result4; else the original Population
value is assigned.

8.6 How to calculate (advanced)

8.6.1 How to calculate a classified aspect map
An aspect map shows to which side a slope is directed. A classified aspect map does
not show the angle in radians or degrees but only a limited number of classes. To
calculate an aspect map, refer to How to calculate an aspect map.

When you already calculated an aspect map, you can classify that map by creating a
new representation value for the map, or by creating and applying a Group domain
on it with the Slicing operation. For more information, refer to How to classify a
map.

This topic deals with the direct calculation of a classified aspect map by using a
neighbourhood function. Although the commands to use are rather simple, this
topic is considered to be for advanced users because of the concepts of
neighbourhood operations.

1. Create a segment map with a value domain (it is advised to create a value
domain Height). Digitize the contour lines and give the contour lines the height
value they represent.

2. To create an interpolated height map from segment contour lines: open the
Operations menu in the Main window, choose Interpolation, then choose
Contour Interpolation. The output map is a Digital Elevation Model (DEM).
Keep in mind the pixel size that you are using.

3. The DEM is used as the input map in a neighbourhood operation. In the
neighbourhood function NBMINP, a pixel is assigned the position number of
the lowest value of all neighbours in a moving window of 3 by 3 cells. The
pixels in the moving window are coded as follows:
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 1 2 3
 
 4 5 6
 
 7 8 9

 The direction of the slope in the classified aspect map is found according the
position of the neighbour with the lowest value:

 
 Pixel value:  Direction:
 1  NW
 2  N
 3  NE
 4  W
 5  Flat
 6  E
 7  SW
 8  S
 9  SE

 
1. To calculate the classified aspect map, type in the command line of the Main

window:
 

ASPECT = NBMINP(DEM#)
 
 The output map contains values 1, 2, 3, ... 9.
 
 As an example, part of a DEM and the corresponding pixels in the classified

aspect map are displayed below.

DEM ASPECT

See also: section 8.5.1 How to calculate an aspect map.
section 8.5.7 How to calculate a slope map.

8.6.2 How to calculate distances using iterations
A distance map shows the minimum distance towards user-specified source pixels,
for instance to schools, to roads, etc. To obtain a distance map, refer to the
operation Distance calculation.
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This topic deals with the direct calculation of distance values by using iteration
functions with propagation. As this requires quite some insight in the working of
neighbourhood operations and iterations, it is considered a topic for advanced
users.

You may calculate the distance from pixels in a map to one or more specified
pixels. To do so you need to create a startmap in which you find these specified
pixels. It is recommended to assign the start pixels value 0, because the output map
contains pixel values which are the sum of the distance between the two pixels and
the value of the pixel in the start map.

The distance calculation in a neighbourhood operation uses a predefined filter
NBDIS. This is a 3 by 3 filter as shown below:

√ 2 1 √ 2

1 0 1

 √ 2 1  √ 2

Preparation
1. To create the start map, you have to use the pixel editor.

Display the map showing the area in which you want to perform the distance
calculation in a map window. In the map window, choose File, Create, Create
Raster Map.

The Create Raster Map dialog box appears.

In the Create Raster Map dialog box:
n Fill in the new map name (e.g. START);
n Accept the default georeference which is the same as the georeference of the

map displayed in the map window;
n Select system domain Value; either accept the default value range and

precision or make sure that the input value range is sufficient, i.e. wide
enough, to contain the future output distance values; make sure that the
precision is set to 0.1.

n Then click OK.

The Pixel editor is opened. Zoom in on the area where the distance calculation
should start. Use the left mouse button to select the pixels from which the
distance calculation should start, while you hold down the Ctrl key of the
keyboard. When the correct pixels are selected,  assign these pixels value 0.

Leave the pixel editor: the map START has one or several defined pixels with
value 0, the rest is undefined. Display the map START to force calculation.
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START

Iteration with propagation
Now the actual distance calculation can be performed by performing an
Iteration with propagation, until there are no changes appear anymore in any of
the pixel values.

First, the NBDIS filter will be applied on the START map and results will be
stored in a temporary map.

2. To start the calculation, double-click the Iteration item in the Operation-list.

The Iteration dialog box appears:
n For Start Map, select START.
n Type for the Expression:

 NBMIN(START# + NBDIS)
 This means: Calculate for every neighbouring pixel the temporary distance

to the nearest specified pixel in the start map; and store the results in output
map TEMP.

n Accept the default Until No changes as the Stop criterium;
n Keep the option Propagation selected because then the new pixel value is

immediately used in the calculation of the next pixel;
n Type TEMP as the name of output raster map;
n Select the Show check box;
n Select the Defaults button, then accept the Value domain;
n Then click OK.

You may also type directly in the command line of the Main window:

TEMP = MAPITERPROP(START, NBMIN(START# + NBDIS))

3. The calculation starts, then the Display Options dialog box of the output map
TEMP appears. Accept the default display options, the pixel values represent
the nearest distance to the earlier specified pixel(s). The pixel size is not taken
into account yet.

4. Finally, to obtain distance values in meters, the temporary results have to be
multiplied with the pixel size of the map.
You can look up the pixel size of the map in the properties of the map; you can
also type the following expression on the command line of the Main window:

MAPDIS = (TEMP * PIXSIZE(START))
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TEMP MAPDIS

Map MAPDIS is the result of the distance calculation. The starting pixels have
value 0. After the iterations with propagation, each pixel in map MAPDIS
represents the shortest distance to the starting pixels.

You may combine steps 2, 3, and 4 by typing the following expression on the
command line of the Main window:

DISTC= MAPITERPROP(NBMIN(START# +
NBDIS*PIXSIZE(START))

This iteration expression however can be a time consuming one, especially
when you use large maps.

8.6.3 How to calculate flooded area and water volume after
construction of a dam (example)

When a dam is constructed in a valley, an area upstream will be flooded up to a
certain water level.
To determine the exact area to be flooded you can use neighbourhood operations in
ILWIS. Then, you can also calculate the volume of the water body.

Preparations
1. The first step is determination of the dam site, dam altitude, freeboard and the

designed water level h. In this example, the upper side of the dam will be at an
altitude of 3360 m; the freeboard of the dam is 20 m; the actual water level will
be at 3340 m altitude.

2. A Digital Elevation Model (DEM) of the area should be available. For more
information, see How to calculate a DEM.

3. Then, make a raster map showing the exact location of the dam. To do so, start
with displaying the DEM and  use the pixel editor to create a new raster map.
Choose in the menu of the map window File, Create, Create Raster Map.

The Create Raster Map dialog box appears:
n Fill in the new map name (e.g. DAM);
n Choose the Georeference which is used in the DEM (accept the default);
n Select the system Value domain; then click OK.

The Pixel editor is opened. Zoom in on the area where you want to build the
dam. Then select pixels which will form the dam in map DAM. The pixels
indicating the dam should be properly 4-connected (see figures below). When
pixels are only 8-connected, pixels at the opposite side of the dam are also used
in the calculation later on.
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Wrong: Correct:

Use the left mouse button to select the pixels while you hold down the Ctrl key
of the keyboard. When the correct pixels are selected, give the dam the value of
the altitude of the top of the dam (in this example 3360).

4. To combine the DEM and the raster map DAM, type on the command line of
the Main window:

DEMNEW = IFUNDEF(DAM,DEM, DAM)

This means that if a pixel in map DAM is undefined, the value of the DEM is
assigned, else the value given in map DAM. Thus the altitude of the dam (in
this example 3360m) is included in the Digital Elevation Model.

Display the output map DEMNEW to force calculation.

5. To determine the area that will be flooded you need to create a map indicating
one pixel in this area. Using neighbourhood operations this pixel acts as the
starting point for the calculation. Use the pixel editor to create the new raster
map. First, display map DEMNEW and choose File, Create, Create Raster Map
from the menu in the map window.

Then fill out the Create Raster Map dialog box:
n In this example, type START for name of the new raster map;
n Select the same georeference as was used in DEMNEW;
n Select the system Bool domain.

Select a pixel in the area which will be flooded, double-click this pixel and
mark it 'True'.

Leave the pixel editor: the map START has only one defined pixel, the rest is
undefined. Display the map START to force calculation.

Calculating the flooded area
6. Now the the actual calculation of the area can be performed. Iteration with

propagation is used until there are no changes anymore in any of the pixel
values. In this example, the upper side of the dam is at an altitude of 3360 m;
the freeboard of the dam is 20 m; the actual water level is at 3340 m altitude. To
start the calculation, double-click the Iteration item in the Operation-list.

The Iteration dialog box appears:
n For Start Map, select START.
n Type for the Expression:

IFF (DEMNEW > 3340, START, NBMAX(START#))
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This means: if the altitude in the new Digital Elevation Model is higher than
3340 m (the desired water level), then return the pixel values of raster map
START (which are undefined). Else, assign the maximum value of the
neighbouring pixels found in raster map START. In the first iteration there is
only one starting pixel which is 'True'. Then in every next iteration, the
neighbours of the True pixel(s) will be assigned True as will, as long as these
pixels have an altitude less than 3340 m.
n Accept the default Until No changes as the Stop criterium;
n Keep the option Propagation selected because then the new pixel value is

immediately used in the calculation of the next line;
n Type FLOODED as the name of output raster map;
n Select the Show check box;
n Select the system Bool domain;
n Then click OK.

7. The calculation starts, then the Display Options dialog box of the output map
FLOODED appears. Accept the default display options, the area which will be
flooded appears on the screen (True values, other pixels are undefined).

8. To find out the size of the flooded area you calculate a histogram by double
clicking the Histogram item in the Operation-list; select map FLOODED. You
can read the size of the area which is flooded (True) from the histogram table.

Calculating the water volume
9. The next step is the calculation of the volume of the water body.
 Therefore, you can Cross the newly calculated map FLOODED with map

DEMNEW. The crossing of two value maps may be a relatively time consuming
process. To reduce calculation time and the size of the output cross table, you
can create another DEM which only shows the original heigth values of the area
that will be flooded, while all other pixels have the undefined value. To do so,
type the following expression on the command line of the Main window:
DEMSMALL = IFF(FLOODED, DEMNEW, ?)

This means that for the flooded area the values of the DEM will be used, while
all other pixels are assigned the undefined value; these undefined values are not
taken into account in the cross operation.

10. To start the Cross operation, double-click Cross in the Operation-list.
The Cross dialog box appears.
n Select for the first map FLOODED;
n Select for the second map DEMSMALL;
n Type FLOODDAM as the name for the output cross table;
n Select the Show check box.
n Do not select the Output Map check box.
n Click OK.
The cross table is calculated and is displayed on the screen. It shows the
combinations of input values of the map FLOODED and the map DEMSMALL,
the number of pixels that occur for each combination and the area for each
combination.
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11. In the cross table, you can calculate the water depths by subtracting the altitude
given in column DEMSMALL from the planned water level (3340 m).
Type the command line of the table window:

DEPTH = 3340 - DEMSMALL

Then calculate the volumes of the depths as follows:

VOL = DEPTH * Area

Finally, sum all volumes of all different water depths together. This can be done
using the aggregation function AGGSUM.

SUM = AGGSUM (VOL)

Column SUM shows the total volume of water in cubic meters for the entire
area which will be flooded after creating the dam.

8.7 How to change

8.7.1 How to change the definition of a dependent data object
Dependent raster maps that are the result of a calculation with MapCalc and
dependent columns that are the result of a calculation with TabCalc, have an
editable definition. The formula or expression with which a dependent raster map
(MapCalculate) or a dependent column (ColumnCalculate) is created, is stored in
the object definition file of the object, can be viewed in the properties dialog box of
the object and can also be changed there.

You can thus simply redo a calculation with a slightly different formula in the same
map or the same column without the need of creating another new map or column.

You can only edit the definition of MapCalculate maps and ColumnCalculate
columns; expressions of other dependent objects created by other operations (such
as MapFilter, MapDistance, MapCross) cannot be edited. For maps created by an
operation, the properties dialog box allows you to select another output domain, and
in case of a value domain adjust the value range and precision with which values
are to be stored for the output map.

To edit the definition a dependent raster map
n select a dependent raster map in the Catalog,
n press the right mouse button,
n choose Properties from the context-sensitive menu,

or
n open the Edit menu in the Main window,
n choose Properties,
n select a dependent data object.
The Raster Map Properties appears; click the button Edit Definition.
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Subsequently, the Raster Map Definition dialog box appears in which you can
change the expression by which the raster map is created, select a domain and in
case of a value domain, specify the value range and precision with which the values
in the output map should be stored. When you click the OK button, the raster map
is redefined.

To edit the definition of a dependent column
The table which contains the dependent columns should be displayed in a table
window. Then,
n double-click the column button (which displays the column name) of a

dependent column,
or

n from the Columns menu, choose Column Management, a dialog box appears in
which all columns are listed, then

n double-click a column in the list, or select a column in the list and click the
Properties button.

The Column Properties dialog box appears in which you can change the expression
by which the column is created, select a domain and in case of a value domain,
specify the value range and precision with which the values in the output column
should be stored. When you click the OK button, the column is redefined and
immediately recalculated.

See also: see section 8.38 How to view and edit the properties of an object.

8.7.2 How to change display options
Before a map or annotation is displayed in a map window, you have to answer some
questions on how this layer should be displayed in the map window:
you have to specify the display options. Also, once one or more data and/or
annotation layers are displayed in a map window, you might want to change the
display options of a certain layer.

To change display options of a data layer
n in a map window, open the Layers menu, choose Display Options and select a

layer from the cascading menu, or
n in a map window, open the Layers menu, choose the command Layer

Management, or
n click the right mouse button in a map window and select a layer from the

context-sensitive menu.

A Display Options dialog box follows in which you can change the colors of the
layer, line width, etc.

To change the display options of an annotation layer
When you are in the Annotation editor you can simply double-click an annotation
layer, except a grid line layer or a graticule layer. For these layes and when you are
in a map window, you can use one of the methods described above.
A Display Options dialog box follows.
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Additional information
On cascading menus, on context-sensitive menus, active layers are marked by a
checkmark (√). On cascading menus, on context-sensitive menus, and in the Layer
Management dialog box, layers are preceded by an abbreviation: a raster layer is
preceded by 'map', a point layer by 'pnt', a segment layer by 'seg', and a polygon
layer by 'pol'. Further, a text layer is preceded by 'txt', a legend by 'legend', grid
lines by 'grid', a graticule by 'graticule', a box by 'box', a scale bar by 'scale bar', a
North arrow by 'north arrow'.

See also: section 8.36.3 How to use layers in a map window.

8.7.3 How to change the properties of an object
For information on How to change the properties of an object , see section 8.38
How to view and edit the properties of an object.

8.7.4 How to change the working or start-up directory for ILWIS for
Windows

When you start ILWIS, you find that the Catalog is located in a certain directory.
When this is not the directory where your data is, you can change this working
directory or start-up directory by changing some Windows settings.

In Windows 3.0, 3.1, 3.11
In Windows Program Manager, click the ILWIS icon in the ILWIS program group.
From the File menu of the Program Manager, select Properties.
The Program Item Properties dialog box appears.
Change the path for the working directory
 for example to C:\ILWIS\DATA.

In Windows 95
Create a shortcut on the desktop from ILWIS.EXE. To do this, click the
ILWIS.EXE file in MyComputer, and choose Create Shortcut from the appearing
menu. At the end of the directory listing, a file/icon appears called Shortcut. Drag
this file/icon to the desktop. Click the shortcut on the desktop and choose Properties
from the appearing menu. Select the Shortcut tab. Change the path for the start in
directory for example to C:\ILWIS\DATA.
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Dialog boxes

For Windows 3.0, 3.1, 3.11:

For Windows 95:
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8.8 How to classify a map or column
You can:
1. Slice or classify a value map interactively;
2. Slice or classify a value raster map permanently;
3. Classify a value column permanently;
4. Perform a multi-spectral image classification on satellite imagery.

1. To slice or classify a value map interactively
Double-click a value map in the Catalog,

n In the Display Options dialog box, click the create button   next to the
Representation list box;

n In the appearing Create Representation dialog box, type a name for the new
representation but do not change the domain listed in this dialog box;

n when the map is using the system domain Value, you will create a
representation gradual, in which boundary values are represented by
percentages;

n When the map is using any other value domain, you will create a representation
value in which boundary values are the actual values in your map;

n Click OK in the Create Representation dialog box. The Representation
Value/Gradual editor is opened;

n Click OK in the Display Options dialog box of the map. The map is displayed in
a map window;

Keep the map window open and switch to the editor.

In the Representation Value/Gradual editor, you can add limits, assign colors to the
limits, and choose to stretch in between limits or use the colors of upper or lower
boundaries (slices);
n To insert a limit: choose Insert Limit from the Edit menu or press Ins on the

keyboard; in the appearing Insert Limit dialog box, type a value for the upper
boundary of a slice, e.g. 100 and assign a color to this limit;

n Double-click a number of times in between two limits, and decide whether the
color(s) of the values in between these two limits in the map should be stretched
or should use the color of the upper limit or the lower limit;

n Double-click an existing limit to change its boundary value or its color;
n The color bar at the bottom of the editor gives an impression of how your total

representation looks like;
When finished adding limits, keep the Representation editor open, and switch to
the map window.

In the map window, click the Redraw button  in the button bar. The map will
be displayed in the colors you just defined;
n Keep the map window open and switch to the representation editor.
n Continue to edit boundary values and/or colors in the Representation

Value/Gradual editor, and redrawing the map window until satisfied.
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For more information, see also ILWIS objects : representations, Representation
Value/Gradual editor or section 8.33 How to slice an image.

2. To classify a raster map with a value domain permanently
You can first try the interactive method.
n Create a domain Group (Main window, File, Create) in which you fill in the

upper boundaries and the output class/group names, and, optionally, edit the
representation of this domain. For more information, see How to create a Group
domain;

n Then, in the Main window, open the Operations menu, choose Image
Processing, Slicing or use the CLFY function on the command line of the Main
window or in a MapCalc dialog box. For more information, see the Slicing
operation or Map calculation : classifying a map (CLFY).

n Display the output raster map in a map window.

To edit the representation of the classified map
n In the map window, open the Edit menu and choose Representation;
n The Representation Class editor is opened: edit the colors of the classes as you

wish;
n Keep the editor open and switch to the map window;

n In the map window, click the Redraw  button.
You can continue switching to the Representation editor and back to the map
window to redraw the map until satisfied.

To change the boundary values on second thought
n You may keep the map window open;
n In the map window, open the Edit menu and choose Domain;
n The Domain Class/ID/Group editor is opened: edit the boundary values of the

groups, insert more groups, etc.;
n In the map window, open the Edit menu and choose Properties;
n In the appearing Properties dialog box, click the Make Up-to-Date button;
n a message appears asking for confirmation to recalculate the map, click OK;

n when the calculation has finished, click the Redraw  button in the map
window.

3. To classify a column with a value domain
n create a domain Group in which you fill in the upper boundaries and the output

class/group names;
n use the CLFY function on the command line in a table window.
For more information, see Table calculation : classifying a column (CLFY).

4. To perform a multi-spectral image classification on satellite imagery
n create a sample set of the bands with Sample, and the Sample Set editor;
n open the Operations menu, choose Image Processing, Classify.
For more information, see Sample, Sample Set editor, and Classify.



How to...

ILWIS Reference Guide 531

8.9 How to copy objects

To copy objects
n use the Copy Object command on the Edit menu of the Main window, or
n use the Copy command on the context-sensitive menu when clicking with the

right mouse button on an object in the Catalog.

The Copy Object dialog box appears.

n choose whether you want to save the object with a new name, or
n whether you want to copy the object to another directory

F It is strongly discouraged to copy, delete or rename any file in DOS or in the File
Manager.

8.10 How to create

8.10.1 How to create a 3D view
To obtain a 3D view of your study area, you first of all need a Digital Elevation
Model (DEM). For more information on creating DEMS, see How to calculate a
DEM. Then you can to construct a 3D view by creating a georeference 3D with the
georeference 3D editor. The process is shortly described below.

To start the Display 3D operation
n select Visualization, Display 3D from the Operations menu in the Main

window, or
n double-click the Display 3D item in the Operation-list.
The Display 3D dialog box appears.

In the Display 3D dialog box:
n select an exisiting georef3D from the drop-down list, or
n click the create button to create a new georeference 3D (a dialog box follows in

which you have to specify the name of the DEM, then you return to this dialog
box).

The Display Options - 3D Grid box appears.

(When you already have a georeference 3D, you can open it by double-clicking it in
the Catalog, or in the Catalog, click the georeference 3D with the right mouse
button, and choose Open from the context-sensitive menu. The Display Options -
3D Grid box appears). In the Display Options - 3D Grid dialog box, you can specify
how the 3D view should be displayed:
n using 3D grid lines in X and Y directions,
n using a raster map (satellite image, thematic map, scanned photograph) draped

over your height values,
n using both a raster map draped over your height values, and 3D grid lines.
The DEM is displayed in three dimensions in a map window.
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To modify the 3D view (i.e. the georeference 3D):
n choose Georeference from the Edit menu in the map window.
The Georeference 3D editor is opened.

The Georeference 3D editor mainly consists of one large Georeference 3D dialog
box in which you can specify parameters (altitude, rotation, distance, vertical
exaggeration, etc.) to define the perspective of the observer in relation to the 3D
model. Some examples of the effects of changing parameters in the dialog box are
presented in Georeference 3D editor : functionality.

When finished editing the 3D view, you can exit the editor and return to the map
window. If you like, you can add any other vector map or annotation to this map
window. You can save the 3D view in the map window as a map view.

See also: section 8.15.1 How to display Digital Elevation Models.

8.10.2 How to create annotation
For information on How to create annotation, see section 8.2.1How to add
annotation to a map window.

8.10.3 How to create an aspect map
For information on How to create an aspect map, see section 8.5.1How to calculate
an aspect map.

8.10.4 How to create attribute maps
In ILWIS for Windows, you can create attribute maps of raster maps, polygon
maps, segment maps and point maps. The original maps have a Class or ID
domain. An attribute table is usually linked to the map or to the domain of the map.
The table uses the same domain as the map and stores additional information for
each class or ID in the map in attribute columns. For more information on creating
an attribute table, see How to create an attribute table.

By creating an attribute map, every original class name or ID in the map is replaced
by an attribute value, class or ID as found in an attribute column in the attribute
table; the geometry of the orignal map remains.

Example
In this example, an attribute map is created for the acreage of cash crops (ha).

Input map: Input attribute table:
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Output attribute map:

There are two general methods to obtain an attribute map:
n Open the map which has an attribute table: in the Display Options dialog box of

the map, select the Attribute check box and select an attribute column from the
attribute table. This results in a 'temporary' attribute map displayed in a map
window. For more information, refer to How to display a map by one of its
attributes.

n Perform one of the Attribute Map operations on a map that has an attribute
table. This results in a 'permanent' attribute map stored on disk. Methods to
access the Attribute Map operations are described below. When you edit the
attribute table and change attribute values, you can make the output attribute
map up-to-date by clicking the Make Up-to-Date button in the Properties dialog
box of the output attribute map.

Attribute Map of a Polygon Map operation
By creating an attribute map, each polygon class name or ID in the original map is
replaced by the value, class name or ID found in a certain column in the attribute
table.

To create an attribute map of a polygon map
n from the Operations menu in the Main window, choose Vector Operations and

select Polygons, Attribute Map, or
n in the Operation-list, double-click the AttribPol item, or
n use the right mouse button on a polygon map in the Catalog and select Vector

Operations, Attribute Map from the context-sensitive menu.

The Attribute Map of Polygon Map dialog box appears.

Attribute Map of a Segment Map operation
By creating an attribute map, each segment class name or ID in the original map is
replaced by the value, class name or ID found in a certain column in the attribute
table.

To create a attribute map of a segment map
n from the Operations menu in the Main window, choose Vector Operations and

select Segments, Attribute Map, or
n in the Operation-list, double-click the AttribSeg item, or
n use the right mouse button on a segment map in the Catalog and select Vector

Operations, Attribute Map from the context-sensitive menu.

The Attribute Map of Segment Map dialog box appears.
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Attribute Map of a Point Map operation
By creating an attribute map, each point class name or ID in the original map is
replaced by the value, class name or ID found in a certain column in the attribute
table.

To create a attribute map of a point map
n from the Operations menu in the Main window, choose Vector Operations and

select Points, Attribute Map, or
n in the Operation-list, double-click the AttribPnt item, or
n use the right mouse button on a point map in the Catalog and select Vector

Operations, Attribute Map from the context-sensitive menu.

The Attribute Map of Point Map dialog box appears.

Attribute Map of a Raster Map operation
By creating an attribute map, each class name or ID of the pixels in the original
map is replaced by the value, class name or ID found in a certain column in the
attribute table.

To create an attribute map of a raster map:
n from the Operations menu in the Main window, choose Raster Operations and

select Raster operations, Attribute map, or
n in the Operation-list, double-click the AttribRas item, or
n use the right mouse button on a raster map in the Catalog and select Raster

Operations, Attribute Map from the context-sensitive menu.

The Attribute Map of Raster Map: dialog box appears.

F The colors in which an attribute map is displayed, depend on the domain of the
specified attribute column:
n If you used a domain Value attribute column, you can either select one of the

standard value representations or create your own representation by clicking the
create button in the Display Options dialog box which appears when you display
the attribute map.

n If you used a domain Class attribute column and this domain already has a user-
defined representation, then this representation is automatically selected in the
Display Options dialog box which appears when you display the attribute map.
In the Display Options dialog box, you can also select another existing
representation or create a new representation by clicking the create button.

8.10.5 How to create an (attribute) table

To create a table
n open the File menu in the Main window, choose Create Table, or
n open the File menu in a table window, choose Create Table, or
n double-click the New Table item in the Operation-list.
The Create Table dialog box appears.
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To create an attribute table
There are several possibilities to create an attribute table:
1. You can open the properties of a point, segment, polygon or raster map, and

select the Attribute check box. Select an existing table (only tables with the
same domain as the map are shown) or create a new table by clicking the create
button. Properties of maps can only be edited when the map is not read-only.

2. Another way to create an attribute table is to open the properties of a class
domain or an identifier domain and select the Attribute check box. Select an
existing table (only tables with this domain are shown) or create a new table by
clicking the create button. Properties of domains can only be edited when the
domain is not read-only.

3. When you use the Create Table command from a File menu, then select for the
domain of the table the same domain as is used by the map to which the
attribute table should refer; this must be a class domain or an identifier domain.

8.10.6 How to create a color composite
A color composite is created by combining three raster images (bands/maps). One
map is displayed in shades of red, one in shades of green and one in shades of blue.
Putting the three bands together in one color composite can give a better visual
impression of the reality on the ground, than displaying one band at a time. There
are three types of color composites: natural color composites, pseudo natural color
composites and false color composites. Natural color composites are made of the
green, blue and red part of the spectrum. This results in an image with realistic
colors. A pseudo color composite is created with other parts of the spectrum, but the
result has natural looking colors. In false color composites the colors in the image
are not the same as in reality. For example healthy vegetation is red and urban
areas are blue.

To create a color composite
n from the Operations menu in the Main Window, choose Visualization, Color

Composite
n double-click the ColorComp item in the Operation-list

The Color Composite dialog box appears.

n select a raster map from the Catalog to the ColorComp item in the Operation-
list; the Color Composite dialog box opens. You can drag the other two raster
maps to the Color Composite dialog box.

8.10.7 How to create columns in a table
For more information on How to create columns in a table, see section 8.2.4 How to
add columns to a table.

8.10.8 How to create a coordinate system
A coordinate system is a service object for point, segment and polygon maps, and
for georeferences. A coordinate system contains information on the kind of
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coordinates you are using in your maps; you may for instance use user-defined
coordinates, coordinates defined by a national standard or coordinates of a certain
UTM zone.

A coordinate system defines the possible minimum and maximum X's and Y's that
can be used. Furthermore, to be able to convert one coordinate system into another,
a projection with parameters needs to be attached to both coordinate systems. If a
projection is added to a coordinate system, the maps using this coordinate system
can be displayed with a graticule.

It is advised to use one coordinate system for all your maps.

To create a coordinate system
n select the Create Coordinate System command on the File menu of the Main

window, or
n double-click the NewCrdSys command in the Operation-list, or

n click the create button  in the dialog box when creating a point, segment or
polygon map, or a georeference.

The Create Coordinate System dialog box appears.

8.10.9 How to create a Digital Elevation Model
For more information on How to create a Digital Elevation Model, see section 8.5.3
How to calculate a Digital Elevation Model.

8.10.10 How to create a domain
A domain is a set of class names, IDs, or values that can be used in a certain data
object. All ILWIS data objects have a domain. One domain can be used for several
data objects. User-defined domains are listed in the Catalog.

F After importing maps containing values from ILWIS version 1.4, it is a good idea
to create a domain and a representation for these maps.

F To show domains in the Catalog, refer to: How to customize the Catalog.

To create a domain
n from the File menu in the Main window, choose the Create Domain command,

or
n in the Operation-list, double-click the New Domain icon, or
n in a dialog box which asks for a domain as input or output, click the little create

button  next to the domain list box.

In the Create Domain dialog box which follows, you have to specify the type of
domain you want to create:
n select Class when the elements in the map are points, lines or areas with class

names. Elements with the same name can occur in several places in the map.
n select ID when the elements in the map are points, lines or areas which are

uniquely identified.
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n select Value when the elements in the map are points, lines or areas
representing measurable values.

n select check box Group to indicate upper value boundaries and group names for
a subsequent Slicing operation of when you want to use the CLFY function in
MapCalc.

When creating a Class or an ID domain, the Domain Class/ID editor is opened. In
the Domain Class/ID editor, you can add the class names or the IDs that you want
to use to the domain but you can also add class names or IDs to the domain later
on, for instance during digitizing. When creating a Value domain, the Edit Domain
Value dialog box is opened, in which you can define exactly what values should be
stored by the domain: specify a minimum and maximum value and a precision.

F When working with maps of different years but of the same theme, or containing
the same class names, IDs, or values, you are advised to create one domain for
these maps and use this domain for all maps. It is not necessary that every class
name, every ID or every value in your domain actually occurs in each map which
uses that domain.

Representations
Representations are linked to a domain. This means that when you use the same
domain in several maps, these maps can easily be displayed in the same colors. ID
domains do not have a representation.

When you create a new class domain, a representation is automatically created with
the same name as the class domain.
One way to view the representation of a class domain is:
n Open the class domain by double-clicking it in the Catalog,
n From the Edit menu in the Domain Class editor, select Representation;
n The Representation Class editor is opened.
For more information, see Representation Class editor and How to edit a
representation.

When you create a new value domain, a representation value is not automatically
created. Two methods to create a representation for a value domain are:
n Double-click a value map in the Catalog;

n In the Display Options dialog box of the map, click the create button  next to
the Representation list box;

n After you specified a name for the new representation in the Create
Representation dialog box, the Representation Value/Gradual editor is opened;
or

n Click the value domain with the right mouse button in the Catalog;
n Select Properties from the context-sensitive menu;
n In the Properties dialog box of the domain, click the create button next to the

Representation list box;
n After you specified a name for the new representation in the Create

Representation dialog box, the Representation Value/Gradual editor is opened;
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For more information, see Representation Value/Gradual editor and How to create a
representation.

See also: section 8.17.4 How to edit a domain.

8.10.11 How to create a domain Group
A Group domain is used:
n to permanently classify or slice a map with a value domain, or
n to classify values in a column.
A domain Group lists the upper value boundaries of the groups and the output
group names. For ILWIS 1.4 users: a domain Group acts as a classify table.

F To interactively slice an image or to interactively classify a map, you can create a
new represetation value or gradual. For more information, see How to slice an
image and How to classify a map.

To create a domain Group
n from the File menu in the Main window, choose the Create Domain command,

or
n in the Operation-list, double-click the New Domain item.

In the Create Domain dialog box which follows:
n select the Class option, and
n select the Group check box.

The Domain Group editor starts:
n Add groups to the domain by selecting Add Item from the Edit menu, or by

pressing the Ins key on the keyboard;
n In the appearing Add Domain Item dialog box, specify the upper boundary

value for this group, the output group name, and optionally a code for the output
group name.

Example
A domain Group which can be used to classify or slice slope values may look as
follows:

Upper Boundary Group Name
2 Flat
8 Undulating
16 Rolling
30 Hilly
200 Mountainous

To apply the group domain
To classify values in a map, use the Slicing operation or use the CLFY function in
MapCalc. The operation and the function produce the same results.
To classify values in a column, use the CLFY function in TabCalc.
For more information, see How to classify a map or column.
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To edit the representation of a group domain
When you create a domain Group, also a representation is created with the same
name as the domain. You can edit the colors of the output groups, i.e. classes, by
opening the representation from the Catalog.

When you have displayed your output raster map in a map window, you can also
choose the Representation command from the Edit menu in the map window:
n The Representation Class editor is opened;
n Modify the colors of the output classes;
n Keep the editor window open and switch to the map window;

n In the map window, press the Redraw button ;
n Switch to the Representation Class editor and continue to modify colors;
n Switch to the map window to redraw the map, until satisfied.

8.10.12 How to create a georeference
A georeference stores the relation between rows and columns of a raster map
(row,col) and coordinates (X,Y). A georeference is needed for raster maps. A
georeference uses a coordinate system.

It is advised that raster maps of the same area use the same georeference, because
raster operations in which raster maps are combined only make sense if the pixels
in the maps refer to the same area on the ground.

There are basically three types of georeferences:
n georeference corners: for rasterized vector maps which are usually North-

oriented,
n georeference tiepoints: for the bands of a satellite image, for maps of different

sources and satellite images of different dates,
n georeference 3D: to create three dimensional pictures of maps.

To create a georeference corners or georeference tiepoints
To create any kind of georeference, you can open the File menu of the Main
window and choose Create Georeference, or double-click the New Georef item in
the Operation-list. The Create georeference dialog box appears.
When finished creating the georeference, add this georeference to a raster map by
editing the properties of that raster map.

Also, through the Edit Properties dialog box of a raster map, you create a new
georeference corners, tiepoints by clicking the create georeference button. The
Create georeference (through Properties) dialog box appears. For more information,
see How to view and edit the properties of an object.

When rasterizing vector maps, you can directly create a georeference corners for

the output raster map by clicking the create georeference button  in the dialog
box of the Rasterize operation. The Create georeference (during Rasterize) dialog
box appears.
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To add tiepoints to bands of a satellite image, you can also display for example a
color composite in a map window, and then choose the Create Georeference
command from the File menu in the map window. The Create georereference
tiepoints (in map window) dialog box appears. When finished creating the
georeference tiepoints, you can add this georeference to all bands of this image by
editing the properties of these bands. For more information, refer to How to add
coordinates to a satellite image.

The same method can be followed for adding tiepoints or control points to a
scanned aerial photograph.

To create a georeference 3D
To obtain a three-dimensional view of your study area, select Visualization, Display
3D on the Operations menu in the Main window or double-click the Display 3D
item in the Operation-list. Then, in the Display 3D dialog box, click the create

georeference button . The Create georeference 3D dialog box appears. Then,
after the Display Options 3D Grid dialog box in which you can specify whether you
want to see your 3D view with grid lines with or without a raster map drape, a map
window is opened with an initial georeference 3D. To modify the 3D parameters,
select Georereference from the Edit menu in the map window and the
Georereference 3D editor is started. Change the 3D parameters as you wish and exit
the editor. The last set of parameters is stored in the georeference 3D.
The 3D view is displayed in a map window. If you like, you can add any other
vector map or annotation to this map window. You can save the 3D view in the
map window as a map view.
To permanently apply a georeference 3D to a raster map, use the Apply 3D
operation.

8.10.13 How to create linear filters
Filtering is a process in which each pixel value in a raster map is replaced with a
new value. The new value is obtained by applying a certain function to each input
pixel and the neighbourhood.

Linear filters use a linear combination of all pixels in a rectangle around the input
pixel. They can have a user-defined size; further, you may wish to insert your own
values in the matrix and determine your own gain value.

To create a user-defined linear filters
n from the File menu in the Main window, choose Create Filter, or
n double-click the NewFilter item in the Operation-list, or

n click the create button  in the dialog box of the Filter operation.

The Create Filter dialog box appears in which you can define the size and type of
values of the filter. Subsequently, you can enter the values of the cells in the filter
in the Edit Filter dialog box.
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F The Average filter, Majority filters, Median filters, the Pattern filter, Rank Order
filters, and the Standard Deviation filter may have a user-defined size, rank or
threshold. These filters can be modified Filter : dialog box; they can also be defined
on the command line.

8.10.14 How to create objects
For more information on How to create objects, see section 8.1.4 How to create
objects.

8.10.15 How to create maps

To create a raster map
n rasterize an existing point, segment, or polygon map, or
n choose the Create  command on the File menu in the Main window, or
n double-click New Map in the Operation-list.
When you do not rasterize an existing point, segment or polygon map but create a
new raster map from scratch, you have to assign class names, IDs or values to the
pixels with the pixel editor.

To create a point map or a segment map
n choose the Create  command on the File menu in the Main window, or
n double-click New PntMap or the New SegMap in the Operation-list.
n when you already have or created a domain or a coordinate system for a map,

you can also click this domain or coordinate system with the right mouse button
in the Catalog, then select a Create command from the context-sensitive menu.
In the appearing Create dialog box, the selected domain or coordinate system is
automatically filled out, or

n when you already have a map of the same dimensions, and you displayed this
map in a map window, you can also open the File menu in the map window and
select a Create command. In the appearing Create dialog box, the coordinate
system and map boundaries are filled out automatically for the new map.

In the Create dialog box which follows, you have to specify for instance the
coordinate system to use, the map boundaries of this map, the domain to use, etc. If
you do not yet have a coordinate system or a domain you have to create them (you

can use the little create buttons  in the dialog box).

F To create a polygon map, refer to How to create polygon maps.
F When you have multiple neighbouring map sheets, you should create one

coordinate system that covers all the map sheets.
F This coordinate system should then be used for all maps. For the map boundaries,

you should stick to the coordinates of each map sheet that you digitize.
F When you want to digitize several maps of the same theme but of different years,

you should create one domain and use this domain for all maps. Not every item of a
domain needs to be present in each map.
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To use the point, segment or polygon editor
After one of the Create dialog boxes, a map editor is automatically started. Fill the
map with points, segments or polygons with or without digitizer. Mind: to obtain a
polygon map, you can directly create a polygon map and use the polygon editor to
create the polygons. For more information, see How to setup a digitizer, Point
editor, Segment editor and Polygon editor.

To rasterize vector maps
When finished creating point, segment and polygon maps, you can rasterize them:
n choose the Rasterize command from the Operations menu in the Main window,

or
n double-click the PntRas, SegRas or PolRas operations in the Operation-list.

In the rasterize dialog box which follows, you have to specify the georeference of
the output map. If you do not have a georeference yet, you have to create one. You
may need to think about an appropriate pixel size for the output raster map(s).

F It is advised to use one georeference for all raster maps of the same area.

8.10.16 How to create a map list
A map list is a set of raster maps, for example the bands of a satellite image. All
raster maps in the map list must have the same georeference.

To create a map list
n from the File menu in the Main window, choose the Create Map List command,

or
n in the Operation-list, double-click the New MapList icon, or
n in a dialog box which requires a map list as input, click the little create button

 next to a Map List list box.

In the Create Map List dialog box which follows, all raster maps in the current
directory are listed. Select the maps that should be included in the map list.
To select two or more maps in sequence:
n click the first raster map you want to select,
n keep the left mouse button down, and
n move the mouse pointer to the last raster map you want to select,
n then release the left mouse button;

or
n click the first raster map you want to select,
n press and hold down the Shift key while you click the last raster map in the

group.

To select two or more maps out of sequence:
n press and hold down the Ctrl key while you click each raster map.

To cancel a selected map:
n press and hold down the Ctrl key while you click a selected raster map.
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8.10.17 How to create polygon maps
According to the ILWIS concept, segments with different class names, IDs or
values can be stored in a segment map. In the text below, the word code will be
used for the class names, IDs, or values of segments.
From each segment code or set of codes, different polygon maps can be created by
using a mask. It is advised that you have a separate label point map for
each set of segment codes from which you want to create a polygon map.

For a general introduction on creating maps, refer to How to create maps.
For more information on using a digitizer, refer to How to set up a digitizer and
start digitizing and Segment editor : functionality.

Steps to obtain a polygon map:
n start the segment editor: when you create a new segment map, the segment

editor is automatically started. To edit an existing segment map in a map
window, open the Edit menu, choose Edit Layer and select the segment layer
from the cascading menu;

n start the point editor: when you create a new point map, the point editor is
automatically started. To edit an existing map, display the point map in a map
window, open the Edit menu, choose Edit Layer and select the point layer from
the cascading menu;

n in the segment editor: digitize the segments. When you want to create multiple
polygon maps from one segment map, you have to code your segments in such a
way that you can select sets of codes by using a mask later on;

n in the point editor: digitize label points within each polygon boundary.

F It is recommended that you add your point map as a data layer to the segment
editor, in order to verify that every polygon has its own label (you can have only
one label per polygon).

n In the segment editor: select Polygonize from the File menu

The Polygonize Segment Map dialog box appears.
n select the mask which will be used for polygonization
n select the label point map
n select a name for the output polygon map

Segment will be checked and if no errors occur in your segment map, the topology
will be built and polygons are named according to the label point map.

F F If you digitize different segment codes in one digitizing session (for example: soil
units, districts, roads etc.) make sure you select the right mask for polygonization.
You can repeat the procedure of creating polygons; each time specify another mask,
another label and a different output polygon map name.
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8.10.18 How to create a representation
A representation defines the manner in which classes of a domain Class map, or
values in a domain Value or domain Image map should be colored. For raster maps,
a representation contains merely colors; for segment, polygon and point maps there
are also possibilities to define for instance: line widths, patterns, and symbols.
Furthermore, a representation is needed for raster maps with a domain Picture. A
representation is a service object for a domain.

Maps with a Bool, the Bit or an ID domain do not have stored representations on
disk. For maps with a Bool or the Bit domain, you can select colors in the Display
Options dialog box of the map each time you display the map. Maps with an ID
domain can be shown in 7, 15, or 31 colors to inpect the map itself, however in
most cases you will display an ID map by one of its attributes from its attribute
table; the options are available in the Display Options dialog box.

Furthermore, special options for point symbols are available in the Display Options
dialog box of a point map.

To create a new representation for a domain Class, Group or Value
n in a Display Options dialog box of a map with a class, group or value domain,

click the little create button  next to the Representation list box, or

n in the Properties dialog box of a domain, click the little create button  next to
the Representation list box, or

n from the File menu of the Main window, choose Create Representation, or
n in the Operation- list, double-click the New Repr item.

Representation types
When you create a new representation for (a map with):
n a class domain: you create a representation class;
n a user-defined value domain: you create a representation value;
n the system domain Value: you create a representation gradual;
n any other system value domain: you create a representation value.
For more information on representation types, see ILWIS objects : representations.

Depending on the type of representation you are creating, the Representation Class
editor is opened or the Representation Value/Gradual editor is opened.

In the Representation Class editor, you can for each class in the domain
n select or create a color (raster form);
n select or create a color and select a pattern (polygon form);
n select or create a color and select a line width (segment form);
n select the symbol type, size, pen width, color and fill color (point form).



How to...

ILWIS Reference Guide 545

In the Representation Value/Gradual editor, you can:
n insert limits, i.e. boundary values for a representation value, or percentages for a

representation gradual,
n choose or create a color for each limit,
n indicate whether to stretch colors between the limits or to use the color of the

upper of lower boundary,
n when you stretch in between limits: the number of steps to be used for stretching

the colors.

F To show representations in the Catalog, refer to Help topic: How to customize the
Catalog.

To obtain a Display Options dialog box:
n in the Catalog, double-click a map which uses a class, group, value, or picture

domain, or
n from the File menu in the Main window, choose Open, and select a map which

uses a class, group, value, or picture domain.

To obtain a Domain Properties dialog box:
n from the Edit menu of the Main window, choose Properties and select a class,

group, value, or picture domain, or
n in the Catalog, click a class, group, value, or picture domain with the right

mouse button, and select Properties from the context-sensitive menu.

8.10.19 How to create a sample set for image classification
To perform an image classification, a sample set has to be created. Then, you can
sample training pixels: assign class names to groups of pixels with similar spectral
values and that are supposed to represent a known feature on the ground.

A sample set consists of:
n a reference to a background map, that is the map on which you can locate your

training pixels; this background map can for instance be a color composite,
n a reference to a map list, that is the set of images you want to classify in a later

stage; the images in the map list are used to extract sample statistics during
sampling and display these in feature spaces,

n a reference to a class domain, that is the collection of class names that you want
to assign to your training pixels,

n a reference to a sample set raster map which is automatically created and
obtains the same name as the sample set; this map contains the locations of the
training pixels and the class names assigned to them.

To create a sample set
n from the File menu in the Main window, choose Create Sample Set, or
n in the Operation-list, double-click the item New SmpleSet, or
n in the Operation-list, double-click the item Sample Map, or
n from the Operations menu in the Main window, choose Image Processing,

Sample.
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By the first two actions, the Create Sample Set dialog box will appear. In the Create
Sample Set dialog box, you can specify the sample set's name, and the domain, map
list, and background map that you want to use during sampling.
By the last two actions, the Sampling dialog box appears in which you can select an
existing sample set, for instance to add more training pixels, but you can also create
a new sample set by clicking the little create button. If the create button is used, the
Create Sample Set dialog box will follow.

When everything is OK, the Sample editor is started which allows you to select
training pixels, show feature spaces, etc.

8.10.20 How to create scripts
A script is a sequenced list of ILWIS expressions. By creating a script, you can
build a complete GIS or Remote Sensing analysis for your own research discipline.
Scripts are more or less equivalent to batch files in ILWIS version 1.4.

To create a script
n in the Main window, open the File menu and choose Create Script, or
n in the Operation-list, double-click the item NewScript.

The Create Script dialog box appears in which you can type your script expressions.

8.10.21 How to create segments which pass exactly through existing
points

Start the point editor
Display your existing point map in a map window, open the Edit menu, choose Edit
Layer and select the point layer from the cascading menu.

Start the segment editor
When you create a new segment map, the segment editor is automatically started.
To edit an existing map, display the segment map in a map window, open the Edit
menu, choose Edit Layer and select the segment layer from the cascading menu.

To create segments which pass exactly through existing points
n activate the point editor and the segment editor next to each other on your

screen
n from the point editor select the points (CTRL & click)
n from the Edit menu in the point editor select copy
n from the Edit menu of the segment editor select paste

Segments will be created which pass exactly through the selected points.

F The segment will get the code of the point you have selected as first (codes can be
edited and changed). If this code does not exist in the domain of the segment map,
ILWIS will ask whether you want to add this code to the domain.
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8.10.22 How to create a slope map
For more information on How to create a slope map, see section 8.5.7How to
calculate a slope map.

8.10.23 How to create two-dimensional tables
A two-dimensional table is used to combine or reclassify two raster maps with a
class or ID domain. It defines a value for each possible combination of input classes
or IDs. A two-dimensional table view consists of rows which represent one domain
and of columns which represent another domain. In the two-dimensional table, you
have to assign a value, class name or ID to the fields which represent the
combination of these domains.

To create a two-dimensional table
n from the File menu in the Main Window, choose Create Two-Dimensional

Table, or
n double-click the New 2DimTbl item in the Operation-list.

The Create Two-Dimensional Table dialog box appears.

When you create a new two-dimensional table, it is directly displayed in a table
window where you can also edit it. To open and to edit an existing two-dimensional
table, see also: How to edit a two-dimensional table.

To apply a two-dimensional table
The table can be applied by typing a special expression on the command line of the
Main window:

OUTMAP = 2dimtablename[map1,map2]

When you apply the two-dimensional table, you need two input raster maps which
have the domains as used by the two-dimensional table, the output raster map then
contains the values, classes or IDs that you entered in the fields of the two-
dimensional table.

8.10.24 How to create user-defined functions
Functions can be used in all three calculators in ILWIS: MapCalc, in TabCalc or in
the pocket line calculator. Some 50 internal functions are available (see also
MapCalc and TabCalc), but also user-defined functions can be created.

A user-defined function may contain any combination of operators and functions,
and may use parameters representing map names, table names and column names.
Parameters in a user-defined function can have any name.

A user-defined function can be created
n to perform calculations in MapCalc and Tabcalc which use difficult or long

formulas that are tedious to type in on the command line, or
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n to perform calculations in MapCalc and Tabcalc that you want to use a number
of times on different maps or columns.

To create user-defined functions
n from the File menu in the Main window, choose Create Function, or
n from the File menu of a table window, choose Create Function, or
n double-click the NewFunction item in the Operation-list

The Create Function dialog box appears.

To show user-defined functions in the Catalog, see section 8.11 How to customize
the Catalog.

8.11 How to customize

8.11.1 How to customize the Catalog
By default, the Catalog shows all data objects in the current directory; however,
service objects, such as domains, georeferences and representations, and system
objects are not shown. A selection can be made which objects are to be shown in the
Catalog.

To show different object types in the Catalog
n open the Options Menu in the Main window,
n choose the Catalog command,
 or

n click the Customize Catalog  button in the button bar of the Main window.

The Customize Catalog dialog box appears; this dialog box contains a list box in
which objects shown in the Catalog appear highlighted:
n select items that are to be shown in the Catalog, or
n deselect items that are to be hidden from the Catalog.

The following object types can be shown in the Catalog:
raster maps, polygon maps, segment maps, point maps, map lists, tables, domains,
representations, georeferences, coordinate systems, map views, histograms of raster,
polygon, segment and point maps, sample sets, two-dimensional tables, matrices,
user-defined filters, user-defined functions and scripts. Also drives and directories
can be shown.

F The Catalog can also show system objects: select the Include System Objects check
box in the Customize Catalog dialog box.

F If you only want to see objects that start with certain characters: specify a Mask in
the Customize Catalog dialog box. Then only the objects of which the name
matches the specified mask will be shown in the Catalog.

F To see, for instance, only maps that start with Land, select the object types: raster,
polygon, segment and point maps and specify as mask: Land*.
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To select two or more object types in sequence
n click the first object type you want to select,
n keep the left mouse button down, and
n move the mouse pointer to the last object type you want to select,
n then release the left mouse button;

or
n click the first object type you want to select,
n press and hold down the Shift key while you click the last object type of the

group.

To select two or more object types out of sequence
n press and hold down the Ctrl key while you click each object type.

To cancel a selected object type
n press and hold down the Ctrl key while you click a selected object type.

See also: section 8.36.1  How to use the Catalog.

8.11.2 How to customize the Operation-list
The Operation-list contains a list of all ILWIS operations and some other
commands (New, Show, Edit).

To hide or show the Operation-list
n on the Options menu in the Main window, look for the Operation-list command:

– if a check mark √ appears in front of 'Operation-list', the Operation-list is
displayed. To hide the Operation-list, click the command Operation-list on
the Options menu;

– if no check mark appears in front of 'Operation-list', the Operation-list is
hidden. To show the Operation-list, click the command Operation-list on the
Options menu; or

n click the Operation-list button in the button bar of the Main window.

8.11.3 How to customize the Pixel Information Window
The pixel information window allows you to interactively inspect class names, IDs
or values in multiple raster, polygon, segment and point maps with the same or a
compatible coordinate system. When one map is displayed in a map window, the
pixel information window will retrieve values of all maps added to the pixel
information window, at the position of the mouse pointer in the map window.
In the same way, when you have an analog map on the digitizer and you performed
MapReference, the pixel information window is capable of retrieving values of all
maps added to the pixel information window, at the position of the digitizer cursor.

To customize the pixel information window
n open the pixel information window, see How to open the pixel information

window
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In the Pixel Information window,
n open the Options menu and select the Customize command.

See also: section 8.36.8 How to use pixel information.
section 8.8.24.2 How to open the pixel information window.

8.11.4 How to customize the Point Editor
The point editor is used to create a map with point features.

With the point editor, you can insert new points, edit the code of existing points,
move points to another position and delete points. The point editor can work in
Select mode, Move Points mode and Insert mode. The point editor has a menu bar,
a context-sensitive menu, and button bar.

To start the point editor
When you are creating a new point map, the point editor is automatically started.
To edit an existing point map, display the point map in a map window, open the
Edit menu, choose Edit Layer and select the point layer from the cascading menu.
For more info on this topic; refer to How to edit point, segment, polygon and raster
maps.

To customize the point editor
n choose Customize from the File menu,or
n use the right mouse button and select Customize from the context-sensitive

menu

You can amongst other indicate whether to show text next to your points and
choose the symbol type and color in which your points should be displayed.

The Customize Point Editor dialog box appears.

8.11.5 How to customize the Polygon Editor
The polygon editor is used to create a map with area features.

With the polygon editor, you can insert new polygons, edit the code of existing
polygons, change the position of intermediate coordinates within a polygon
boundary, and delete polygon boundaries.
The polygon editor can work in Select mode, Boundary mode, Move Points mode,
and Insert mode. The polygon editor has a menu bar, a context-sensitive menu and
a button bar.

To start the polygon editor
When you are creating a new polygon map, the polygon editor is automatically
started. To edit an existing polygon map, display the polygon map in a map
window, open the Edit menu, choose Edit Layer and select the polygon layer from
the cascading menu. For more info on this topic; refer to How to edit point,
segment, polygon and raster maps.
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To customize the polygon editor
 Customize the way polygon boundaries are displayed in the polygon editor and the
behaviour of the polygon editor itself:
n choose Customize from the File menu, or
n use the right mouse button and select Customize from the context-sensitive

menu

You can among others indicate whether to use Autosnap or not and choose the
colors in which you want to see your polygon boundaries.

The Customize Polygon Editor dialog box appears.

8.11.6 How to customize the Segment Editor
The segment editor is used to create a map with line features. To create a map with
digital area features, you can directly use the polygon editor.

With the segment editor, you can insert new segments, edit the code of existing
segments, change the position of intermediate coordinates within a segment and
delete segments. The segment editor can work in Select mode, Move Points mode,
and Insert mode. The segment editor has a menu bar, a context-sensitive menu, and
a button bar.

To start the segment editor
When you are creating a new segment map, the segment editor is automatically
started. To edit an existing segment map, display the segment map in a map
window, open the Edit menu, choose Edit Layer, and select the segment layer from
the cascading menu. For more info on this topic; refer to How to edit point,
segment, polygon and raster maps.

To customize the segment editor
Customize the way segments are displayed in the segment editor and the behaviour
of the segment editor itself:
n choose Customize from the File menu, or
n use the right mouse button and select Customize from the context-sensitive

menu

You can among others indicate whether to use Autosnap or not and choose the
colors in which you want to see your segments.

The Customize Segment Editor dialog box appears.

8.12 How to delete objects

To delete objects
n use the Delete Object command on the Edit menu of the Main window, or
n use the Delete command on the context-sensitive menu when clicking with the

right mouse button on an object in the Catalog.

The Delete Object dialog box appears.
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You can check if the object to be deleted is used by other objects
n use the right mouse button on an object in the Catalog and select Properties,

Used By
n it is possible to delete objects used by other objects; be careful!

F F It is strongly discouraged to copy, delete or rename any file in DOS or in the File
Manager.

8.13 How to digitize

To start digitizing a new map:
1. Check whether on the Options menu in the Main window, the digitizer is active

(a check mark √ should appear in front of the menu option active). If not,
reference your map again, see How to reference a map.

2. Create a new map (see also How to create a map). When you want to digitize
polygons, you can directly create a new polygon map. Decide on the domain, i.e.
the set of class names, IDs or values, that you want to assign to your points,
segments or polygons. You can also edit or create a representation for a domain
of type Class or Value.

3. If you have performed all steps described above, you will directly be led to the
appropriate map editor, and the digitizer is ready for use. For more information
on the editors, press F1 in the editor window or see: Point, segment and poygon
editor: Functionality.

To continue digitizing an existing map
1. Check whether on the Options menu in the Main window, the digitizer is active.

If not, reference your map again.
2. If the map has not moved on the digitizer tablet, continue with step 3.
3. If you newly placed or moved the map on the digitizer tablet,  reference the

map.
4. To open the appropriate map editor:

– in the Catalog, click with the right mouse button on the map that you want
to continue editing, choose Edit from the context-sensitive menu, or

– open the map in a map window, open the Edit menu, and choose Edit Layer.
5. When the editor is opened, you can continue digitizing. For more information

on the editors, press F1 in the editor window or see: Point, segment and polygon
editor: Functionality.

8.14 How to digitize on a background map (screen-digitizing)

Digitizing a map on the graphics screen
Apart from digitizing using a map on the digitizer, it is also possible to digitize
using a map displayed on the graphics screen, or using both a  map on the digitizer
and a raster map on the graphics screen.
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In this way for instance an interpretation can be made from a scanned photograph
or a satellite image. To be able to use a map on the graphics screen, it must be:
n available on disk at a map,
n georeferenced, i.e. it has to have (metric) coordinates. If both a map on the

digitizer and a map on the graphics screen are used, the coordinates assigned to
the image must be specified in the same coordinate system as the map.

n also other vector layers and e.g. a grid can be available.

To start
1. Check whether on the Options menu in the Main window, the digitizer is active.

If not, reference your map again.
2. If the map on the digitizer has not moved on the digitizer tablet, continue with

step 3.
3. If you newly placed or moved the map on the digitizer tablet, reference the map.
4. Display the map in a map window (See: How to display maps and tables).
5. If you want to edit more maps, display the other map(s) you want to edit in the

same window. This can be done by:
– dragging these maps out of the Catalog to the Map Window or,
– by selecting Add Data Layer in the Layers menu in the Map Window.

6. Start editing by opening the Edit menu. Choose Edit Layer and select the map
you want to edit. Depending on the type of map your editing, the pixel editor,
point editor, segment editor or polygon editor is now opened. Note that when
you have displayed the map with an edit command, you are in an editor
already. For more information on the editors, press F1 in the editor window.

7. When you are finished editing, select Exit Editor from the File menu of the map
window. The Display Options Window now opens, in which you can make
adjustments. Press ok to continue.

8. When you want to edit another graphics map, first close the editor your using
(See 6). Choose Edit Layer from the edit menu and select the map you want to
edit to continue.

Data reduction
In order to reduce the amount of coordinate data to be stored, a data reduction
procedure is carried out automatically before the data are written to the coordinate
file. This technique is called tunnelling and is explained at Help: Tunnel Segments.

8.15 How to display

8.15.1 How to display Digital Elevation Models
A (digital) representation of relief over space is known as a digital elevation model
(DEM). By relating any map with the corresponding terrain surface in a 3D model,
you can discover and understand relations between spatial data sets. For example,
by draping a land use map over the height values of a 3D model, you can see where
your areas of interest are located: on slopes, on flat areas, in the lower areas, in the
mountains, etc.
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Although Display 3D was originally developed to model relief, it can of course also
be used to model the continuous variation of any other value map as a surface (e.g.
concentration values, land values).

To obtain a Digital Elevation model, you can digitize contour lines and assign
height values to the segments in the segment editor. Then use the Contour
Interpolation operation. The output is a DEM, also called a height map. For more
information, see How to calculate a Digital Elevation Model.

1. An easy method to get a general impression of your relief is to apply the
Shadow filter on your DEM with the Filter operation. When you display the
result in a map window, you can already see the relief coming out of the map.

 To start the Filter operation
n from the Operations menu in the Main window, select Image Processing,

Filter, or
n double-click the Filter operation in the Operation-list, or
n use the right mouse button on your DEM in the Catalog and select Image

Processing, Filter from the context-sensitive menu.
 The Filtering dialog box appears.

 In the Filtering dialog box:
n select the Shadow filter from the Filter Name list box,
n type a name for the output map,
n for the best result, modify the value range and the precision for the output

map, so that a 1 or 2 byte map will be created,
n press OK.

 When you display the output map in a map window, choose Representation
Gray; additionally you can add the segment map with the contour lines and
display these in one color (e.g. light brown).

When the output map uses 4 or 8 bytes per pixel, you may first calculate a
histogram of the filtered map with the Histogram operation to enhance the
display.

2. Another method is to create a 3D view out of your DEM with the Display 3D
operation; you create a georeference3D in the georeference 3D editor.

 To start the Display 3D operation
n select Visualization, Display 3D from the Operations menu in the Main

window, or
n double-click the Display 3D item in the Operation-list.
The Display 3D dialog box appears.

In the Display 3D dialog box:
n select an existing georef3D from the drop-down list, or
n click the create button to create a new georeference 3D (a dialog box follows

in which you have to specify the name of the DEM, then you return to this
dialog box).

The Display Options - 3D Grid box appears.
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(When you already have a georeference 3D, you can open it by double-clicking
it in the Catalog, or in the Catalog, click the georeference 3D with the right
mouse button, and choose Open from the context-sensitive menu. The Display
Options - 3D Grid box appears.)

In the Display Options - 3D Grid dialog box, you can specify how the 3D view
should be displayed:
n using 3D grid lines in X and Y directions,
n using a raster map (satellite image, shadow map, thematic map, scanned

photograph) draped over your height values,
n using both a raster map draped over your height values, and 3D grid lines.
The DEM is displayed in three dimensions in a map window.

To modify the 3D view (i.e. the georeference 3D):
n choose Georeference from the Edit menu in the map window.
The Georeference 3D editor is opened.

The Georeference 3D editor mainly consists of one large Georeference 3D
dialog box in which you can specify parameters (altitude, rotation, distance,
vertical exaggeration, etc.) to define the perspective of the observer in relation
to the 3D model. Some examples of the effects of changing parameters in the
dialog box are presented in Georeference 3D editor : functionality.

When finished editing the 3D view, you can exit the editor and return to the
map window. If you like, you can add any other vector map or annotation to this
map window. You can save the 3D view in the map window as a map view.

Example using a drape of a Shadow map
A simple and nice 3D view of a Digital Elevation Model can be obtained by using
the output map of the DEM filtered with the Shadow filter as a raster drape over the
height values and by overlaying the contour segments on the 3D view.

Start the Display 3D operation and create a suitable georeference 3D with the
Georeference 3D editor (see above).

In the Display Options - 3D Grid dialog box:
n clear the Grid check box,
n select the Raster Drape check box,
n select the filtered Shadow map in the Raster Drape list box,
n press OK.
The 3D view appears in a map window.

Drag the segment map with the contour lines from the Catalog to the map window.
The Display Options - Segment Map dialog box appears.

In the Display Options - Segment Map dialog box:
n select single color, choose for example the color brown, press OK.

The Shadow map is displayed in three dimensions in the map window and the
segment map with the contours is overlayed on the 3D view.

Then, to save your 3D view (incl. contour lines),
n from the File menu in the map window , choose Save View.
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3. Lastly, to permanently display a raster map in as a 3D view, use the Apply 3D
operation. This operation resamples a raster map according to a georeference
3D. When you create a map list of raster maps that are the outcome of an Apply
3D operation (for instance depicting the same area in three dimensions but from
different angles), and display this map list as a slide show, you can obtain a
kind of rotating DEM with raster drape.

8.15.2 How to display map lists as a slide show
With Slide Show, you can display multiple raster maps that are combined in a map
list as a slide show in a map window. The maps of the map list are displayed one
after the other in the map window at a user-specified rate. A slide show is designed
to present multi-temporal changes in maps.

Raster maps that you can include in a map list for a slide show may be:
n satellite images of the same area of for instance different months,
n derived products from satellite images, such as NDVI maps, of for instance

different months,
n classified satellite images of for instance different months or years,
n thematic raster maps (e.g. land use maps) of for instance different years.

A slide show is in fact the same as repeatingly replacing raster maps in a map
window, e.g. by dragging raster maps from the Catalog one by one into a map
window.

To create a map list
The first step of making a slide show is to create a map list of all the raster maps
that you want to show. For more information, refer to How to create a map list.

To start a Slide Show
n from the File menu in the Main window, choose the Open command, or
n from the Operations menu in the Main window, choose Visualization, Slide

Show, or
n double-click the Slide Show item in the Operation-list.
Subsequently, select a map list in the Show Map List dialog box.

You can also:
n use the right mouse button on a map list in the Catalog and select Open from

the context-sensitive menu, or
n drag a map list from the Catalog to the Slide Show item in the Operation-list, or
n drag a map list to an existing map window.

A Display Options dialog box appears for the first raster map of the map list.
n specify the display options, these settings will be used for all the maps in the

list.

The Display Options - Map List dialog box appears.
n specify the number of maps you want to see per minute as the Refresh Rate.

The Slide Show will start after you press the OK button.
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F A map list can only be created of raster maps that have the same georeference and
the same domain.

F If the refresh rate is set to zero, it means that the maps will not be refreshed

automatically. To show the next slide, click the Redraw button  in the button
bar of the map window or press Ctrl+R on the keyboard.

F To stop the show, press Esc. To restart the show, press the Redraw button.
F When you create a map list of raster maps that are the outcome of the Apply 3D

operation (for instance depicting the same area in three dimensions but from
different angles), and display this map list as a slide show, you can obtain a kind of
rotating DEM with raster drape. For more information, refer to Display 3D and
Apply 3D.

See also: section 8.10.16 How to create a map list.

8.15.3 How to display maps and tables and zoom
For more information on How to display maps and tables and zoom, see section
8.1.1 How to display maps and tables and zoom.

8.15.4 How to display a map by one of its attributes
Raster, polygon, segment and point maps of the domain type Class or ID can have
an attribute table. The domain of the attribute table should be the same as the
domain of the map to which it relates. The domain is the link between the map and
the attribute table. Maps of domain type Value contain purely values; they cannot
have attributes. For more information on creating an attribute table, see How to
create a table.

When an attribute table is linked to a map and the map is displayed in a map
window, and you double-click in the map, the attributes of the Class or ID are
shown. Whether an attribute table is linked to a map can be inspected from the
properties dialog box of the map.

How to display a map by one of its attributes
n  Open the map, see How to display maps and tables and zoom

The Display Options dialog box appears.

n Select the Attribute check box,
n A list box that appear; select the attribute which you want to display.

See also: section 8.10.4 How to create an attribute map.
section 8.1.1 How to display maps and tables & zoom.
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8.16 How to drag and drop
The idea of drag and drop is that you can pick up an ILWIS object from the Catalog
and release it somewhere else, in order to perform a certain task without using any
menu or any typing. In a table window, you can use drag and drop to change the
order of columns.

1. Select for instance an ILWIS data object from the Catalog by pressing and
holding down the left mouse button, and

2. while holding down the left mouse button, move the mouse to a map window, a
pixel information window, an operation in the Operation-list, or a drop-down
list box in a dialog box (drag),

3. then release the left mouse button (drop).

To display two or more maps in one map window
n display a map in a map window,
n drag another point, segment, or polygon map or an annotation object from the

Catalog to the existing map window, and
n specify display options for the second map.
If you drag a raster map to a map window which already contains a raster map,
then the raster map will be replaced by the newly dragged one.

To add maps and attribute tables to the pixel information window
n display a map in a map window,
n open the Pixel Information window,
n drag one or more maps from the Catalog to the pixel info window,
n move with the mouse pointer over the map in the map window.
The values of all maps are displayed in the pixel information window. When a map
has an attribute table, also the attribute values are displayed.

To start an ILWIS operation with a certain map or table
n drag a data object from the Catalog to an operation in the Operation-list,
n the dialog box of the operation appears: the input map or table is already

selected.

To use a certain map or table name as input in a dialog box
n when a dialog box appears,
n drag an object from the Catalog into a drop-down list box in the dialog box.

To change the orders of columns in a table window
n drag a grey column name to another position.

To change the width of a column in a table window
n position the mouse pointer in between two column names,
n the mouse pointer changes into a double-sided arrow,
n drag to the left or right to decrease or increase the width of the left column.
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See also: section 8.36.1 How to use the Catalog.
section 8.36.6 How to use the Operation-list.
section 8.36.8 How to use pixel information.
section 8.36.2 How to use columns.

8.17 How to edit

8.17.1 How to edit a 3D-view
To define the perspective of the observer in relation to the 3D model, the view
parameters can be specified. When the Map Window is closed it saves the view
parameters, that are set in GeoRef 3D Editor.

To show (3D) georeferences in the Catalog, refer to Help topic: How to customize
the Catalog.

To edit the view parameters
From Main window:
n open the Edit menu in the Main window, choose Edit Object and select a 3D

georeference, or
n in the Operation-list, double click the Edit item, and select a 3D georeference,

or
n drag a georeference from the Catalog to the Edit item in the Operation-list.

 The Display Options - 3D Grid box will appear.

n Press OK and the Map window and GeoRef 3D Editor are opened.

From Map Window:
n  choose the Georeference command on the Edit menu in the map window.

The Georef 3D Editor is opened.

Note that the view parameters are not independent. Changing one of them causes
some others to be changed automatically. Changing the view point, horizontal
rotation, vertical rotation or distance, the location point and/or location height of
the observer change automatically, and vice versa.

It is important to notice that when you changed a parameter in the dialog box this
not immediately changes in the map viewer. Therefore you have to press the redraw
button in the button bar of the Map window to see the result.

8.17.2 How to edit annotation
Annotation can be edited in the Annotation editor.

To start the Annotation editor
The Annotation editor is automatically started when a new annotation layer is
added to a map window. For more information, see How to add annotation to a map
window.
To start the Annotation editor from a map window, open the Edit menu and choose
Annotation.
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To change the display options of existing annotation
Display options are specified in a Display Options dialog box.
When you are in the Annotation editor you can simply double-click an annotation
layer, except a grid line layer or a graticule layer. A Display Options dialog box
follows.

To change display options of grid lines or a graticule, or to change display options
when you are in a map window:
n from the Layers menu, choose Display Options and select an  annotation layer

from the cascading menu. A Display Options dialog box appears;
n select an annotation layer by clicking it, and press the ENTER key on the

keyboard. A Display Options dialog box follows;
or

n from the Layers menu, choose Layer Management. In the appearing Layer
Management dialog box, select an annotation layer and click the Display
Options button,

 or
n click the right mouse button in the map window from the context-sensitive

menu and choose Layer Management. The Layer Management dialog box
appears.

In the Layer Management dialog box, select an annotation layer and click the
button 'Display Options', or simply double-click an annotation layer. A Display
Options dialog box appears in which you can change the settings of the selected
layer.

To move annotation to a new position
n click an annotation 'object' with the left mouse button, and hold the left mouse

button down,
n drag the selected annotation 'object' to another location,
n then release the left mouse button.
Grid lines and a graticule depend on the georeference of the map window and can
only be positioned by changing their display options.

To size annotation
n select an annotation 'object' by clicking it: the borders of the annotation become

visible,
n position the mouse pointer on one of the 2, 4 or 8 size handles (little black

blocks appearing at  the annotation borders),
n drag the size handle to a new position.
Dragging one of the corner handles maintains the original ratio of height to width
ratio. Dragging one of the middle handles resizes the annotation horizontally or
vertically; the height to width ratio changes.

To save annotation
When finished editing annotation, you can save the map window as a map view.
In the Annotation editor or in the map window, open the File menu, and choose the
Save View command or the Save View As ... command.
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To exit the annotation editor
n double-click the Control-menu box, or

n in the button bar, click the Exit Editor button  , or
n choose from the File menu, choose Exit Editor.

F After editing annotation, you might need to redraw the map window: click the

Redraw button .
F To create more space in a map window for annotation, select the Extend Window

command from the Options menu. In the Annotation editor, you can also choose
Extend by Percentage or Extend by Coordinates from the context-sensitive menu.

8.17.3 How to edit the definition of dependent data objects
For more information on How to edit the definition of dependent data objects, see
section 8.7.1 How to change the definition of dependent data objects.

8.17.4 How to edit a domain
A domain is a set of class names, IDs, or values that can be used in a certain data
object. All ILWIS data objects have a domain. One domain can be used for several
data objects.

For a domain Class or ID, you might want to add new items to the domain, or you
might want to change the names of the classes or IDs. Editing a domain Value is
usually not necessary.

F When working with maps of different years but of the same theme, or containing
the same class names, IDs, or values, you are advised to create one domain for these
maps and use this domain for all maps. It is not necessary that every class name or
every ID of a domain is present in each map.

F To show domains in the Catalog, refer to: How to customize the Catalog.

To edit a domain
n double-click a domain in the Catalog, or
n click the right mouse button on a domain in the Catalog, and choose Edit from

the context-sensitive menu, or
n open the Edit menu in the Main window, choose Edit Object and select a

domain, or
n in the Operation-list, double-click the Edit item, and select a domain, or
n drag a domain from the Catalog to the Edit icon in the Operation-list.
When a map is of the domain Class or ID type, and the map is displayed in a map
window, you can also choose the Domain command on the Edit menu in a map
window.



How to...

562 ILWIS Reference Guide

For domain Class and ID: the Domain Class/ID editor follows in which
you can add class names or IDs to the domain,
etc.

For domain Value: an Edit Domain Value dialog box follows, the
value range and precision can be changed.

See also: section 8.10.10 How to create a domain.

8.17.5 How to edit a georeference
A georeference stores the relation between rows and columns of a raster map
(row,col) and coordinates (X,Y). A georeference is needed for raster maps. A
georeference uses a coordinate system.

There are basically three types of georeferences in ILWIS:
n georeference corners: for North-oriented maps;
n georeference tiepoints: for satellite images;
n georeference 3D: for a 3D view of your study area.

Further, you can have georeference None for raster maps without a georeference
(not advised) or a georeference SubMap or a georeference MirrorRotate. These last
two types of georeferences are output georeferences of the SubMap and
MirrorRotate operations respectively, and such georeferences belong to the output
maps produced by these operations.

F You can see the type of a georeference by viewing the properties of a georeference.
F To be able to calculate with raster maps, it is advised that raster maps of the same

area use the same georeference corners or the same georeference tiepoints.
F To show georeferences in the Catalog, refer to How to customize the Catalog.

To edit a georeference
n double-click a georeference in the Catalog, or
n click a georeference corners in the Catalog with the right mouse button, and

choose Open from the context-sensitive menu,
n open the Edit menu in the Main window, choose Edit Object and select any

georeference, or
n in the Operation-list, double-click the Edit item, and select any georeference, or
n drag any georeference from the Catalog to the Edit item in the Operation-list, or
n when a raster map is displayed in a map window, you can also choose the

Georeference command on the Edit menu in the map window.

Depending on the type of the georeference you selected (or on the type of the
georeference of the raster map in the map window):
n for georeference corners: the Edit Georeference Corners dialog box appears,
n for a georeference tiepoints: the Georeference Tiepoints editor is started,
n for a georeference 3D: the Display Options - 3D Grid dialog box appears, in
which you can specifying how the 3D view should be displayed in the map window.
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When the 3D view is displayed in a map window, you can select the Georeference
command from the Edit menu of the map window to edit the georeference 3D. The
Georeference 3D editor is started with the Georefence 3D editor : Edit dialog box.

8.17.6 How to edit map lists
A map list is a set of raster maps, for example the bands of a satellite image. All
raster maps in the map list must have the same domain and georeference.

To edit a map list
n from the Edit menu in the Main window, choose Edit object, select a map list,

or
n in the Catalog, double-click a map list, or
n in the Catalog, click the map list with the right mouse button and subsequently

choose Edit
n from the context-sensitive menu.
The Edit Map List dialog box follows; you can change the selection of raster maps
that are included in the map list.

8.17.7 How to edit maps
In a map window, map editors can be used to edit features of raster, polygon,
segment or point maps.
n In a raster map, the class names, IDs, or values of selected pixels can be edited;
n In a polygon map, new polygons can be inserted and existing ones can be

deleted, codes of polygons can be edited, the shape of a polygon boundary can
be changed and unnecessary polygon boundaries can be deleted;

n In a segment map, new segments can be inserted and existing ones can be
deleted, the codes of segments can be edited, and the shape of a segment can be
changed;

n In a point map, new points can be inserted and existing ones can be deleted, the
class names, IDs, or values of selected points can be edited, and points can be
moved to a new position.

You can use a digitizer but you can also use the mouse pointer.

To start a map editor
n in the Main window, open the Edit menu, choose Edit Object, and select a map,

or
n in the Operation-list, double-click the Edit item, and select a map, or
n in the Catalog, click with the right mouse button on a map and choose Edit

from the context-sensitive menu, or
n display a map in a map window, open the Edit menu in the map window,

choose Edit Layer, select the map layer you want to edit, or
n display a map in a map window, open the Edit menu in the map window,

choose Edit Other Map, and select the editor you want to use and the map you
want to edit.

When an editor is started, the mouse pointer appears as a hand.
In the editors, you can press F1 to obtain Help on that editor.
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8.17.8 How to edit objects
For more information on How to edit objects, see section 8.1.7 How to edit objects.

8.17.9 How to edit the properties of an object
For more information on How to edit the properties of an object, see section 8.38
How to view and edit the properties of an object.

8.17.10 How to edit a representation
A representation defines the manner in which classes of a domain Class map, or
values in a domain Value or domain Image map should be colored. For raster maps,
a representation contains merely colors; for segment, polygon and point maps there
are also possibilities to define for instance: line widths, patterns, and symbols.
Furthermore, a representation is needed for raster maps with a domain Picture. A
representation is a service object for a domain.

Maps with a Bool, the Bit or an ID domain do not have stored representations on
disk. For maps with a Bool or the Bit domain, you can select colors in the Display
Options dialog box of the map each time you display the map. Maps with an ID
domain can be shown in 7, 15, or 31 colors to inpect the map itself, however in
most cases you will display an ID map by one of its attributes from its attribute
table; the options are available in the Display Options dialog box.

Furthermore, special options for point symbols available in the Display Options
dialog box of a point map. Raster maps with the Color domain store colors in each
pixel, so no representation is needed.

F You can see the type of a representation by viewing the properties of a
representation.

F To show representations in the Catalog, refer to Help topic: How to customize the
Catalog.

To open and edit a representation
Choose one of the following methods:
n Double-click a representation in the Catalog;
n Click a representation in the Catalog with the right mouse button, and choose

Open from the context-sensitive menu;
n Open the Edit menu in the Main window, and choose Edit Object and select any

representation;
n In the Operation-list, double-click the Edit item, and select any representation;
n Drag any representation from the Catalog to the Edit item in the Operation-list;
n When a map is displayed in a map window, you can also choose the

Representation command on the Edit menu in the map window;
n In the Domain Class editor, open the Edit menu and choose Representation.

When a map with a class domain is displayed in a map window, you can also set
the Double-click Action to Representation, see below.
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Depending on the type of the representation you selected (or the type of the selected
representation of a map in a map window):
n For a representation class, the Representation Class editor is opened:

for each class in the class domain to which this representation fits, you can:
– select or create a color (raster form);
– select or create a color and select a pattern (polygon form);
– select or create a color and select a line width (segment form);
– select the symbol type, size, pen width, color and fill color (point form).

n For a representation value or gradual, the Representation Value/Gradual editor
is opened:
– insert limits, i.e. boundary values for a representation value, or percentages

for a representation gradual,
– choose or create a color for each limit,
– indicate whether to stretch colors between the limits or to use the color of the

upper of lower boundary (slice),
– when you stretch in between limits: the number of steps to be used for

stretching the colors.
For more information, refer to the respective editors.

To interactively change colors in a map
1. For maps with a class or group domain:

n Display the map in a map window; open the Layers menu, choose the
Double-Click Action command, and select the Edit Representation option;

n Then, double-click the units in the map: each time a Edit Repr Item dialog
boxes appears in which you can directly change colors, patterns, etc.;

n Redraw  the map window to apply the changes;
n Continue editing colors and redrawing the map until satisfied.

2. For maps with a class, group or value domain:
n Display a map with a class, group or value domain in a map window, open

the map's representation by selecting the Representation command on the
Edit menu in the map window;

n One of the representation editors appears, edit one or more colors;
n Keep the editor open and switch to the map window;
n Redraw the map window to apply the changes;
n Continue editing colors and redrawing the map until satisfied.

F You cannot edit a representation in this way when you displayed a value map in the
map window with a system representation like Gray, Pseudo, etc. In that case the
Representation command is grayed out on the Edit menu of the map window.
Instead, you can create a new representation: in the Display Options dialog box of

the map, click the create button  next to the Representation list box. The Create
Representation dialog box follows. 
n When the map uses the Image domain or a value domain which is not system

domain Value, you will create a representation value (which works on values);
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n When the map uses system domain Value, you will create a representation
gradual (which works on percentages).

After the Representation Value/Gradual editor is opened, you can interactively edit
the new representation as described above.

See also: section 8.10.18 How to create a representation.

8.17.11 How to edit an existing sample set
To perform an image classification, a sample set has to be created. Then, you can
sample training pixels: assign class names to groups of pixels with similar spectral
values and that are supposed to represent a known feature on the ground.

To open an existing sample set
n double-click an existing sample set in the Catalog, or
n from the Operations menu in the Main window, select Image Processing,

Sample, and select an existing sample set, or
n in the Operation-list, double-click Sample Map, and select an existing sample

set, or
n click the sample set with the right mouse button in the Catalog: choose Open

from the context-sensitive menu, or
n drag an existing sample set from the Catalog, to the Sample Map item in the

Operation-list, or
n from the File menu in the Main window, select Open, specify sample set for

object type, and select a sample set, or
n from the Edit menu in the Main window, select Edit object, specify sample set

for object type, and select a sample set.

F To show sample sets in the Catalog, refer to: How to customize the Catalog.

The Sample editor is started. There you can select more training pixels, inspect
statistics of classes of training pixels, inspect feature spaces, merge classes of
training pixels, etc.

8.17.12 How to edit a script
A script is a sequenced list of ILWIS expressions. By creating a script, you can
build a complete GIS or Remote Sensing analysis for your own research discipline.
Scripts are more or less equivalent to batch files in ILWIS version 1.4.

To edit a script
n Open the Edit menu in the Main window,
n choose Edit Object, and
n select a script,

or
n in the Catalog click a script with the right mouse button,
n then select Open from the context-sensitive menu.

The Edit Script dialog box appears in which you can edit your script expressions.
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F For more information on valid script expressions, see Appendices : ILWIS script
language (syntax).

F An example of a script is presented in Map & Table calculation : creating and
running scripts.

F To show scripts in the Catalog, refer to Help topic: How to customize the Catalog.

8.17.13 How to edit a table
A table displayed in a table window can be edited both in Table View and in
Record View. Only fields of source columns can be edited; you cannot edit fields of
dependent columns, fields of table-owned columns that store the results of a
calculation or an operation in a dependent table and fields of read-only columns.

In short:
n When a column uses a value or identifier domain, you can select a field by

clicking it with the mouse pointer and directly start typing.
n When a column uses a class domain, you can select a field, open the drop-down

list box and then select a class name from the list.

If a column is not wide enough to the contents of the fields, stars * appear. You can
enlarge the width of the column by dragging the right side of the column button to
the right.

Using the keyboard to move through fields of a table
If you want to edit many fields in a table, it is advised not to use the Enter key on
the keyboard, instead:
n to move downward or upward in the table to edit other fields, press the Down

Arrow or Up Arrow keys on the keyboard,
n to move to the right in a table to edit other fields, press the Tab key on the

keyboard,
n to move to the left in a table to edit other fields, press the Shift +Tab keys on the

keyboard.
Whenever you move to antoher field, the previously edited field is directly stored on
disk. You can stop editing by pressing Enter or Esc.

To edit columns using a value domain
n select a field in the column and type a new value.
If the value you typed does not fit in the value range of the column, the undefined
value is assigned represented by a question mark. Values are rounded so that fit the
precision of the column. To have column values displayed with more decimals or
less decimals, change the Decimals option in the Column Properties dialog box.

To edit columns using an ID domain
n select a field in the column and type a new value or a new Identifier.
If the ID you typed is not yet present in the domain of the column, a question is
asked whether this ID should be added to the domain.
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To edit columns using a class domain:
By mouse:
n select a field in the column,
n open the drop-down list box showing all class names of the domain and
n select a class name from the list.
By keyboard:
n select a field in the column,
n press the Left Arrow and Right Arrow key on the keyboard, to move up and

down in the drop-down list box with the classes,
n press the Down Arrow or Up Arrow keys on the keyboard, to move downward

or upward to another record in the column.

You can add a new class to the domain, by selecting the <new> item in the list.

To edit columns using the Bool or the Yes/No domain
A column which uses the Bool domain can contain the values True, False and ?
(undefined); a column which uses the Yes/No domain can contain the values Yes,
No and ? (undefined).
In a field of a column that uses the Bool or Yes/No domain:
n type T or Y or 1 to obtain a True value,
n type F or N or 0 to obtain a False value,
n type ? to obtain an undefined value,
n press the space bar to change True in False and vice versa.

To edit columns using the Color domain
Fields in a column that uses the Color domain can store colors as (Red, Green,
Blue) values. The minimum value for Red, Green, and Blue is 0; the maximum
value for Red, Green and Blue is 255.

(  0,  0,  0) represents black
(255,255,255) represents white
(255,  0,  0) represents red, etc.

If width of the column is not large enough to display Red, Green and Blue values,
the Red, Green and Blue values are shown in hexadecimal notation. You can
enlarge the column width of such a column to change the hexadecimal notation to
values between 0 and 255.

Editing dependent columns and table-owned columns in dependent tables
In principle, dependent columns and table-owned columns in dependent tables are
not editable in order to protect the results of a calculation or an operation. If you
need to edit fields of a dependent column, you first have to break the dependency
links of the dependent column through the Column Properties of that dependent
column. If you need to edit fields of a table-owned column in a dependent table, you
first have to break the dependency links of the dependent table through the
Properties of that dependent table.

There are many more keys on the keyboard that you can use in a table window. For
more information, see Appendices : keyboard shortcuts.
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8.17.14 How to edit two-dimensional tables
When you create a new two-dimensional table, it is directly displayed in a table
window where you can also directly edit it.

To display and to edit an existing 2-dimensional table
n from the Edit menu in the Main window, choose Edit Object and select a two-

dimensional table, or
n double-click a two-dimensional table in the Catalog, or
n use the right mouse button on a two-dimensional table in the Catalog, and select

Open from the context-sensitive menu.

A table window is opened which displays the two-dimensional table; you can edit
the two-dimensional table in the table window. For more information on editing
fields in a table, see section 8.17.13 How to edit a table.

F To show two-dimensional tables in the Catalog, refer to How to customize the
Catalog

8.17.15 How to edit user-defined linear filters
You can define your own linear filters or view the contents of a linear system filter.

To edit a user-defined linear filter
n from the Edit menu in the Main window, choose Edit Object and select a filter,

or
n use the right mouse button on a filter in the Catalog, and select Open from the

context-sensitive menu.

The Edit Filter dialog box appears.

F To show filters in the Catalog, refer to How to customize the Catalog.
F Linear system filters available in your ILWIS21\SYSTEM directory can be viewed

in the Edit Filter dialog box but not be edited.
F When you double-click a filter in the Catalog, the Filter operation is started with

the selected filter.

See also: section 8.10.13 How to create linear filters.

8.17.16 How to edit user-defined functions

To edit a user-defined function
n from the Edit menu in the Main window, choose Edit Object and select a

function, or
n in the Catalog, double-click a function, or
n use the right mouse button on a function in the Catalog, and select Open from

the context-sensitive menu
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The Edit Function dialog box appears.

F To show functions in the Catalog, refer to Help topic: How to customize the
Catalog.

See also: section 8.10.24 How to create user-defined functions.

8.18 How to export

8.18.1 How to export data
The operation Export enables you to convert files from ILWIS format to other
formats. Files can be exported using Export or Convert 1.4.
When you are exporting with Export, some formats are exported via Convert 1.4.
While converting,  an ms DOS icon then appears on the desktop (Windows 31) or
on the taskbar (Windows 95). These formats can also be exported using Convert
1.4. The difference between exporting these formats with Export or with Convert
1.4 is, that when using Export ILWIS automatically fills in the name of the export
file, etc. When exporting with Convert 1.4, you have to fill these in yourself.
There are also formats that can be exported using Export, which are not converted
via Convert 1.4. In some cases however, these can also be exported using Convert
1.4. This means that the export function has been improved under Export (e.g.
AutoCAD-DXF). We advise to export these formats with Export.
The formats that can only be exported using Convert 1.4, are either formats that no
longer have to be exported  (e.g. PostScript) or formats that are no longer widely
used today (e.g. LIP-file). You can still export these formats, using Convert 1.4.

Exporting with Export
1. Open the directory in the main window to which you want to export a file.
2. Open the Export dialog box:

n open the File menu of the main window and choose Export, or
n double-click the Export item in the Operations-list.

3. In the dialog box, select the directory from which you want to export and the
export format. This because the list displays only files of a certain  format. The
files with the format you have selected now appear in the File list.

4. Select the file you want to export.
5. Optionally, change the output file name, if you want it to be different from the

existing filename, which will be automatically filled in by ILWIS .
6. Click the ok button to start the conversion.

Exporting with Convert 1.4:
1. Open the directory in the main window to which you want to export a file.
2. Open the Convert 1.4 dialog box:

n double-click the Convert 1.4 item in the Operations-list.
3. Select one of the following operations:

n Raster Output: converts raster maps in the ilwis raster format to a number of
other formats. The name of the ilwis map, and of the output map are asked.
Optionally, some other questions may also be asked.
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n Vector Output: Converts vector maps in ILWIS format to vector maps in
several other formats.

n Table Output: Converts ILWIS tables to tables in several formats.

8.19 How to extract points from selected segments

Start the segment editor
Display your existing segment map in a map window, open the Edit menu, choose
Edit Layer and select the segment layer from the cascading menu.

Start the point editor
When you create a new point map, the point editor is automatically started. To edit
an existing map, display the point map in a map window, open the Edit menu,
choose Edit Layer and select the point layer from the cascading menu.

To extract points from selected segments
n activate the segment editor and the point editor next to each other on your

screen
n from the segment editor select one or more segments
n from the Edit menu in the segment editor select copy
n from the Edit menu of the point editor select paste

All points which are part of the selected segment(s) will appear in the point editor.

F  The point will get the code of the segment you have selected as first (codes can be
edited and changed). If this code does not exist in the domain of the point map,
ILWIS will ask whether you want to add this code to the domain.

8.20 How to import

8.20.1 How to import data from ILWIS 1.3, 1.4 or 1.41

Data from ILWIS 1.3, 1.4 or 1.41 can be imported into ILWIS for Windows. These
files can be imported with Import, Import 1.4 or Batch Import from 1.4. In the
remainder ILWIS 1.4 is used meaning ILWIS 1.3, 1.4 or 1.41.

Importing with Import
1. Open the directory in which you want to import a file in the ILWIS main

window.
2. Open the Import dialog box:

n open the File menu of the main window and choose Import, or
n double-click the Import item in the Operation-list.

3. In the dialog box, select the directory from which you want to import and the
import format. This because the list displays only files of a certain format. The
files with the format you have selected now appear in the File list.
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4. Select the file you want to import.
5. Optionally, change the Output Filename, if you want it to be different than the

imported filename, which will be automatically filled in by ILWIS.
6. Click the ok button to open the Import from version 1.4 dialog box.
7. In this dialog box:

n select the domain type. When selecting domain Class or ID, enter a name for
the domain object or accept the default domain name. The domain contains
the valid class names or IDs in one or more maps.

n for raster maps, Import assigns the same georeference to all maps of the
same area. When a georeference name is asked, enter a name indicating the
area.

n give a description for the file that you import. This descriptions appear in
the title bar when the imported objects are displayed.

n optionally, change the Output Filename or Output directory, if you want it to
be different than the previous changed filename or directory.

8. Click the ok button to start the conversion.

Importing with Import 1.4 or Batch Import from 1.4
1. Open the directory in which you want to import a file in the ILWIS main

window.
2. Open the Import from ILWIS 1.4 dialog box:

n open the File menu of the main window and choose Batch Import from 1.4,
or

n double-click the Import 1.4 item in the Operation-list.
3. In the dialog box, type as the mask the directory from which and the file

name(s) to be imported. By default all files in the current directory are
imported. Wildcards are allowed; to import for example all files that start with
'a', type as the mask: 'a*.* ' To import these files from another directory, for
example from drive 'a: ' directory “data”, type as the mask: 'a:\data\a*.*' Click
the ok button or press ENTER to open the Import from version 1.4 dialog box.

4. In this dialog box:
n select for each object to be imported the domain type. When selecting

domain Class or ID, enter a name for the domain object or accept the default
domain name. The domain contains the valid class names or IDs in one or
more maps.

n for raster maps, Import assigns the same georeference to all maps of the
same area. When a georeference name is asked, enter a name indicating the
area.

n give a description for each file that you import. This descriptions appear in
the title bar when the imported objects are displayed.

n optionally, change the Output Filename or Output directory, if you want it to
be different than the imported filename(s) or directory, which will be
automatically filled in by ILWIS.

5. Click the ok button to start the conversion.
When Import has finished you can start to display your maps, etc., see Help topic
Getting started with ILWIS 2.1.
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A conversion can have the following output:
n one or more maps, including a domain, representation and georeference,
n a table with one or more domain(s) and a representation. Because every column

of a table can have a domain, one table can have more domains.

The output domain names are equal to the name of the imported file. If there is
already a domain carrying that name, the domain name is slightly adjusted to be
unique.

F It is strongly advised to take the following paragraphs into account before starting
Import 1.4.

Importing satellite images
The .MPD and .MPI files of the satellite bands should be available. Any .HSB or
.COL files must be deleted. During Import 1.4, select domain Image for satellite
imagery.

Importing color composites
The .MPD, .MPI, and .COL  files of the color composite should be available. You
may need to save the color composite’s color look up table (.COL) in ILWIS 1.4;
give it the same name as the color composite. During Import 1.4, select domain
Picture for color composites.

Importing raster maps created from vector data, and attribute tables
For the raster data, vector data and attribute tables, select during Import 1.4:
n domain Class when the elements in the original  polygon, segment or point map

are named by class names (e.g. mapping units in thematic maps). The classes
may occur in various parts in the original polygon, segment or point map. The
.MPD, .MPI, .COL and .INF files should be available for domain Class raster
maps.

n domain ID, when the elements in the original polygon, segment or point map
are uniquely named (e.g. cadastral plots). The .MPD, .MPI, and .INF files
should be available for domain ID raster maps.

n domain Value when the elements in the original polygon, segment or point map
refer to measurable values (e.g. contour lines). The .MPD and .MPI files should
be available for domain Value raster maps.

When importing polygon maps that were rasterized, the .SEG, .CRD, .TOP and
.POL files should be available. All these files should have the same name: e.g.
LANDFORM.SEG, LANDFORM.CRD, LANDFORM.TOP, LANDFORM.POL. If
this is not the case:
n create a label point file for the polygon map (SegPol),
n polygonize in version 2 or 1.4,
n use CopySeg to copy those segments of which one polygon map should be

created,
n re-polygonize (SegPol),
n assign labels to the polygons (SegPol).
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When importing segment maps, the .SEG and .CRD files should be available.
When importing point maps: the .PNT should be available. There is no need for
.SLG, .PLG, .SGC or .PLC files.

Import of attribute tables works best when attribute tables have the same names as
the maps to which they relate. Attribute tables are expected to have the extension
.TBL. In case you have your attributes in an .INF or .PNT table, it is advised to
save these as .TBL as well. Attribute tables are expected to have a Name$ column.
Attribute table can only be linked to domain Class or domain ID maps, not to
domain Value maps.

Make sure that you select the same domain names for the vector data during import
as for the rasterized forms of these maps. Also, select the same domain names for
the attribute tables as for the maps to which they relate.

In ILWIS 2.1, polygonized segment maps are only imported as polygon maps. This
is correct:
display of polygon boundaries over a raster map in ILWIS 2.1 has the same effect
as displaying segments over a raster map in ILWIS 1.4.

Importing maps obtained through calculations
For maps containing measurable values, for example created by MCalc calculations
or by interpolations, the .MPD and .MPI files should be available. Any .HSB, .HSI
files can be deleted.  During Import 1.4, select domain Value. If you have a byte
map with a user-defined color lut, see the next paragraph.

Importing classified raster data
Byte maps containing classes are expected to have an .INF table with the class
names and a color lut .COL. Such maps may for instance be obtained by a classify
operation in MCalc using a classify table, or are output maps of an image
classification. However, when maps created through a classify table do not
automatically get an .INF table; it is advised to create one before Import 1.4. You
could do this in ILWIS 1.4 TabCalc: create a table with as many records as classes
in your map, add one column Name$, and type the meanings of your classes for
each record, save as .INF. Of course, the same can be obtained with an text editor.

As mentioned before, for Import 1.4 it is best when the .MPD, .MPI, .COL and
.INF files are available. It is also advised that the files have the same file name, e.g.
DISTCLAS.MPD, DISTCLAS.MPI, DISTCLAS.COL, and DISTCLAS.INF.
During Import 1.4, select domain Class.  Mind: if you do not make the effort to
create an .INF table beforehand, then select domain Class or ID during Import 1.4,
and edit this domain later yourself.

Importing other raster data
To import bit maps, the .MPD and .MPI files should be available. There is no need
for a .COL file. Bit maps are automatically imported with domain Bit. Scanned
raster data can be imported when the .MPD, .MPI are available. If the scanned data
consists of grey values, select domain Image during Import 1.4. If the scanned data
is in color, the .COL should also be available. Select domain Picture during Import
1.4.



How to...

ILWIS Reference Guide 575

Import of point tables
For point tables with a Name$ column, you can follow the instructions in paragraph
‘Importing raster maps created from vector data, and attribute tables’; select
domain Class or domain ID.  Point tables without a Name$ column are imported as
a domain ID map.

Importing vector data without raster data
Vector data will rarely occur without raster data. You can follow the instructions in
paragraph ‘Importing raster maps created from vector data, and attribute tables’.

Importing other tables
Tables without a Name$ column (.TBL or other extension) can be imported by
selecting domain None during Import 1.4. At the moment, Import 1.4 has no
facilities to import classify tables (.CLT) or 2-dimensional tables (.TB2).
Histograms from ILWIS 1.4 (.HSB, .HSI) can be deleted; they are recalculated in
ILWIS 2.1.

Batch files
Import of existing batch files is not possible.

8.20.2 How to import other formats
1. Open the directory in which you want to import a file in the ILWIS main

window.
2. Open the Import dialog box:

n open the File menu of the main window and choose Import, or
n double-click the Import item in the Operation-list.

3. In the dialog box, select the directory from which you want to import and the
import format. This because the list displays only files of a certain format. The
files with the format you have selected now appear in the File list.

4. Select the file you want to import.
5. Optionally, change the Output Filename, if you want it to be different than the

imported filename, which will be automatically filled in by ILWIS.
6. Click the ok button to start the conversion.

A conversion can have the following output
n one or more maps, including a domain, representation, coordinate system and

Georeference,
n a table with one or more domain(s) (and a representation). Because every

column of a table can have a domain, one table can have more domains.

The output domain names are equal to the name of the imported file. If there is
already a domain carrying that name, the domain name is slightly adjusted to be
unique.

See also: section 8.20.1 How to import data from ILWIS 1.3, 1.4 or 1.41.
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8.21 How to interpolate
Interpolations can be performed on domain Value segment maps, point maps and
raster maps. The following interpolation operations are available:

Contour interpolation
Contour interpolation first rasterizes a domain Value segment map, and then
calculates values for pixels that are not covered by segments by means of a linear
interpolation. Contour interpolation can be used to create digital elevation models
(DEM), also called a digital terrain models (DTM), or any other raster map
representation of a continuously changing variable.

Point interpolation
A point interpolation performs an interpolation on randomly distributed point
values (domain Value point map) and returns regularly distributed point values.
This is also known as gridding. In ILWIS, the output values are raster values.
Several interpolation methods are available: nearest point, moving average, trend
surface and moving surface. For the moving average and moving surface
operations, several weight functions are available. After a point interpolation,
Densify should be used to obtain finer grid values.

Densify
Densify performs a reduction of the pixel size of a raster map. The number of rows
and columns of the map are increased, and new values are assigned to the pixels by
means of nearest neighbour, or a bilinear or bicubic interpolation.

See also: section 8.5.3 How to calculate a Digital Elevation Model.

8.22 How to join

8.22.1 How to join areas from a histogram to an attribute table
Suppose you have a polygon map and a raster map Landuse with domain Landuse.
This map has an attribute table Landuse; the attribute table also uses domain
Landuse.

A histogram can be created both of the polygon map Landuse and of the raster map
Landuse; both histograms will contain a column Area which are the areas of all
classes in polygon map Landuse and raster map Landuse. The histograms use
domain Landuse which is the domain of the map.

To join the values Area from a polygon histogram to the attribute table
n open the attribute table,
n choose from the Columns menu in the Table window, command Join, and in the

dialog box:
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n select for Table: the polygon histogram  Landuse, and
n select for Column: Area which contains area values for the polygons,
n type a name for the output column, or accept the default name,
or
n type on the command line of the table window:

LandArea = Landuse.hsa.Area

To join the values Area from a raster histogram to the attribute table
n open the attribute table,
n choose from the Columns menu in the Table window, command Join, and in the

dialog box:
n select for Table: the raster histogram  Landuse, and
n select for Column: Area which contains area values for all pixels with the same

class name( or ID),
n type a name for the output column, or accept the default name,
or
n type on the command line of the table window:

LandArea = Landuse.his.Area

In the command line example:
Column LandArea is the new column in the attribute table,
Landuse.his is the histogram of map Landuse, it stores a column Area,
Area is the column in Landuse.his which you want to retrieve into the attribute
table.

The link between the histogram and the map is via the domain. As both the
attribute table and histogram of have the same domain, everything goes
automatically OK.

Histogram of raster map Landuse
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Attribute table Landuse with joined column LandArea

8.22.2 How to join columns from another table into a table
You may want to use information available in another table. Then it might be
useful to join the column from that other table into the current table. The join
operation enables you to do so.

To read a column from a second table and join it into the current table, you need a
link between the tables. This link is made via the domain of the tables or columns
in the tables. There are four possibilities:
1. The tables use the same domain.
2. A key column in the current table uses the same domain as the second table.
3. The current table uses the same domain as a column in the second table.
4. A key column in the current table uses the same domain as a column in the

second table.

To join a column into another table
Choose from the table menu: Column and then Join. The Join Column Dialog box
appears. You fill in the Table name in which you can find the column to join into
the current table and you specify the Column name. You may leave the option of
aggregating the column values on. If you want to aggregate the column values then
you also can specify the type of aggregation function and the column name
according to which you want to group the values. You also have the opportunity to
use weights while aggregating, then you choose the column name containing the
weight values. Finally you fill in the name of the output column and you click the
OK button.
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Examples of joining columns

1. The tables use the same domain
The column Area in the histogram table of the map landuse will be joined into the
attribute table landuse. Choose column and join from the table menu. Specify
Landuse.his as the table from which you want to join a column and select column
Area.

Landuse.tbt Landuse.his
Domain
Landuse

Comm
val

Domain
Landuse

Area

Residential 1000 Residential 9920800
Commercial 2000 Commercial 4131200
Industrial 5000 Industrial 2161600
Institutional 4000 Institutional 4918400
Agricultural 2000 Agricultural 10461600

Landuse.tbl after joining
Domain
Landuse

Comm
val

Area

Residential 1000 9920800
Commercial 2000 4131200
Industrial 5000 2161600
Institutional 4000 4918400
Agricultural 2000 10461600

The same result is obtained when you type the proper tabcalc formula  on the
command line in the table window. Then you use the following formula:

Area = ColumnJoin(Landuse.his.Area)

The joining of column Area  in the histogram table Landuse.his is done via the
domain Landuse which was the domain of both tables.

2. A key column in the current table uses the same domain as the second table
You can also use the domain of a key-column in the current table to make the link
to the second table. Choose again Columns and Join from the menu in the table
window. Specify from which table you want to join a column and you select that
column. You also specify the key column in the current table.
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3. The current table uses the same domain as a column in the second table
When the domain of your current table is the same as the domain of a column in
your second table you make the link as follows:
Start again with selecting Columns and Join from the menu in the table window.
Then select the second table used for the joining operation and the column that you
want to join into your current table. DO NOT select a key column in your current
table. In this way you use the domain of the current table and not the domain of one
of the columns in your current table. In your second table you select a key column
according which the data are grouped. When the column in the second table
contains values you may also want to perform aggregation operations. This is not
done in this example. Finally the output column name is per default the same name
as the name of the column that you want to join into the current table. If you want
to you may change it.

4. A key column in the current table uses the same domain as a column in the
second table

The last possibility is when you join a column into a the table via the corresponding
domains of columns in both of your tables. Start with the selection of Columns and
Join in the menu of your table window. Choose the table name which you want to
use and the column which you want to join into your current table. Then, select a
key column in your current table and a column in the second table to group your
data. Note that these two columns must have the same domain. You may choose to
perform aggregation operations but this can only be performed on values. The join
will take place as was described before. When an item of your key columns is
linked to several possibilities in the column you want to join into your current table,
then an undefined is the result.
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8.23 How to make dependent data objects up-to-date
Dependent maps, tables and columns are the result of a calculation with MapCalc
or TabCalc (in which you used the definition sign =) or the result of another
operation. The complete expression by which dependent output objects are created
is stored by the output maps, tables and columns as their definition. Dependent data
objects thus know how they were created and on which input data they depend.

Whenever you edit one of the input maps, tables or columns on which a dependent
object depends, it is obvious that also the dependent output objects need to be
updated, i.e. recalculated. In the Properties dialog box of dependent maps, tables
and columns, it is specified whether the current object is still up-to-date or not. If
not, you can press the Make Up-to-Date button in the Properties dialog box and the
dependent data object is redefined.
In fact, all dependent maps, tables and columns in between the current one and
your updated starting material are scanned and recalculated. There is thus no need
to completely redo all operations to obtain the dependent output again.

To make dependent maps and dependent tables up-to-date
n select a dependent raster, polygon, segment or point map or a dependent table in

the Catalog,
n press the right mouse button,
n choose Properties from the context-sensitive menu,

or
n open the Edit menu in the Main window,
n choose Properties,
n select a dependent map or table.

The Properties dialog box of the dependent map or table appears; click the button
Make Up to Date.

When a dependent map is displayed in a map window, or when a dependent table is
displayed in a table window, you can also open the Edit menu in the map or table
window and select the Properties command. The Properties dialog box of that map
or table then appears; to break the dependency links, click the button Make Up to
Date.
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To make dependent columns up-to-date
n open a table in a table window,
n double-click the column button (which displays the column name) of a

dependent column,
or

n from the Columns menu, choose Column Management, a dialog box appears in
which all columns are listed, then

n double-click a column in the list, or select a column in the list and click the
Properties button.

The Column Properties dialog box appears; click the button Make Up to Date.

To make dependent data objects up-to-date on the command line or in scripts
You can also make dependent maps and tables up-to-date by typing the following
on the command line in the Main window or in a script:

update object.ext

For 'object.ext' fill out the object name and extension. It is also allowed to use the
DOS wildcards * and ?.

To make dependent columns up-to-date, you can type:

updatecol table.ext.column

For table.ext.column fill out the table name (its extension in case it is not .TBT)
and the column name. It is not allowed to use the DOS wildcards.
For more information, see Appendices : script language (syntax).

8.24 How to open

8.24.1 How to open objects
For more information on How to open objects, see section 8.1.5 How to open
objects.

8.24.2 How to open the pixel information window
For more information on How to open the pixel information window, see section
8.1.6 How to open the pixel information window.
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8.25 How to open (advanced)

8.25.1 How to open internal domains/representations
Some operations create an internal domain for the output map of the operation. For
some operations this happens automatically; for other operations you can specify
whether to store the output domain as a separate object, or have the output domain
stored by the output map (internal domain).
When an internal Class domain or an internal Picture domain is created, then also
an internal representation is created. Internal representations are stored by the
output map and not as a separate object.
The software provides the possibility of using internal domains and internal
representations to reduce the number of domains and representations shown in the
Catalog.

Operations which always create an internal domain for the output map
n Cluster: Internal Class domain and internal representation. 

Domain items are named 'Cluster 1', 'Cluster 2', etc.
n Color Composite: When using the Dynamic/Heckbert option: internal 

Picture domain and internal representation.
n Glue Raster Maps: When merging two Pictures: internal Picture domain 

and internal representation.
n Polygons to Segments: When the input map has a Class domain: internal Class

domain (no representation), when the input map has an
ID domain: internal ID domain. Domain contains

either one item named 'Segments' or contains several items 
named 'neighbour1|neighbour2', 
'neighbour1|neighbour3' etc.

n Raster to Segments: When the input map has a Class domain: internal Class
domain and internal representation. When the input

map has an ID domain: internal ID domain. Domain
contains either one item 'Segments' or contains several items 

named 'neighbour1|neighbour2', 
'neighbour1|neighbour3' etc.

Operations which optionally create an internal domain for the output map
n Area Numbering: New ID domain or internal ID domain; domain items 

are named 'Area 1', 'Area 2', etc.
n Glue Raster Maps, When merging maps with different Class domains: new

Glue Segment Maps, Class domain or internal Class domain with internal
Glue Point Maps: representation. Output domain contains all class names

of all input maps.
When merging maps with different ID domains: new

ID domain or internal ID domain. Output domain contains
all IDs of all input maps.
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n Segments to Polygons: When not using the Label Points option in the 
operation's dialog box: internal ID domain.
When using the option Auto Identifiers option in the 
segment editor: internal ID domain. Domain items are 
named 'Pol 1', 'Pol 2', etc.

n Unique ID: New ID domain or internal ID domain; domain items 
are named 'Pol 1', 'Pol 2', etc. when performed on a 
polygon map, 'Seg 1', 'Seg 2', etc. when performed on a 
segment map, or 'Pnt 1', 'Pnt 2', etc. when performed on
a point map.

To view or edit an internal domain/representation
n Display the output map of the operation in a map window, open the Edit menu

in the map window and choose Domain or Representation.
n Click the output map of the operation with the right mouse button in the

Catalog, then choose Open as Domain or Open as Representation from the
context-sensitive menu.

You can display and edit internal domains and representations in the same way as
normal domains and representations. Internal domains/representations do not have
their own Properties dialog box and cannot be opened as a table.

8.25.2 How to open objects as a table
Some objects are internally stored as a table and can therefore be opened as a table.
Histograms and two-dimensional tables are automatically opened as a table, but you
can also open a point map, a class/ID domain, a class/picture representation, a
georeference tiepoints as a table.

The main idea behind opening these objects as a table is to allow the user to
perform calculations with TabCalc on or with the columns of the objects. A special
set of functions was designed to be able to calculate with XY-coordinate columns,
color columns, etc.

Examples
n by opening a point map as a table, you can perform calculations on the

coordinate columns which define the location of the points using special
Coordinate functions,

n by opening a domain as a table, you can perform calculations on the class names
or IDs of this domain with String functions,

n by opening a representation as a table, you can perform calculations on the
colors of this representation with special Color functions,

n by opening a georeference tiepoints, you can perform calculations on the
coordinate columns and the rows and columns which define the location of the
tiepoints, etc.

Opening point maps and class/picture representations as a table will look familiar
to ILWIS 1.4 users as in ILWIS 1.4 point maps and color look-up-tables were
stored as ASCII tables.
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To open objects as a table
n from the File menu in the Main window, choose the Open as Table command,
n the Open As Table dialog box appears, and select an object,

or
n click a point map, a class/ID domain, a class/picture representation, a

georeference tiepoints in the Catalog with the right mouse button and
n select Open As Table from the context-sensitive menu,

or
n on the command line of the Main window, type ShowAsTbl object.ext.

F The option Open As Table is designed for experienced users. Opening an object as
a table means that you can touch the object as it is stored on disk; you can see and
edit the binary data files of an object which are otherwise not readable in ASCII
now. Editing leads to changes with the risk of making an object unusable. Keep in
mind that names and codes of domain items should be unique and it is not advised
to edit the values in columns Ind and Ord of a domain as this can lead to serious
problems like missing domain items, wrong colors, wrongly linked attributes, etc.
Be wise and keep a backup of your data.

8.26 How to print

8.26.1 How to print maps and annotation
Before you can print in ILWIS for the first time, you must:
n Connect the printer to your computer or a network by following the instructions

in your printer manual.
n Install a printer driver by using Windows Setup or the Windows Control Panel.

For more information, see your Windows documentation.
n Select the printer you will use in the Printer Setup dialog box: from the map

window open the File menu and choose Printer Setup.

Display in a map window all map layers and annotation layers you want to print, or
open a map view.
To add more annotation, see How to add annotation to a map window.

Then from the map window:
n open the File menu,
n choose Print (or CTRL + P)

The Print dialog box follows. The contents of the current map window or the entire
map can either be printed on a certain scale or will be fit on an entire page.
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F To choose a printer, select the paper size and orientation, etc., see the Printer Setup
dialog box.

F In case you have specified a gamma factor during the setup of the printer, it is
advised to use gamma factor 1.0 in ILWIS in order to prevent a double color
correction.

F  To combine a map with a report, copy the map to the clipboard, you can easily
paste it into a text document, see Copy to clipboard.

8.26.2 How to print tables
Before you can print in ILWIS for the first time, you must:
n Connect the printer to your computer or a network by following the instructions

in your printer manual.
n Install a printer driver by using Windows Setup or the Windows Control Panel.

For more information, see your Windows documentation.
n Select the printer you will use in the Printer Setup dialog box: from the map

window open the File menu and choose Printer Setup.

A table is displayed in a table window. Each table window displays one table. A
table consists of columns, records and fields. You can open as many table windows
on your screen as you like.

To print a table
n display the table you want to print. See also: How to open maps and tables &

zoom,
n from the table window,
n open the File menu,
n choose the Print Table command.

The Print Table dialog box appears.
n select the columns which you want to print
n select the font
n press OK

F When you copy a table window to the clipboard, you can easily paste the table or a
selection into a text document, see Copy to clipboard.

See also: section 8.26.1 How to print maps and annotation.

8.26.3 How to print pixel information
The pixel information window allows you to interactively inspect class names, IDs
or values in multiple raster, polygon, segment and point maps with the same or a
compatible coordinate system. When one map is displayed in a map window, the
pixel information window will retrieve values of all maps added to the pixel
information window, at the position of the mouse pointer in the map window. In
the same way, when you have an analog map on the digitizer and you performed
MapReference, the pixel information window is capable of retrieving values of all
maps added to the pixel information window, at the position of the digitizer cursor.
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Before you can print in ILWIS for the first time, you must:
n Connect the printer to your computer or a network by following the instructions

in your printer manual.
n Install a printer driver by using Windows Setup or the Windows Control Panel.

For more information, see your Windows documentation.
n Select the printer you will use in the Printer Setup dialog box: from the map

window open the File menu and choose Printer Setup.

To print the pixel information window
n Open the pixel information window, see also How to open the pixel information

window.

The pixel information window appears.
n Add all maps and coordinate systems which you would like to print.
n Select Print from the File menu,  you can choose a font by pressing the font

button.

See also: section 8.36.8 How to use pixel information.

8.27 How to Rasterize

Points to raster
The Points to raster operation rasterizes a point map.

To rasterize a point map:
n from the Operations menu in the Main window, choose the Rasterize command

and select Point to Raster, or
n double-click the PntRas item in the Operation-list, or
n use the right mouse button on a polygon map in the Catalog and select Point to

Raster

The Rasterize Point Map dialog box appears.

F To analyze the surroundings of points, you can rasterize points with a point size
greater than one, and perform a Cross operation.

Segments to raster
The Segments to raster operation rasterizes a segment map.

To rasterize a segment map:
n from the Operations menu in the Main window, choose the Rasterize command

and select Segment to Raster, or
n double-click the SegRas item in the Operation-list, or
n use the right mouse button on a segment map in the Catalog and select Segment

to Raster

The Rasterize Segment Map dialog box appears.
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F to rasterize only segments with a specific code, you can first use the Mask segments
operation.

F when you want to print vector maps for annotation purposes on top of raster maps,
print quality will improve if you use the vector maps as they are, thus without
rasterizing them.

F to obtain frequency information on segments, you can calculate the histogram of
segment map with the Histogram operation.

Polygons to raster
The Polygons to raster operation rasterizes a polygon map.

To rasterize a polygon map:
n from the Operations menu in the Main window, choose the Rasterize command

and select Polygon to Raster, or
n double-click the PolRas item in the Operation-list, or
n use the right mouse button on a polygon map in the Catalog and select Polygon

to Raster

The Rasterize Polygon Map dialog box appears.

F to obtain frequency information on polygons, you can calculate the histogram of a
polygon map with the Histogram operation.

8.28 How to reference a map
Before you reference the map, make sure that the digitizer has been Setup.

To make a relation between digitizer coordinates and map coordinates, you have to
do a Map Reference. This can be done by specifying control points.
n First you have to select a coordinate system or create one using the create button

, and choose for metric coordinates or geographic coordinates. Make sure that
you select or create the same coordinate system as used by the paper map that
you want to digitize.

n Then you digitize the control points. The corresponding real world coordinates
should be entered, in order for the program to be able to calculate a
transformation between digitizer and real world coordinates. Points may well be
grid line intersections or triangular points; points of which the coordinates can
be determined accurately. A mathematically minimum of 3 points has to be
digitized, but to be able to correct possible input errors, a minimum of four
points should be digitized. An affine transformation, involving rotation and
scaling of the coordinates axes of the tablet, is carried out. The transformation
coefficients are displayed on the screen in order to check the result of the
transformation and to ascertain whether control points have been inserted
correctly. The value of sigma (in mm) is an indication of the accuracy of the
transformation, and should be small (dependent on the accuracy of the digitizer,
the accuracy of the map, map size etc.). A large sigma indicates an inaccurate
transformation.



How to...

ILWIS Reference Guide 589

To reference
n Place a map on your digitizer, find the coordinates that you want to use as

reference points.
n From the Main window in ILWIS, open the Options menu, choose Digitizer,

Map Reference.
n The first Map Reference (1) dialog box appears, select a coordinate system or

create one using the little create button , and choose for metric coordinates or
geographic coordinates. Click ok to continue.

n The second Map Reference (2) dialog box appears:
n click a reference point in the map with the digitizer cursor,
n to the left, the coordinates as received from the digitizer appear,
n to the right of these, type the XY-coordinate that belongs to this point as you

read it from the map on the digitizer (the map coordinates that you enter by the
keyboard should fall inside the selected coordinate system of step 3),

n continue with other reference points,
n check diffX and diffY values: for a good map reference, these figures should 

be between -0.3 and 0.3. This is the aberration (in mm) of the recorded
digitizer coordinate pair, compared to the calculated pair. When you normally
digitize, your aberration will be near these figures, because of distortions in the
map, accuracy of the map, etc. A larger aberration may be an indication that
this coordinate pair has been entered incorrectly.

n Click the ok button when finished.

These map reference settings are stored on disk. Whenever you continue digitizing,
and the map is still on the same position on the digitizing tablet, you do not need to
reference your map again.

8.29 How to release disk space
When creating dependent data objects through a calculation or another operation,
in principle only a small ASCII object definition file is stored on disk. The object
definition file stores among others the expression by which the dependent object
was created, this is the definition of the dependent object. Based on the definition, a
dependent data object can always recalculate itself.

Data files of dependent objects are automatically calculated when you display a
dependent map or a dependent table, i.e. when needed. Data files may need a lot of
disk space and as the definition of the object is stored in an object's object definition
file, data files may thus be deleted to obtain more free disk space. For dependent
raster maps for example, the data file (.MP#) can be deleted as long as the object
definition file (.MPR) remains.

You can release disk space for dependent raster, polygon, segment and point maps
and for dependent tables. You cannot release disk space for dependent columns.
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To release disk space
n select a dependent raster, polygon, segment or point map or a dependent table in

the Catalog,
n press the right mouse button,
n choose Properties from the context-sensitive menu,

or
n open the Edit menu in the Main window,
n choose Properties,
n select a dependent map or table.

The Properties dialog box of the dependent map or table appears; click the button
Release Disk Space.

When a dependent map is displayed in a map window, or when a dependent table is
displayed in a table window, you can also open the Edit menu in the map or table
window and select the Properties command. The Properties dialog box of that map
or table then appears; to break the dependency links, click the button Release Disk
Space.

To release disk space on the command line or in scripts
You can also release disk space by typing the following on the command line of the
Main window or in a script:

reldisksp object.ext

For object.ext fill out the object name and extension. For more information, see
Appendices : script language (syntax).

8.30 How to retrieve specific elements from maps

Point maps
The Mask Point operation allows you to selectively copy points into a new point
map. You have to specify a mask which lists the point classes, values or identifiers
that need to be copied to the new map; wildcards are allowed.

n from the Operations menu in the Main window, choose the Vector operations
command and select Points, Mask points, or

n double-click the MaskPnt item in the Operation-list, or
n use the right mouse button on a point map in the Catalog and select Vector

operations, Mask points from the context-sensitive menu

The Mask points dialog box appears.

You can also display specific points in a map window without creating a new point
map:
n use the right mouse button on a point map in the Catalog and select open

The Display Options - Points dialog box appears.
n select Mask
n in the box that appears, select the masks which specify the points you want to

display
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F To copy a certain area of a point map into a new map, see Sub-map of point maps.
F To combine two or more points, see Glue point maps.

Segment maps
The Mask Segment operation allows you to selectively copy segments of a segment
map into a new map. You have to specify a mask which lists the segment classes,
values or identifiers that need to be copied to the new map; wildcards are allowed.
n from the Operations menu in the Main window, choose the Vector operations

command and select Segments, Mask segments, or
n double-click the MaskSeg item in the Operation-list, or
n use the right mouse button on a point map in the Catalog and select Vector

operations, Mask segments from the context-sensitive menu

The Mask segments dialog box appears.

You can also display specific segments of a segment map in a map window without
creating a new segment map:
n use the right mouse button on a segment map in the Catalog and select open

The Display Options - Segments dialog box appears.
n select Mask
n in the box that appears, select the masks which specify the segments you want to

display, see also Mask segments: dialog box

F To copy a certain area of a segment map into a new segment map, see Sub-map of
segment map.

F To combine two or more segment maps, see Glue segment maps.

Polygon maps
The Mask Polygon operation allows you to selectively copy polygons of a polygon
map into a new polygon map. The user has to specify a mask which lists the
polygon classes, values or identifiers that need to be copied; wildcards are allowed.
n from the Operations menu in the Main window, choose the Vector operations

command and select Polygons, Mask polygons, or
n double-click the MaskPol item in the Operation-list, or
n use the right mouse button on a point map in the Catalog and select Vector

operations, Mask polygons from the context-sensitive menu

The Mask polygons dialog box appears.

You can also display specific polygons of a polygon map in a map window without
creating a new polygon map:
n use the right mouse button on a polygonmap in the Catalog and select open

The Display Options - Polygon dialog box appears.
n select Mask
n in the box that appears, select the masks which specify the polygons you want to

display, see also Mask polygons: dialog box
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8.31 How to run scripts

To run a script without parameters
n double-click the script in the Catalog

or
n type on the command line of the Main window:

run scriptname

or
n with the right mouse button, click a script in the Catalog and choose Run from

the context-sensitive menu.

To run a script which contains parameters
Type on the command line in the Main window:

run scriptname  parameter  parameter

Fill out script name and parameters. The first text string found after the script name
will replace %1 in the script, the second %2, etc. On the command line, script
parameters are entered without brackets and separated by spaces.

8.32 How to save

8.32.1 How to save annotation
Annotation layers in a map window can be stored together with the data layers in a
map window as a map view. When a map view is opened, the set of data and/or
annotation layers that it contains is directly displayed.

To use the same annotation in different maps, the best is to copy an annotation
layer from the annotation editor into the clipboard, and then paste this into another
map window.

To save annotation as a map view
n from the map window or from the Annotation editor:
n open the File menu,
n choose Save View or Save View As ... command.

If this is a new map view, the Save View As ... dialog box appears, in which you
can specify a name and a title for the map view.

8.32.2 How to save a map view
A set of data and annotation layers displayed in a map window can be saved as a
map view. When a map view is opened, the set of data and/or annotation layers that
it contains is directly displayed.

A map view contains the names of data layers and/or annotation layers to be
displayed in one map window. Also, the display settings of the layers are stored; so
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the system knows the colors, widths etc. for the display of each layer. Further, the
georeference is stored, meaning that when you save a map view when zoomed in on
a part of the map, this zoomed area will be displayed when opening the map view
later.

To save the contents of a map window from the map window or from the
Annotation editor
n open the File menu,
n choose Save View or Save View As ... command.
If this is a new map view, the Save View As ... dialog box appears, in which you
can specify a name and a title for the map view.

8.32.3 How to save raster maps
This command is designed to save changes in a displayed raster map. For example:
it is possible to drag a filter from the Catalog to an existing map window. After the
filter has finished, you can save the result in the map window with the Save Raster
Map as command.

From the map window:
n open the File menu,
n choose the Save Raster Map As command.

The Save Raster Map As dialog box appears.

See also: section 8.1.1 How to open maps and tables & zoom.

8.33 How to slice an image
You can slice an image interactively or permanently; follow the instructions below.

1. To slice an image interactively
n Double-click an image in the Catalog;
n In the appearing Display Options - Raster Map dialog box, click the create

button  next to the Representation list box;
n In the appearing Create Representation dialog box, type a name for your new

representation but do not change the domain listed in this dialog box;
n Click OK in the Create Representation dialog box. The Representation

Value/Gradual editor is opened;
n Then click OK in the Display Options - Raster Map dialog box. The image

is displayed in a map window;
n Click somewhere in the Representation Value/Gradual editor to make this

window the active window.

In the Representation Value/Gradual editor:
n Choose Insert Limit from the Edit menu or press Ins on the keyboard;
n In the appearing Insert Limit dialog box, type a value for the upper boundary

of a slice, e.g. 75, and assign a color to this limit;
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n Double-click a number of times in between two limits, and decide whether
the values in between the two limits in the image should use the color of the
upper limit or the lower limit; you can also stretch the colors in between two
limits;

n Double-click an existing limit to change its boundary value or its color;
n The color bar at the bottom of the editor gives an impression of how your

total representation looks like;
n Keep the editor open and switch to the map window.

In the map window:

n Click the Redraw  button  in the button bar to see the result of editing
the representation;

n Keep the map window open and switch to the editor.

In the Representation editor:
n Continue to insert limits, edit colors of limits, etc.;
n Keep the editor open and switch to the map window.

In the map window:
n Click the Redraw button in the button bar to see the result of editing the

representation.

Continue to switch between the Representation editor (to edit the representation)
and the map window (to redraw the map) until satisfied.

F All changes you make in the editor are immediately stored in the new
representation.

F Each time you open a map with the Image domain, you can select the new
representation.

F You can use this method of creating a new representation, editing colors and
redrawing the map for all maps that use a value domain.

2. To slice an image permanently
It is advised to first try the interactive method to get an idea where you want to
put your boundaries.
n Create a domain Group (Main window, File, Create) in which you fill in the

upper boundaries and the output class/group names, and, optionally, edit the
representation of this domain. For more information, refer to How to create
a domain Group;

n In the Main window, open the Operations menu, choose Image Processing,
Slicing; or in the Operation-list, double-click the Slicing operation. For
more information, refer to the Slicing operation.

n You can also use the CLFY function on the command line of the Main
window or in a MapCalc dialog box. For more information, see Map
calculation : classifying a map (CLFY function);

n Display the output raster map in a map window.
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To edit the representation of the output map
n In the map window, open the Edit menu and choose Representation;
n The Representation Class editor is opened: edit the colors of the classes as

you wish;
n Keep the editor open and switch to the map window;

n In the map window, click the Redraw  button .

You can continue switching to the Representation editor and back to the map
window to redraw the map until satisfied.

To change the boundary values on second thought
n You may keep the map window open;
n In the map window, open the Edit menu and choose Domain;
n The Domain Class/ID/Group editor is opened: edit the boundary values of

the groups, insert more groups, etc.;
n In the map window, open the Edit menu and choose Properties;
n In the appearing Properties dialog box, click the Make Up-to-Date button;
n A message appears asking for confirmation to recalculate the map, click

OK;

n When the calculation has finished, click the Redraw  button in the map
window.

8.34 How to set up

8.34.1 How to set up a digitizer and how to start digitizing

To set up a digitizer
1. First, connect all cables of the digitizer to the proper components and setup the

digitizer tablet itself. If you use a WinTab driver, select the WinTab device
driver in the first Setup Digitizer (1) dialog box (see Port Settings) to configure
your digitizer. Otherwise, be sure you make the digitizer work in Run mode
(sometimes called continuous mode) and send information in ASCII format;
note the Parity, DataBits, Resolution (lines per inch or per mm). For more
information, refer to your digitizer manual and Appendix ?? Settings for some
widely available digitizers.

2. Connect the digitizer to a serial port on your computer. Note the port number.
3. Start ILWIS:

n In the Main window, open the Options menu, choose Digitizer, Setup Digitizer.

Port Settings
n The first Setup Digitizer (1) dialog box appears in which you can select a serial

port to which your digitizer is connected, or you can select  the WinTab device
driver to configure your digitizer.

n Then, a message box appears which lists the communication settings of the
selected port (baud rate, parity, data bits, stop bits). If these settings are exactly
the same as the settings on your digitizer, press yes.
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n If any of the listed settings does not match the settings you used on your
digitizer tablet for baud rate, parity, data bits and stop bits, press no; the control
panel Ports will be started, so that you can change the settings..

n When you accept the port settings, the a second dialog box appears. If the
settings of the digitizer tablet itself and the settings of the port match, i.e. if you
have communication between your digitizer and the port, you should now see
coordinates as readable numbers that change when you move the digitizer
cursor on the digitizer tablet.

n If this is not the case, check the Setup of the digitizer tablet itself, and change
the port settings accordingly to the digitizer settings until you have
communication. If you do have communication, but not in readable numbers,
it’s most likely that you didn’t configure the digitizer in ASCII mode or that the
port settings are wrong. If so, reconfigure the digitizer in ASCII mode or
change the port settings.

Automatic Setup
When you do have good communication between the digitizer tablet and the serial
port, follow the instructions in the second dialog box for automatic setup. Press the
digitizer cursor buttons which you want to use as buttons 0, 1, 2 and 3 (Press the
button you want to use as 0 button, when asked Press Button 0, etc.). Remember
the sequence you have entered, because these are the buttons you have to press to
execute the command following a 0, 1, 2 or 3 in the different Digitizer Modes of
the editors. After you have entered the sequence, a new dialog box appears.

Manual Setup
If for some reason the automatic Setup doesn’t work, it’s also possible to do the
setup manual. Click the manual button in the second dialog box. You can now
enter the format and the flag codes in the third dialog box. These can be obtained
by analysing the received coordinates in the second dialog box. These contain the
amount of characters, the position and amount of the X and Y characters and the
flag codes. Move the cursor horizontally and vertically over the tablet to obtain X
and Y position. The flag codes can be obtained by pressing the cursor buttons
sequentially. The corresponding characters will show on the flag codes position.

For example, Received Coordinates:

03791,07676,0

Means:
Format: XXXX,YYYY,c (Format: X characters,Y characters,flag codes)
Flag Codes: 1248 (depending on the tablet you use)

And thus:
Nr chars: the amount of characters in the format is 11
X Pos: the start position of the first X character is 1
X Length: the amount of X characters of the format is 4
Y Pos: the start position of the first Y character is 6
Y Length: the amount of Y characters of the format is 4
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Flag Pos: the position of the flag codes is 11
Flag Codes: the flag codes are 1248

Note that all characters are counted as positions. You can also find the format and
flag codes in your digitizer manual. You now can enter the format and flag codes in
the third dialog box.

Check Setup
n The Setup Digitizer Size dialog box appears.
n In the upper part of this dialog box: check if all buttons work, and check

whether the X-values  increase by moving the digitizer cursor to the right, and
Y-values increase by moving the cursor up. If something is wrong, press
CANCEL to return to the second dialog box.

n Then, fill out the resolution (lines per inch or per mm) that the digitizer is using
and the size of the digitizer. Remember to enter the same resolution, as you
have configured on your digitizer. Check the feedback you obtain in the lower
part of the dialog box and make changes until satisfied.

You can now reference your map.

See also: section 8.28 How to reference a map.

8.34.2 How to set up a plotter
Provides a list of installed plotters, sets the default plotter, and provides access to
other plotter options for the plotter you select.

To set up your plotter
1. Connect the plotter to your computer or a network by following the instructions

in your plotter manual.
2. Configure your plotter using the plotters reference guide and/or the

configuration software and/or the plotters dip switches. For more information
about the configuration, see your plotters manual.
Configure the plotter for the following settings:
n Baud Rate: 9600.
n Data Bits: 8.
n Parity: None.
n Stop Bits: 1.
n Flow Control: Xon/Xoff.

F Note that these are just suggestions, plotters can often be configured for several
data formats.

3. Install the plotter driver by using Windows Setup or the Windows Control
Panel. For more information, see your Windows documentation.

 Open the Port Settings window in Windows (see your Windows
documentation), and select the port on which you have connected the plotter
and fill out the settings equal to the plotter configuration settings.

4. Dependent on your plotter, fill in different options such as paper size,
orientation etc. in the Windows Print Manager.
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Up till this stage, you do not need ILWIS yet!

6. Start ILWIS.
7. Open the Printer Setup dialog box

n Open the File menu of a graph window, table window or a map window, and
select the option Printer Setup.

8. Select the plotter.
9. Click the ok button to finish the setup, or the cancel button to return without

changes.

To print: see section 8.26.1How to print maps and annotation.

F If you connect the plotter to a port on which you previously had a digitizer
connected, make sure that the digitizer is inactive (no checkmark in front of the
active option in the options menu of the Ilwis main Window). When you connect
and configure the digitizer to another comport before connecting the plotter (and
start plotting), this is not necessary.

F We recomend not to plot under Windows, but to create a plot file and send this to
the plotter.

8.34.3 How to set up a printer
Provides a list of installed printers, sets the default printer, and provides access to
other printing options for the printer you select.

Set up your printer:
1. Connect the printer to your computer or a network by following the instructions

in your printer manual.
2. Install the printer driver by using Windows Setup or the Windows Control

Panel. For more information, see your Windows documentation.
3. Open the Printer Setup dialog box:

n open the File menu of a graph window, table window or a map window, and
select the option Printer Setup.

4. Fill out the following options:
n Default printer: Displays the name of the default printer and shows the

printer connection.
n Specific printer: Select the printer you want to use; ILWIS lists only printers

installed by using either Windows Setup or the Windows Control Panel. For
information about installing printers, see your Windows documentation.

n Orientation: Select the orientation of the paper in relation to the map(s) you
want to print:

n Portrait: Vertical paper orientation.
n Landscape: Horizontal paper orientation.
n Paper: Select the paper size and the source of the paper:
n Paper size: Select the paper size for the selected printer, for example A4 or

A3, or another paper size appearing in the drop-down list box. The paper
sizes that appear depend on the printer driver.



How to...

ILWIS Reference Guide 599

n Source: Select the paper source for the selected printer. The paper sources
that appear in the drop-down list box depend on the printer driver.

n Options button: Controls printer settings for the printer you select in the
Specific Printers list. The available options vary depending on the printer
driver. To get Help for the selected printer, choose the Options button, and
then choose the Help button.

n Network button: Connects your computer to a network printer. The Network
button is available only if your computer is connected to a network. To get
Help on network printers, choose the Network button, and then choose the
Help button.

5. Click the OK button to finish the setup, or the Cancel button to return without
changes.

To print, see section 8.26.1How to print maps and annotation.

F If you connect the printer to a port on which you previously had a digitizer
connected, make sure that the digitizer is inactive (no checkmark in front of the
active option in the options menu of the Ilwis main Window). When you connect
and configure the digitizer to another comport before connecting the printer (and
start printing), this is not necessary.

8.35 How to start operations
For more information on How to start operations, see section 8.1.3 How to start
operations.

8.36 How to use

8.36.1 How to use the Catalog
The Catalog is located at the right-central part of the Main window. It provides an
overview of ILWIS objects in the current directory. By default only data objects are
shown (maps and tables).
The Catalog is very sensitive to clicking, double-clicking and drag and drop
actions. You can use the Catalog for instance to display a map or table or to start an
operation with a certain map or table. Using the Catalog capabilities is generally far
more efficient than using menus.

To get more information on an object
Move the mouse pointer over an object in the Catalog, then the status line displays
the description of that object.

To see different object types in the Catalog
n from the Options menu in the Main window, choose the Catalog command,

or

n click the Customize Catalog button  in the button bar of the Main window.



How to...

600 ILWIS Reference Guide

In the Customize Catalog dialog box, you can select the object types that you want
to see in the Catalog (e.g. domains, representations etc.).

Double-click
When you double-click an object in the Catalog, the object is generally opened and
shown in a new window or shown in a dialog box.
n Double-click a map in the Catalog in order to display the map in new map

window;
n Double-click a table or a histogram in order to display the table or the histogram

in a table window, etc.

When double-clicking a filter, map list or script something else happens: double-
clicking a filter will start the Filter operation; double-clicking a map list will open
the Edit Map List dialog box; double-clicking a script will run the script without
parameters.

Drag from Catalog to map window
n Drag a polygon map, a segment map or a point map from the Catalog and drop

it into an existing map window in order to add that map as an extra data layer
to that map window.

n Drag a raster map from the Catalog and drop it into an existing map window
which does not yet contain a raster map in order to add the raster map as an
extra data layer to that map window. When the map window already contains a
raster map, the displayed one is replaced by the dragged raster map. For more
information, see also How to use layers in a map window.

n Drag a map list from the Catalog to a map window, and the map window will
display all maps in the map list as a slide show.

n Drag a georeference or a coordinate system which has for instance a different
projection, from the Catalog and drop it into a map window without a raster
map. If a conversion between both coordinate systems is possible, the map
window will show the maps using the dragged coordinate system.

Drag from Catalog to Operation-list
Drag a data object from the Catalog and drop it on an operation in the Operation-
list. The operation's dialog box appears in which the dragged object already filled
out as input.

Drag from Catalog to a dialog box
Drag an object from the Catalog to a drop-down list box in a dialog box in order to
select this object.

Drag from Catalog to Pixel info window
n Drag a point, segment, polygon or raster map from the Catalog to the pixel

information window. When an attribute table is linked to a map, this table is
displayed in the pixel info window as well.

n Drag a map list from the Catalog to the pixel information window in order to
add all raster maps in the map list to the pixel information window.
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n Drag a coordinate system which has for instance a different projection, from the
Catalog and drop it into the pixel info window.
If a conversion between both coordinate systems is possible, the pixel info
window will show coordinates in the dragged coordinate system.

Dragging within the Catalog
n Drag a georeference to a polygon, segment or point map or vice versa: the

appropriate Rasterize dialog box is opened in which both the Georeference and
the Input Map are already filled out.

n Drag a georeference to a raster map or vice versa: the Resample dialog box is
opened in which both the Georeference and the Input Raster Map are already
filled out.

n Drag a filter to a raster map or vice versa: the Filter dialog box is opened in
which both the Filter and the Input Raster Map are already filled out.

n Drag a coordinate system to a polygon, segment or point map or vice versa: the
appropriate Transform dialog box is opened in which both the Coordinate
System and the Input Map are already filled out.

Right mouse button
By clicking an object in the Catalog with the right mouse button, a context-
sensitive menu appears which contains all actions that can be performed on the
selected object.

Click an object in the Catalog with the right mouse button, and choose from the
context-sensitive menu:
n Open, to open the object;
n any operation, to start the selected operation with the selected object as input;
n Open As Table, to show a table, a class, ID or Picture domain, a representation

class or georeference tiepoints as a table (for advanced users);
n Open As Domain, for domains that are created by an operation and that are

stored by the output map of that operation (internal domains) and are thus not
stored as seperate objects, to open the internal domain;

n Open As Representation, for representations that are created by an operation
and are stored by the output map of that operation (internal representations) and
are thus not stored as seperate objects, to open the internal representation;

n Properties, to open the Properties dialog box of the object;
n Edit to open the object in an appropriate editor or open a dialog box in which

you can edit the object (dependent data objects cannot be edited);
n Copy or Delete, to copy or delete the object;
n Help to obtain a little Help popup on the selected object type.

8.36.2 How to use columns
A table is displayed in a table window. Each table window displays one table. A
table consists of columns, records and fields. You can open as many table windows
on your screen as you like.
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Grey areas in a table window are sensitive to clicking, double-clicking and drag-
and-drop actions. Column names in the table appear at the top of the table and are
in grey.

To add a column to a table
n From the Columns menu, choose Add Column, or
n From the Columns menu, choose Column Management; the Column

Management dialog box appears; click the button 'Add Column', or
n In the table, with the lower scroll bar, go to the right of the last column in the

table and click in the grey column area.

To delete a column from a table
n From the Columns menu, choose Column Management; the Column

Management dialog box appears; select a column on the dialog box and click
the button 'Delete Column', or

n In the table, select a column by clicking a column name, then choose Delete
from the Edit menu, or

n In the table, select a column by clicking a column name and press Del on the
keyboard. To select multiple columns, hold the Shift key down and select
columns.

At this moment, columns cannot be renamed.

To change column properties
n From the Columns menu, choose Column Management; the Column

Management dialog box appears; select a column on the dialog box and click
the button 'Properties', or

n In the table, double-click the grey area above a column.

The Column Properties dialog box appears in which you can fill out the position of
the column in the table, the column width and, in case of a Value column, the
number of decimals to be displayed.

To change the width of columns
n From the Columns menu, choose Column Management; the Column

Management dialog box appears; select a column on the dialog box and click
the button 'Properties', or

n In the table, double-click a column name, or
n In the table, drag the line which separates column names to the left or right.

The mouse pointer changes to a double-sided arrow when you are at the right
position to start dragging.

To change the order of columns
n From the Columns menu, choose Column Management; the Column

Management dialog box appears; select a column on the dialog box and drag it
to another position in the list, or

n In the table, drag a column name to another position in the grey area of column
names.
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To copy columns to the clipboard
To copy all columns and their contents into clipboard:
n from the Edit menu, select the Select All command, and
n from the Edit menu, choose Copy, or press CTRL+C on the keyboard.

or
n click the first and the last column of the table while holding the SHIFT key

down, and
n from the Edit menu, choose Copy, or press CTRL+C on the keyboard.

To copy one or more selected columns and their contents into clipboard:
n click a column name or  to select multiple columns hold the SHIFT key down,

or
n to copy only the contents of fields into clipboard and not column names:
n click the first field you want to copy, click the last field; and
n from the Edit menu, choose Copy, or press CTRL+C on the keyboard.

Use the Paste option in another Windows application to paste this selection into the
other application. To copy the whole table into clipboard inclusive the table window
borders, use the ALT+PRTSCR keys on the keyboard.

To paste something from the clipboard into a column
n use Edit, Paste.

8.36.3 How to use layers in a map window
A map window can display one or more data and annotation layers. A data layer is
a raster, polygon, segment or point map for which the user has specified display
options such as color, width, size, etc. for the display in a map window. An
annotation layer is a an annotation 'object' (texts, legends, boxes, North arrow, scale
bar, grid lines, graticule, bitmaps or pictures) for which the user has specified
display options for the display in a map window.

You may combine the display of several data and annotation objects in one map
window: one raster map and multiple point, segment and polygon and annotation
objects. When a second raster map is added to a map window which already
contains a raster map, the second raster map replaces the first. To view and/or
change display options of layers, use the Layers Menu of a map window. To save a
set of displayed layers, save the window as a map view.

To add extra data or annotation layers to a map window
n from the Layers Menu, choose Add Data Layer or Add Annotation, or
n from the Layers Menu, choose Layer Management, click the Add Map button or

the Add Annotation button in the dialog box, or
n drag an ILWIS data object from the Catalog to the existing map window.

To remove layers from a map window
n from the Layers Menu, choose Layer Management,
n the Layer Management dialog box appears with a list box containing all layers

in the map window,
n select a layer to be removed, and click the Remove button in the dialog box.
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To hide or show a layer in a map window
n from the Layers Menu, choose Layer Management,
n the Layer Management dialog box appears with a list box containing all layers

in the map window,
n select a layer and subsequently select the Show check box to show this layer in

the map window or clear the Show check box to hide this layer from the map
window.

To change the order of layers
n from the Layers Menu, choose Layer Management,
n the Layer Management dialog box appears listing all layers in the map window,
n drag a layer upward or downward in the list.
The layer at the top of the list appears as the top layer in the map window.

To change display options of a layer
n from the Layers Menu, choose Display Options, and select a layer from the

cascading menu, or
n from the Layers Menu, choose Layer Management. In the appearing Layer

Management dialog box, double-click a layer, or select a layer and click the
Display Options button, or

n from the context-sensitive menu (which appears when you click the right mouse
button in a map window), select a layer by clicking it.

A Display Options dialog box appears in which you can change e.g. color, line
width, etc. of the selected layer.

To activate Layer Info for data layers
You can obtain information on the contents of data layers by pressing the left
mouse button in map window. This is called 'layer info'. For raster maps, layer info
is activated by default. To activate layer info for other map types:
n from the Layers Menu, choose Display Options,
n choose a layer from the cascading menu;
n a Display Options dialog box appears;
n select the Info check box in this dialog box,

or
n click the right mouse button in a map window,
n choose a layer from the context-sensitive menu;
n a Display Options dialog box appears;
n select the Info check box in this dialog box,

or
n from the Layers Menu, choose Layer Management,

the Layer Management dialog box appears listing all layers in the map window;
n select a layer;
n select the Info check box to obtain info for this layer or clear the Info check box

if you want no info for this layer.
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To save multiple layers in a map window as a map view
Multiple data and annotation layers as currently displayed in a window can be
saved as a map view. When you open the map view later, all layers are directly
displayed without any display options being asked.
n from the File menu, choose Save View or Save View As.

The description you give for the map window will be visible in the title bar of the
map window.

8.36.4 How to use the Georeference Tiepoints editor
To insert tiepoints by using an existing map with coordinates (master/slave):
Display a map with correct XY coordinates in a map window (master). Open the
tiepoint editor with the image that you want to give tiepoints (slave). Make sure
that you can identify future tiepoints both in the image (row, col) and in the other
raster map with the correct coordinate system (XY coordinates). Then:
n click in the slave image,
n the Add Tie Point dialog box appears, the row and column values are filled out,

and
n click on the corresponding position in the master raster map,
n in the Add Tie Point dialog box, the X and Y coordinates are filled out as well,
n click OK.
Do the same for more tiepoints.

To insert tiepoints by using a map on a digitizer
Stick an analog paper map on the digitizer, setup the digitizer and reference the
map. For more information, see How to setup a digitizer and reference a map.
Start the tiepoint editor with the image that you want to give coordinates. Make
sure that you can identify future tiepoints both in the image and in the map on the
digitizer.

Then:
n click in the image,
n the Add Tie Point dialog box appears, the row and column values are filled out,

and
n click on the corresponding position in the map on the digitizer,
n in the Add Tie Point dialog box, the X and Y coordinates are filled out as well,
n click OK.
Do the same for more tiepoints.

To insert tiepoints by reading coordinates from paper
Start the tiepoint editor with the map that you want to give coordinates.

Then:
n in the tiepoint table, click on a grey record button,
n the Add TiePoint dialog box appears,

type for a Row and Column values and X and Y coordinates in the tiepoints
table, or
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n click with the mouse pointer in the tiepoint editor window on a recognisable
point,

n the Add Tie Point dialog box appears, the row and column values are filled out,
n type X and Y coordinates for this point,

or
n in the map window, press the right mouse button, select the Add Tiepoint

command on the context-sensitive menu and type Row, Column, X and Y
coordinates for the tiepoint.

8.36.5 How to use masks
By specifying a mask, you can search for points, segments or polygons with a
certain class name, ID or value. A mask is in fact a simple query to find (retrieve),
display or use only those points, segments or polygons in a map that have certain
class names, identifiers or values. A mask contains one or more search strings in
which wild cards, asterisks (*) and question marks (?), are allowed. You can enter
as many search strings in a mask as you like; separate the strings by commas.

When you specify a mask in the Display Options dialog box of a point, segment or
polygon map, then only those points, segments or polygons in the map of which the
class name, identifier or value matches one of the strings specified in the mask are
displayed in a map window.

Further, in many Vector Operations a mask can be used to selectively copy or use
points, segments or polygons with certain class names, identifiers or values from an
input map into an output map. Only those points, segments or polygons of the input
map of which the class name, identifier or value matches one of the strings listed in
the mask are copied to the output map.

Mask syntax
n search strings in a mask are compared with the classes, IDs or values of the

domain of a map; when a map uses a class or ID domain and the classes or IDs
have codes, the mask works on the codes and on the names and on the
combination of codes and names,

n to find/retrieve one specific class name, identifier or value: type that class name,
ID or identifier in the mask,

n to find/retrieve multiple class names, identifiers or values: separate the different
class names, identifiers or values in the mask by commas (it does not matter
whether you use spaces before or after a comma),

n you can use asterisks as wild cards to replace zero or more characters in class
names, IDs or values, for example road*,riv* or  1*,2*,3* , or even
*25,*50,*75,*00, or A*b*,D*g*

n you can use question marks as wild cards to replace single characters in class
names, identifiers or values, for example Ab?,D?,Gl? or ?p,??i, or A*b??,D*g??

n in a dialog box, you should not use quotes around class names, identifiers or
values,

n on the command line, you must use double quotes around the complete mask.



How to...

ILWIS Reference Guide 607

Example of using a mask on a map with a class domain
Consider the domain Landuse with its class codes as presented below.

Code Class Name
Fb Secondary forest, shrubland, bushland
Fp Primary forest
G Grazing
H Homestead gardens
P Fish ponds
Pi Paddy rice irrigated
Pr Paddy rice rainfed
Tu Tree crops and upland field crops
U Upland field crops
Ut Upland fields crops and tree crops
W Waterbody

Mask Retrieves
Fp Fp
Grazing G
upland* U, Ut
*tree* Tu, Ut
? G, H, P, U, W
*forest* Fb, Fp
F? Fb, Fp
F* Fb, Fp, P
*rice * Pi, Pr
P? Pi, Pr
P, P? P, Pi, Pr
P* P, Pi, Pr, Fb
*u* Tu, U, Ut, Fb

Example using a mask on a map with a value domain
Suppose you have a segment map with contour lines between 3000 and 4500m and
the segment map has a precision of 1.

Mask Retrieves
3000 contour lines with value 3000
3*,4000 all contour lines between 3000 and 4000m
30*,31* all contour lines between 3000 and 3199m
*00 all contour lines ending on 00, thus 3000, 3100, 3200, etc.

If the segment map uses a precision of 0.01 and you want to retrieve segments with
value 3000, you need to specify in the mask "3000.00". Similarly, to retrieve all
100m contour lines, use a mask of "*00.00".
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Another example to display contour lines
Suppose you have a segment map with contour lines between 3000 and 4500m, at
every 10m (precision of the map is 1). Goal: display the contour lines 3000, 3100,
3200, etc. in one color, and all contour lines with values like 3050, 3150, 3250, etc.
in another color and all remaining contour lines in another color.
n Display the segment map; do not use a mask.
 Specify one color and a line width of 1.
n Add the same segment map to this map window; use as mask: *00 and
 choose a color for these segments and a line width.
n Add the segment map again to this map window; use as mask: *50 and

choose another color and another line width for these segments.

8.36.6 How to use the Operation-list
The Operation-list provides an overview of ILWIS operations. The Operation-list is
located along the left side of the Main window.

As the Catalog, the Operation-list is very sensitive to clicking, double-clicking and
drag and drop actions. The Operation-list is mostly used to start operations
bypassing the Operation menu, or to create, show or edit objects. Using the
Operation-list capabilities is far more efficient than using menus.

To get more information on an operation
When moving the mouse pointer over an operation, the status line gives a brief
description of that operation.

To start an operation
Double-click the desired operation in the Operation-list.

To start an operation with a certain input map or table
Drag a map or table from the Catalog to an operation in the Operation-list.

8.36.7 How to use parameters in scripts
Parameters in a script can replace (parts of) object names, operations, etc.
Parameters in scripts work as DOS replaceable parameters in DOS batch files, and
must be written in the script as %1, %2, %3, up to %9.
The parameters of a script have to be filled out on the command line when you run
the script. The first text string found after the script name will replace %1 in the
script, etc.

Example 1
Suppose you have a segment map 'Contour' and an available georeference 'Geo'
with pixel size 20.

To obtain a slope map in degrees and a slope map in percentages, you can create a
script (e.g. Slopes) and type in the script text box:
%2 = MapInterpolContour(%1,geo)
%3 = MapFilter(%2, dfdx)
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%4 = MapFilter(%2, dfdy)
%6 = ((HYP(%3,%4))/%5)*100
%7 = RADDEG(ATAN(%6/100))

To run this script, type on the command line of the Main window:

run Slopes contour.seg dem.mpr DX DY 20 Slopepct
Slopedeg

In script 'Slopes', 'contour.seg' replaces %1, 'dem.mpr' replaces %2, 'DX' replaces
%3, 'DY' replaces %4, '20' replaces %5, 'SlopePct' replaces %6, and 'SlopeDeg'
replaces %7.

This script is more elaborately explained in MapCalc & TabCalc : creating and
running scripts. Of course, you could also specify the objects names and pixel size
in the script itself, thus creating a script without parameters.

Example 2
Suppose you have three landuse maps (LU70, LU80, and LU90) of different years
(1970, 1980, 1990). Each map has an attribute table linked to it (LUTBL70,
LUTBL80, LUTBL90), and each table contains a column YieldMainCrop.

To obtain attribute maps of all landuse maps, you can create a script (e.g. Yields)
and type in the script text box:

Yield%1=MapAttribute(LU%1, YieldMainCrop)

Yield%2=MapAttribute(LU%2, YieldMainCrop)

Yield%3=MapAttribute(LU%3, YieldMainCrop)

To run the script (e.g. called Yields), type on the command line of the Main
window:

run Yields 70 80 90

In script Yields, '70' replaces %1, '80' replaces %2 and '90' replaces %3. You thus
obtain three attribute maps (Yield70, Yield80, Yield90) from the three input maps
(LU70, LU80, LU90). Of course, you could also specify the years in the script itself,
thus creating a script without parameters.

8.36.8 How to use pixel information
The pixel information window allows you to interactively inspect class names, IDs
or values in multiple raster, polygon, segment and point maps with the same or a
compatible coordinate system. When one map is displayed in a map window, the
pixel information window is capable of retrieving values of all maps added to the
pixel info window, at the position of the mouse pointer in the map window. In the
same way, when you have an analog paper map on the digitizer and you performed
MapReference, the pixel information window is capable of retrieving values of all
maps added to the pixel info window, at the position of the digitizer cursor.
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General method to use Pixel Information
n Open the pixel info window by choosing the Open Pixel Information command

on the File menu of the Main window or a map window. You can also click the
Pixel Information button in the button bar of the Main window.

n Add maps to the pixel information window by choosing the Add Map command
on the File menu of the pixel info window. You can also drag maps from the
Catalog into the pixel info window. Raster maps as well as polygon, segment
and point maps can be added to the pixel information window. If an attribute
table is linked to a map or to the domain of a map, the attribute information is
shown as well. You can check whether an attribute table is linked to a  map or a
domain in the Properties dialog box of the map or the domain..

n Locate the mouse pointer on a map or locate the digitizer cursor on a reference
paper map on the digitizer.

To hide or show maps or attribute columns in the pixel info window
n from the Options menu, choose Customize, or
n click on the upper left grey area in the pixel info window.
The Customize Pixel Info dialog box appears which displays a list of maps, tables
and columns.By clicking in this list, maps and columns can be (de-)selected;
selected items appear highlighted and will be shown in the pixel info window.

Detailed pixel info by using the keyboard
To move the mouse pointer in the map window and see the result in the Pixel info
window, you can use the ARROW keys on the keyboard to move 1 screen pixel, or
use the CTRL+ARROW keys on the keyboard to move 10 screen pixels.

8.36.9 How to use the status line
The status line is located at the bottom of the Main window, a map window, a table
window, the pixel information window and in editors. The status line gives a brief
explanation on selected menu commands and on the functionality of buttons in a
button bar. Further, the status line may give additional information when the mouse
pointer is located in the Catalog, the Operation-list, a map window, a table window,
the pixel information window or an editor.

Information on menu commands
Highlight a menu command by opening a menu and drag the mouse pointer along
the commands on the menu; the status line displays information that helps explain
the task of the highlighted menu command. You can also use the UP ARROW and
DOWN ARROW keys on the keyboard to move through the commands on a menu.

Information on buttons in the button bar
Move the mouse pointer over a button in a button bar; the status line gives a short
explanation of the function of the button.
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Information on objects and operations
When you move with the mouse pointer over an object in the Catalog or over an
operation in the Operation-list, the status line shows the description of the object or
operation.

Information on coordinates and row and column numbers in a map window
When you move with the mouse pointer in a map window, X and Y coordinates are
displayed on the status line. When a raster map is displayed in a map window, the
row and column numbers appear as well.

Hide or Show the status line
You can hide the status line by opening an Options menu and selecting the
command Status Line. The check mark (√ ) to the left of the command Status Line
disappears, and the status line will no longer appear in your window. When you
choose this command again, the check mark and the status line  will reappear.

8.37 How to vectorize
Vectorize includes:
n Raster to vector operations which create vector data format such as polygon,

segment and point maps from a raster map, and
n conversions between vector data format.

Raster to vector operations

Raster to polygon
The Raster to polygon operation extracts polygons from units in a raster map.
This operation can be useful to polygonize classified images or scanned paper
maps. Only homogeneous raster maps consisting of areas with a considerable
number of pixels should be converted. When for example polygons are extracted
from a classified raster map, it can be useful first to run the majority filter on the
classification in raster form to homogenize the classification.

To polygonize a raster map
n from the Operations menu in the Main window, choose the Vectorize command

and select Raster to Polygon, or
n double-click the RasPol item in the Operation-list, or
n use the right mouse button on a raster map in the Catalog and select Raster to

Polygon.

The Polygons of Raster Map dialog box appears.

F If you only want to extract polygons from a small part of your raster map, you can
first create a Submap of the raster map and then extract polygons from the raster
submap.
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Raster to segment
The Raster to segment operation extracts segments from mapping unit boundaries
in a raster map.

To extract segments of a raster map
n from the Operations menu in the Main window, choose the Vectorize command

and select Raster to Segments, or
n double-click the RasSeg item in the Operation-list, or
n use the right mouse button on a raster map in the Catalog and select Raster to

Segment.

The Segments of Raster Map dialog box appears.

F If you only want to extract segments from a small part of your raster map, you can
first create a Submap of the raster map and then extract segments from the raster
submap.

Raster to point
The Raster to points operation extracts a point from each pixel in the raster map.
Each point gets the value, class name or ID of the corresponding pixel. No points
are created for pixels with the undefined value. Note that it is only useful for raster
maps with a relative small amount of defined values.

To extract points of a raster map
n from the Operations menu in the Main window, choose the Vectorize command

and select Raster to Point, or
n double-click the RasPnt item in the Operation-list, or
n use the right mouse button on a raster map in the Catalog and select Raster to

Point.

The Points of Raster Map dialog box appears.

F To temporarily view pixel values as text in a map window, you can select the Text
check box in the Display Options dialog box of a raster map.

Conversions between vector data formats

Polygon to segment
The Polygon to segment operation extract segments from polygon boundaries of a
polygon map.

To extract segments of a polygon map
n from the Operations menu in the Main window, choose the Vectorize command

and select Polygon to Segment, or
n double-click the PolSeg item in the Operation-list, or
n use the right mouse button on a raster map in the Catalog and select Polygon to

Segment.

The Boundaries of Polygons dialog box appears.
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F Another way to extract segments from polygon boundaries of a polygon map is by
using the option Extract segments in the Polygon editor.

Polygons to points
The Polygon to point operation creates a point from each polygon in the polygon
map.

To create points of a polygon map
n from the Operations menu in the Main window, choose the Vectorize command

and select Polygon to Point, or
n double-click the PolPnt item in the Operation-list, or
n use the right mouse button on a raster map in the Catalog and select Polygon to

Point.

The Polygons to Points dialog box appears.

F Another way to create points of  polygons is by using the option Create Labels in
the Polygon editor.

F By creating polygon label points, you can easily display polygon names on top of
the polygon map. First display the polygon map, then display the label point map in
the same map window; select the Text check box in the Display Options dialog box
of the point map.

F When you are not satisfied with the position of a label point, display the polygon
boundaries and the label points in the same map window, break the dependency
link of the point map, and use the Point editor to move a label point to another
position. This can be useful when you want to use it as annotation.

Segment to polygon
The Segment to polygon operation polygonizes a segment map.

To polygonize a segment map
n from the Operations menu in the Main window, choose the Vectorize command

and select Segment to Polygon, or
n double-click the SegPol item in the Operation-list, or
n use the right mouse button on a raster map in the Catalog and select Segment to

Polygon.

The Polygonize Segment Map dialog box appears.

F Before performing the operation it can be useful to check on whether the segments
have been correctly digitized. Cleaning the segments can be done using the Clean
Segments operation to remove double segments from a segment map and insert
nodes where these are required. It can also be done in the Segment editor with the
option Check Segments and Polygonize. See also Check Segments. In this way you
can have more control over the ‘cleaning process’.
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Segment to points
The Segments to points operation creates a point map from a segment map.
This operation can be useful to make a cross-section of (one of) the segments. In the
output point map you can add information on the altitude along the cross-section.
See also Calculation on coordinates (example of calculating a cross-section).

To extract points from a segment map
n from the Operations menu in the Main window, choose the Vectorize command

and select Segment to Points, or
n double-click the SegPnt item in the Operation-list, or
n use the right mouse button on a raster map in the Catalog and select Segment to

Point.

The Segment to Points dialog box appears.

8.38 How to view and edit the properties of an object
The properties of a map, table or column or any other ILWIS object shows you
important information on the object. In fact, an object's Properties dialog box lists
the information that is stored in an object's object definition file and that is relevant
to the user.

Viewing the properties of an object may be very useful. You can see for instance the
date and time and the description of the object, which other objects the current
object is using (e.g. for raster maps the domain and georeference) and whether an
attribute table is linked to a map or a domain. The properties dialog box also shows
whether the object is dependent or not, and whether a dependent object is up-to-
date or not. Furthermore, you can easily update objects when they are not up-to-date
any more, you can change the definition of calculated maps and calculated
columns, break dependencies, etc. For more information, see Basic concepts :
properties of objects.

Viewing properties of objects

To view the properties of an object (except columns)
n click an object in the Catalog with the right mouse button, and choose

Properties from the context-sensitive menu, or
n from the Edit menu in the Main window, choose Edit Properties, and select an

object.

Other methods are:
n for maps displayed in a map window, open the Edit menu of the map window,

and choose Properties
n for a table displayed in a table window, open the Edit menu in the table window

and choose Properties
n for domains Class or ID displayed in the Domain Class/ID editor, open the Edit

menu in the domain Class/ID editor and choose Properties
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n for representations displayed in the Representation Class editor or
Representation Value editor, open the Edit menu in the Representation Class
editor or the Edit menu in the Representation Value editor window and choose
Properties.

The Properties dialog box of the selected object appears.

To view the properties of column s in a table
n open a table in a table window, and double-click a column button (which

displays a column name), or
n from the Columns menu in a table window, choose Column Management, the

Column Management dialog box appears, select a column in the list box and
click the Properties button.

The Column Properties dialog box of the selected column appears.

Handling properties of objects
n The Description of an object can always be changed.
n An Attribute table can always be linked to a raster, polygon, segment or point

maps with a class or ID domain or to a class or ID domain itself.
n The Used By button can always be pressed to see by which other objects the

current object is used.
n An object can always be made read-only or not.
n For columns that are the result of a calculation (ColumnCalculate), the

calculation formula or expression used to create the column can be changed.

For dependent maps, tables and columns, the most important features of a
properties dialog box are invoked by pressing one of the following buttons that may
appear in your Properties dialog box: Make Up-to-Date, Edit Definition, Break
Dependency Link, Release Disk Space, Calculate.

Make Up-to-Date
For dependent data objects of which the input data has changed: click this button to
redefine the dependent output object.

See also: section 8.23 How to make dependent data objects up-to-date.

Edit Definition
For dependent raster maps that are the result of a map calculation (MapCalculate),
click this button to modify the map calculation formula by which this map was
created. The definition of  a dependent column that is the result of a table
calculation (ColumnCalculate), can be directly edited in the Properties dialog box
of the column.
See also How to change the definition of a dependent data object.

Break Dependency Link
For dependent data objects: click this button to break the dependency links between
the current dependent object and the objects it depends on. After breaking
dependency links of a dependent map, table or column, the map, table, or column
becomes editable. See also How to break dependency links.
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Release Disk Space
For dependent data objects with a calculated data file: click this button to delete
calculated data files. Only the object definition file that contains the expression by
which the object is defined remains. See also How to release disk space.

Calculate
For dependent data objects without a calculated data file: click this button to
execute the expression by which this object was created and store the calculated
data file on disk.

Editing properties of non-dependent objects
For non-dependent objects, relations to other objects may be changed. You can for
instance link another default representation to a domain, another georeference to a
raster map, or link another coordinate system to a vector map, or change the
domain of an object. Editing Properties through the Edit Properties button is
something for the more experienced user. Especially changing the domain of an
object is only necessary in very specific cases and should never be done without a
backup of your original map.

To edit the properties of a non-dependent object
n open the Properties dialog box of an object as described above,
n click the Edit Properties button.

The Edit Properties dialog box of the selected object will appear. In this dialog box,
you can change the links to objects that the current object uses, such as domain,
georeference, etc.

8.39 How to zoom in on maps
For more information on How to zoom in on maps, see section 8.1.2 How to zoom
in on maps.






